WordPress.org

Ready to get started?Download WordPress

Forums

vSlider Multi Image Slider for WordPress
[resolved] Fatal Error after updating to vSlider 4.2 (24 posts)

  1. AustBest
    Member
    Posted 1 year ago #

    Help! - a client's site has suddenly come down with a fatal error after I just updated to vSlider 4.2

    Fatal error: Call to a member function generate_theme() on a non-object in /[...directory path]/public_html/wp-content/plugins/vslider/vslider.php on line 59

    (The "[...directory path]" was substituted in this message as it contains the WP username)

    In the meantime, I will try to re-install the plugin. I have very little PHP knowledge to troubleshoot the error.

    I hope some knowledgeable kind soul knows what the problem is and can offer some suggestions. I've placed the site into "Maintenance Mode" for the time being.

    http://wordpress.org/extend/plugins/vslider/

  2. AustBest
    Member
    Posted 1 year ago #

    More information: When I go to the vSlider settings in the left sidebar, I just see a button saying "Upgrade to vSlider 4.2"

    Perhaps the regular update didn't complete properly?

    At any rate, clicking on the button doesn't do anything.

  3. AustBest
    Member
    Posted 1 year ago #

    Update: I've tried deactivating it, then activating it again, and was given an option to "Migrate to 4.2" which I did.

    The website now loads up without showing errors, but the slides are blank.

    The data appears to be in the settings, but right now, I'm trying to figure out how to get the slides to display again...

  4. AustBest
    Member
    Posted 1 year ago #

    Previously, there was an option to Activate or Deactivate a particular slider. Is there an equivalent option in this version? I'm having difficulty finding it.

  5. Ashley Michèlle
    Member
    Posted 1 year ago #

    I am having the same problem! My images are also not appearing within the slides, where they did on the previous version of vSlider...

    http://nwimt.com

    The big blue space should be a featured post image slider!

  6. AustBest
    Member
    Posted 1 year ago #

    Hi Ashley, I see one big image there. Is it meant to show more or are you still trying to tweak it?

    Right now, I'm attempting to delete the whole plugin and re-install the older version 4.1.1 which worked a bit, but not displaying the slides properly!

  7. davidmoulton
    Member
    Posted 1 year ago #

    Same problem here. Thankfully, was able to roll back to previous version.

  8. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    Please deactivate and reactivate the plugin. It should resolve these issues.

  9. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    http://nwimt.com : The vslider haven;t migrated properly, please deactivate and reactivate your plugin from Dashboard->plugins panel

  10. anaeme
    Member
    Posted 1 year ago #

    Deactivate and reactivate is not working for me. Other workaround?

  11. AustBest
    Member
    Posted 1 year ago #

    I managed to re-install 4.1.1 and set it all up again.

    I'll stick to this for a while and see what happens with 4.2.

    Otherwise, I think it's a great plugin and I'm really grateful to Mr. Vibe not only for writing it but taking time out to respond to support requests.

    Thank you very much!

  12. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    I checked again, the vslider on your site is using older files. the site is using older vslider.js file. So you'll have to deactivate and delete and then install and activate the plugin.

  13. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    @anaeme: did this work?

  14. anaeme
    Member
    Posted 1 year ago #

    I have to delete the whole plugin and re install it?

    The slider is working on my site, but I'm still having problems. When I clicked "Save settings" the changes that I made were reverted... and the navigation buttons disappeared... (apologize for my English...)

  15. anaeme
    Member
    Posted 1 year ago #

    didn't work... I'm not able to change the settings...

  16. sunrise1
    Member
    Posted 1 year ago #

    Dear Mr. Vibe. I just update a newer version and I have exactly the same problem.

    The whole website is not working by now and it shows:
    Fatal error: Call to a member function generate_theme() on a non-object in /homepages/6/d380626310/htdocs/wsb6520773201/wp-content/plugins/vslider/vslider.php on line 59

    Could you please help me with that.

    Thank you.

  17. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    @sunrise, please send me your website link at vibethemes at gmail dot com

  18. MarkFokkema
    Member
    Posted 1 year ago #

    I also have this problem since I updated today. The area is blank. I deleted the old version, installed the new one and upgraded to 4.2.0.

  19. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    @anaeme, I an not sure, your site still shows [http://nwimt.com/]still shows older version of vslider.
    I think there's some issue while you;re upgrading the plugin. I'll suggest you to download and then install the plugin.

  20. anaeme
    Member
    Posted 1 year ago #

    But this is not my site. I've already delete and reinstall de plugin, and I'm having the same issue regarding settings and navigation buttons.

  21. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    I've sent replies to @anaeme, @markfokkema, @sunrise, Please update me on mail, I will post the solution back here.

  22. MarkFokkema
    Member
    Posted 1 year ago #

    Thank you Mr. Vibe. I did something wrong with the code myself. It works again.

    Kind regards,
    Mark Fokkema

  23. Ashley Michèlle
    Member
    Posted 1 year ago #

    I just went back to an older version of vSlider (http://nwimt.com) because upgrading - even after following all of the proper steps - was not working for me.

  24. Mr. Vibe
    Member
    Plugin Author

    Posted 1 year ago #

    Please Upgrade to latest version 5.0.0.

    In case you have any issues, please post then here: http://vibethemes.com/forums/forumdisplay.php?30-vSlider

    Note: We've removed Timthumb.php and migrated from coin slider to responsive Flexslider 2.0. In case you loose your slides, Try out the new vSlider Slide Generator, you'll get back your slides in matter of seconds.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.