WordPress.org

Ready to get started?Download WordPress

Forums

Volusion
[resolved] Settings not configured properly (19 posts)

  1. kristingcs
    Member
    Posted 3 years ago #

    Ive setup the API correctly, but Im getting an error that it is not setup correctly. However the link to the XML product listing is generating data and the link to my store is correct. Any suggestions?

    http://wordpress.org/extend/plugins/volusion/

  2. joshuaiz
    Member
    Posted 3 years ago #

    Getting the same error but my link and API is configured correctly.

    Has anyone gotten this plugin to work?

  3. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    So both of you can see the product text at http://YOURSTOREURL.COM/net/webservice.aspx?api_name=generic\all_products ?

    If so, then your hosting may not have support for the function simplexml_load_string() - check with them to make sure that function is supported.

  4. smbutler79
    Member
    Posted 3 years ago #

    I can't get it to work either. I know my API is set up correctly as it feeds just fine with my Facebook page that has the Volusion Social Store integrated. I talked with Volusion and they said the above mentioned function was a PHP-based function that won't run on Volusion. Why can't this just work??

    I can see my site and the XML information in WordPress.

  5. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    I have released Version 1.1.2, which I think should fix this issue. Please upgrade, re-save your Volusion settings and let me know if it works.

  6. kristingcs
    Member
    Posted 3 years ago #

    Ive updated the plugin and I still get the same error that the API settings are not configured correctly. I even tried a fresh install and still nothing. Id love for this to work, but so far I can't get past the errors.

  7. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    Have you confirmed that http://yourstoredomain.com/net/webservice.aspx?api_name=generic\all_products shows a bunch of text?

    It should look like this.

  8. kristingcs
    Member
    Posted 3 years ago #

    Yes I get the list that has all the products listed and I have my address in the URL box, but it still is giving me the error code saying it is not configured properly. Any other suggestions? Thanks for the help.

  9. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    Please either post here or email me your store's URL.

    One possibility is that your server doesn't support something in the plugin. You should also make sure your server is running PHP 5.

  10. Zack Katz
    Member
    Plugin Author

    Posted 3 years ago #

    So the issue is that it's taking too long to download the products list. Increasing the "timeout" time makes getting all the products work, but the list of your products is also too large to store in a cache (as the plugin is currently set up).

    I am not sure how to fix the caching issue, but I can fix the timeout issue.

  11. sgridley
    Member
    Posted 3 years ago #

    Hi Zack,

    Love this plugin! We get the same error from time to time. Our store is at store.fabrics.net and we have a couple thousand products so maybe we're getting the timeout issue due to too many products?

    Also, when this happens I do confirm that our API shows the text and that our store is up and running.

    Thanks,
    Sam

  12. robahas
    Member
    Posted 2 years ago #

    Hi Sam - I'm having the same trouble integrating to the Volusion API. I'm wondering if this has to do with the fact that I'm developing the site under a beta folder? Of course, at Volusion the store is configured at the root. I'd just like to get your take before moving the site to the root (something I would rather avoid if possible).

  13. robahas
    Member
    Posted 2 years ago #

    Er... Sorry, ZACK, not Sam

  14. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    I can't be sure unless you email me your credentials: info@katzwebservices.com

  15. osolano
    Member
    Posted 2 years ago #

    I am having the same problem. The settings are correct as my webpage pulls up but I can't get to the settings page.

    http://www.triplejsunprotection.com/net/webservice.aspx?api_name=generic\all_products

  16. Randy Bass
    Member
    Posted 2 years ago #

    Zack - Will you share the link to some WordPress sites using Volusion? I have a client using Volusion who would like to integrate into WordPress.

    Thanks

    Randy

  17. jlheidecker
    Member
    Posted 2 years ago #

    Is a GOLD volusion account required for this? I don't think I can turn on the xml stuff unless I upgrade.

    ?

  18. Zack Katz
    Member
    Plugin Author

    Posted 2 years ago #

    You need an XML products API set up. Check out how to here: http://support.volusion.com/article/where-do-i-find-information-volusion-api

  19. godspawned
    Member
    Posted 2 years ago #

    Is there a fix to this error yet? From reading the above I believe the problem to be the plugin timing out as my API is setup right, but I have a large product base and it takes the XML a bit to load. I'd love to be able to use the plugin.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags