WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Visitor Maps and Who's Online] Visitor Map just displays pins and no outline for the world (14 posts)

  1. chrisleo33
    Member
    Posted 4 years ago #

    Visitor Map just displays pins and no outline for the world or countries

    http://wordpress.org/extend/plugins/visitor-maps/

  2. Mike Challis
    Member
    Posted 4 years ago #

    You probably do not have proper GD image support in your PHP installation.
    You may have to make a trouble ticket with your web host.

    What is the URL to the page with the problem?
    View the image separately, is there an error shown?

  3. Mike Challis
    Member
    Posted 4 years ago #

    The plugin called "Donate plus" can cause this as well.

  4. menacek04
    Member
    Posted 4 years ago #

    Ok so I am seeing the same issue. I have made sure that there is proper GD support on my server.

    In fact, the map worked for a couple of minutes on my site, then I changed some of the options that are available for the plugin and now it does not work and I can't figure out what has caused it.

    Just a pin showing.

  5. Mike Challis
    Member
    Posted 4 years ago #

    Try temporarily disabling other plugins.
    What is the URL to the page with the problem?
    View the image separately, is there an error shown?
    Look in PHP error logs. What are the errors found?

  6. didierott
    Member
    Posted 4 years ago #

    I have the same issue on one of my two wordpress sites

    to make the maps visible, I have modified the source :
    // select map image
    $image_worldmap = $url_visitor_maps .'images/' . $C['image_worldmap']; // default
    $image_worldmap_path = $path_visitor_maps .'images/' . $C['image_worldmap']; // default
    $G['map'] = 1;
    if ( isset($MS['map']) && is_numeric($MS['map']) ) {
    $G['map'] = floor($MS['map']);
    $image_worldmap = $url_visitor_maps . 'images/' . $C['image_worldmap_'.$G['map']];
    $image_worldmap2 = $image_worldmap;
    // line above was added;

    $image_worldmap_path = $path_visitor_maps . 'images/' . $C['image_worldmap_'.$G['map']];

    and modified a word in the line below :

    $string .= '<div style="position:relative; border:none; background-image:url('.$image_worldmap2.'); width:'.$image_worldmap_width.'px; height:'.$image_worldmap_height.'px;">';

  7. Mike Challis
    Member
    Posted 4 years ago #

    didierott,

    The reason it seems to fix it is because that causes it to not show the text "xx visitors since xx days ago".

    The actual problem is your PHP has an error trying to print text on images. Your PHP is missing image text support or TTF support.

  8. Mike Challis
    Member
    Posted 4 years ago #

    OK I added a workaround for this in version 1.3.3 (15 Jan 2010)

    New setting on the admin page: "Disable text on geolocation maps (missing map background fix)"

    Explanation:
    Some PHP servers do not have full support for printing text on the Visitor Map image. Only if the Visitor Map just displays pins and no image for the world or countries, select this setting. After selecting this setting, check your visitor maps page to see if the map is now working.

  9. chrisleo33
    Member
    Posted 4 years ago #

    Well I upgraded and it still doesn't work with the maps, everything else is awesome and i would like to thank you for your work on it. I have the plugin on another site as well and that one works fine, same template and same web host. The site is http://www.talksportsphilly.com

    thanks

  10. chrisleo33
    Member
    Posted 4 years ago #

    the image does get an error when i try to view it separately.

    It can not be displayed because it has errors, it says.

  11. freshwidows
    Member
    Posted 4 years ago #

    Hi, for me it doesn't work BUT i like it so much, not seeing the map, like the minimalism of my page :
    You Came From
    I will try to upgrade today but if the map appears i think i will go back to the precedent version, anyway thks you so much!

    Antoine

  12. didierott
    Member
    Posted 4 years ago #

    Hi
    thanks for the version 1.3.3 . I have installed it
    Without selecting the new option or with selecting the new option, I have only the pins without the map as background of the image.

    When I look at the $image_worldmap
    i got
    http://ott.fr/wp?do_wo_map=1&time=15&units=minutes&map=2&pin=1&pins=off&text=on&textcolor=000000&textshadow=FFFFFF&textalign=cb&ul_lat=0&ul_lon=0&lr_lat=360&lr_lon=180&offset_x=0&offset_y=0&type=png

    which gives when I put in in Firefox
    the image ... cant be shown because it contains errors

    didier

  13. Mike Challis
    Member
    Posted 4 years ago #

    The plugin called "Donate plus" can cause this, if you have it, deactivate it.
    Try temporarily disabling other plugins.

    Look in PHP error logs. What are the errors found?
    Your server could have insufficient support for the GD image functions. Make a trouble ticket with your web host.

    In my latest version, I was trying to make a workaround for the few servers without proper image functions. Since my server works fine, it is not possible for me to test my changes.
    If one of you is willing to give me temporary admin login, I can test on your server a bit, maybe get something working for you. Contact me here if interested.
    http://www.642weather.com/weather/contact_us.php

  14. Mike Challis
    Member
    Posted 4 years ago #

    Ok I coded the fix to work for didierott. It will be included in the next version.

    The fix is just a hack to make it kind of work though. Your wordpress has a problem with header characters (a unicode marker) in the image that is created. This causes the image to fail to display. The header characters are coming from one of the PHP files in wordpress or another plugin.

    I confirmed this was the problem on didierott's blog.
    See explanation of the cause here:
    http://saratoga-weather.org/template/template-FAQ.php#FAQ2

    My template shows some funny characters like '' in various pages. How can I fix that?

    A2: This is most likely caused by uploading the .php, .html, .txt files in FTP BINARY mode. In Binary mode, the text files may contain a unicode marker at the start of the file, which will be removed if uploaded in FTP ASCII mode.

    All the files in the template set (except for the graphics [*.jpg, *.gif, *.png]) should be uploaded with FTP ASCII mode. The graphics files need to be uploaded in FTP BINARY mode. A good FTP program should be able to do this automatically. Filezilla and Cute FTP come to mind. Try re-uploading the files to your server with a different FTP program or check that it is set up properly.

    Then you could uncheck the setting.. "Disable text on geolocation maps (missing map background fix)"

Topic Closed

This topic has been closed to new replies.

About this Topic