WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Visitor Maps and Who's Online] The plugin cannot install "Maxmind GeoLiteCity database" (17 posts)

  1. bluebird2
    Member
    Posted 4 years ago #

    I tried to install the plugin but it says it needs to install "Maxmind GeoLiteCity database" first. The attempt to install that resulted in giving me this message:

    "Please allow plenty of time for the approximately 19meg file to download.
    The time needed depends on your server download speed.
    A timeout can happen if the connection is really slow causing this to take more than 3 minutes.
    download_file error: cannot write to file, check server permission settings"

    But it does not say what folder does not have proper permission setting.

    http://wordpress.org/extend/plugins/visitor-maps/

  2. Mike Challis
    Member
    Posted 4 years ago #

    If the geolite database errors trying to download, the server's PHP
    settings could be the cause. Possible reasons: PHP safe_mode could be
    enabled, you should turn it off. allow_url_fopen could be disabled, you
    should turn it on.

    If you can, edit your PHP.ini file (usually located in /etc/php.ini or
    the root folder of your web site) and make sure these two settings are
    like this: safe_mode = Off, allow_url_fopen = On

    The geolite database is really just a 30 meg file. As a workaround,
    you can manually download the GeoLiteCity.dat.gz file from this URL,
    http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
    unzip it and upload GeoLiteCity.dat to the /plugins/visitor-maps/
    folder. The GeoLiteCity.dat file is the database for the location from
    IP feature. If the file is missing, the blog should function fine.
    When the file is not installed, the location information for a user is
    skipped.

  3. bluebird2
    Member
    Posted 4 years ago #

    Thanks. That fixed it!

  4. Jyn
    Member
    Posted 4 years ago #

    I got the message

    Please allow plenty of time for the approximately 19meg file to download.
    The time needed depends on your server download speed.
    A timeout can happen if the connection is really slow causing this to take more than 3 minutes.
    download_file error: reading or opening file

    ...?

  5. Mike Challis
    Member
    Posted 4 years ago #

    Some servers are picky. See my reply above, you may have to manually install the file.

  6. guz843
    Member
    Posted 4 years ago #

    i dont understand this error message:

    Warning: VisitorMaps::require_once(/home/rehavac/public_html/blog/wp-content/plugins/visitor-maps/class-wo-update.php) [visitormaps.require-once]: failed to open stream: No such file or directory in /home/rehavac/public_html/blog/wp-content/plugins/visitor-maps/visitor-maps.php on line 615

    i read your response but it didnt make sense. where is the class-wo-update.php file??? ii cant find it?

  7. Mike Challis
    Member
    Posted 4 years ago #

    guz843, Your installation is broken (a file is missing). Try to uninstall and then reinstall.

  8. mugil
    Member
    Posted 4 years ago #

    I manually download the file GeoLiteCity.dat.gz and i uploaded it to the plugins/visitor maps folder.But i still get this message Visitor Maps plugin needs the Maxmind GeoLiteCity database installed. Install Now.
    Please help me to solve this problem.

  9. Mike Challis
    Member
    Posted 4 years ago #

    You need to unzip it.
    GeoLiteCity.dat.gz becomes GeoLiteCity.dat

    GeoLiteCity.dat is the file the plugin uses.

  10. mugil
    Member
    Posted 4 years ago #

    Thanks for your reply Mike.I unzipped it and then i uploaded it.But i still get this message Visitor Maps plugin needs the Maxmind GeoLiteCity database installed. Install Now.

  11. Mike Challis
    Member
    Posted 4 years ago #

    It must be in the correct folder.
    /wp-content/plugins/visitor-maps/

    where did you put it it?

  12. mugil
    Member
    Posted 4 years ago #

    i uploaded it inside this folder as u mentioned above /wp-content/plugins/visitor-maps/ but it still didnt work for me.
    Thanks for u reply Mike

  13. Mike Challis
    Member
    Posted 4 years ago #

    Make sure it has been uploaded in binary and that it has proper permissions.
    chmod 644 is usually sufficient.

  14. mugil
    Member
    Posted 4 years ago #

    Hiii Mike,I am new to this i am sory i dont know how to upload it in binary or to set permissions.

  15. Mike Challis
    Member
    Posted 4 years ago #

    mugil, which FTP program do you use?

  16. mugil
    Member
    Posted 4 years ago #

    Hello Mike,
    I use Filezilla.

  17. Mike Challis
    Member
    Posted 4 years ago #

    Manual method:
    Download the latest GeoLite City Binary Format file (28 MB when uncompressed):
    http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz

    After you have downloaded the database, unzip it using a program like WinZip.
    Finally upload the GeoLiteCity.dat file to your web site folder on your server using FTP or another upload mechanism.
    Note: since the file is around 30 meg, it can take a very long time to upload.

    If you use filezilla ftp program:
    make sure you use binary mode and there is a setting for timeouts, set that to 1800 seconds (30 minutes).
    Edit - Settings - Connection - Timeout

    Once you have logged in, use your mouse to direct your pointer to “transfer” in the top toolbar. Under “transfer,” you will see a few different options. Choose “transfer type” and then select “Binary.”

    Manual method:
    Download the latest GeoLite City Binary Format file (28 MB when uncompressed):
    http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz

    After you have downloaded the database, unzip it using a program like WinZip.
    Finally upload the GeoLiteCity.dat file to your web site folder on your server using FTP or another upload mechanism.
    Note: since the file is around 30 meg, it can take a very long time to upload.

    Highlight all the files and folders you want from your hard drive (local site), and drag them into the field containing the directories on your web host (remote site).

    Change the “transfer type” back to Auto when you are done or you could have problems with other files you upload later.

Topic Closed

This topic has been closed to new replies.

About this Topic