WordPress.org

Ready to get started?Download WordPress

Forums

Visitor Maps and Who's Online
Cannot Update GeoLiteCity Data (11 posts)

  1. fwchapman
    Member
    Posted 2 years ago #

    Hi Mike,

    I just upgraded to Version 1.5.7 of the plugin. When I try to update the GeoLiteCity data, I get this error message:

    Checking for updates for the Maxmind GeoLiteCity database
    PHP Memory Limit is 256M, increasing is not needed.
    Connecting to this URL: http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
    curl_last_mod error: could not connect to remote file

    Is this a MaxMind problem or a plugin problem?

    Thanks,

    Fred

    http://wordpress.org/extend/plugins/visitor-maps/

  2. engin1984
    Member
    Posted 2 years ago #

    i think its a Maxmind GeoLiteCity error.

  3. fwchapman
    Member
    Posted 2 years ago #

    I'm still having the problem. Sometimes I get this error message instead:

    Checking for updates for the Maxmind GeoLiteCity database
    PHP Memory Limit is 256M, increasing is not needed.
    Connecting to this URL: http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
    curl_last_mod error: fetching timestamp failed for URL, 404 not found?

  4. fwchapman
    Member
    Posted 2 years ago #

    I think it's a MaxMind problem, too. When I click on the link to download the file directly, it does, but at the incredibly slow speed of 32 KB/sec. I have a 10Mb/sec connection, which means the download speed should be about 1 MB/sec.

  5. fwchapman
    Member
    Posted 2 years ago #

    Progress! I'm still having problems updating the database, but I got a little further this time:

    Please allow plenty of time for the approximately 19meg file to download.
    The time needed depends on your server download speed.
    A timeout can happen if the connection is really slow causing this to take more than 3 minutes.
    Download started, (counting megs)(1)(2)(3)(4)(5)(6)
    Fatal error: Maximum execution time of 180 seconds exceeded in /wp-content/plugins/visitor-maps/class-wo-update.php on line 432

    It looks like the MaxMind server is still very, very slow. I'll keep trying.

  6. fwchapman
    Member
    Posted 2 years ago #

    Success! I was finally able to update the GeoLiteCity database a few minutes ago!

  7. meenzal
    Member
    Posted 2 years ago #

    I have had the same issue with all of the same conditions, and now I just get a long pause before I get an internal server error. Something changed when I updated to version 1.5.7 and I have not been able to update since, instead manually updating my database to keep abreast. I have looked for some way to roll back to the previous version to see if the builtin update will work again, but cannot find a way to do that. Are older versions available, and if so, how do I get to them?

  8. fwchapman
    Member
    Posted 2 years ago #

    Meenzal, you can find older versions of the plugin here:

    http://wordpress.org/extend/plugins/visitor-maps/download/

    I'm not sure if rolling back to an earlier version will help. I'm under the impression that it's the MaxMind server which is the bottleneck.

    I just managed to do an automatic update successfully, but it's a lot slower than it used to be. What are the steps to do a manual update?

    Fred

  9. fwchapman
    Member
    Posted 2 years ago #

    P.S. You might want to try temporarily deactivating all your other plugins just to make sure there isn't a conflict which interferes with the update process. I've had the experience, more than once, that updating plugin X breaks plugin Y, and rolling back to an earlier version of Y doesn't help.

  10. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    Nothing has changed in recent versions as to how the database updates. if it will not update it is your server or MaxMind. Recently MaxMind servers have been slow and is probably the cause.

    If the geolite database errors trying to download, the server's PHP
    settings could be the cause. Possible reasons: PHP safe_mode could be
    enabled, you should turn it off. allow_url_fopen could be disabled, you
    should turn it on.

    If you can, edit your PHP.ini file (usually located in /etc/php.ini or
    the root folder of your web site) and make sure these two settings are
    like this: safe_mode = Off, allow_url_fopen = On

    The geolite database is really just a 30 meg file. As a workaround,
    you can manually download the GeoLiteCity.dat.gz file from this URL,
    http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
    unzip it and upload GeoLiteCity.dat to the /plugins/visitor-maps/
    folder. The GeoLiteCity.dat file is the database for the location from
    IP feature. If the file is missing, the blog should function fine.
    When the file is not installed, the location information for a user is
    skipped.

  11. fwchapman
    Member
    Posted 2 years ago #

    Mike, thanks for your valuable technical tips and for providing the steps to manually update the GeoLiteCity database. It's much appreciated! -Fred

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic