WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Viper's Video Quicktags] Progressive download not working with MP3 embeds (4 posts)

  1. tranified
    Member
    Posted 4 years ago #

    When using a the [flv] shortcode to embed an MP3 file, I noticed progressive download was not working properly. Rather than starting playback after buffering a few seconds, playback wouldn't start until after the entire MP3 had been downloaded.

    I did some troubleshooting with the JW Player's Setup Wizard and have isolated it to the use of the "image" flashvar. By default VVQ uses the URL of the MP3 as both the "file" and "image" flashvar.

    If you remove the image flashvar, progressive download works as expected.

    So I'm wondering if the next update could include a fix for this? Potentially checking the file extension and not including the image flashvar if it detects an MP3.

    Thanks!
    -Alex

    http://wordpress.org/extend/plugins/vipers-video-quicktags/

  2. Ooooh, duh! This also fixes the problem I had noticed where it'd download the entire MP3 file without the user clicking the play button.

    A fix is on it's way. Thanks! :)

  3. tranified
    Member
    Posted 4 years ago #

    Werd. You're a rock star. Love seeing how active you are with this forum.

  4. Love seeing how active you are with this forum.

    Nah, too busy to follow along with the forums as a whole. I'm just subscribed to the RSS feeds for all of the tags of my plugins here. ;)

Topic Closed

This topic has been closed to new replies.

About this Topic