WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Viper's Video Quicktags] Error message in IE 7 - VVQT 6.1.15 (12 posts)

  1. infected
    Member
    Posted 5 years ago #

    I am getting an error message (popup) if i activate the latest version.

    Error: 'J.parentNode' is null or no object

    Screenshot of german error message.

    I already have disabled all other plugins but the error still there if vvqt is enabled. Someone knows how to fix it?

  2. I'm just using SWFObject. I'm sure it's IE7 compatible (I tested it myself a few versions back).

    Try the default theme perhaps?

  3. ingejanse
    Member
    Posted 5 years ago #

    Same problem here at http://www.eclectro.nl. It results in only the header being loaded, not the body of the page. The corresponding error message reads:

    Message: 'J.parentNode' is null or not an object
    Line: 5
    Char: 1913
    Code: 0
    URI: http://www.eclectro.nl/wp-content/plugins/vipers-video-quicktags/resources/swfobject.js?ver=2.1

  4. infected
    Member
    Posted 5 years ago #

    @all: Happy new year!
    @viper: Same error message when using the default theme...

  5. If you drop that error message into Google, the results seem to indicate the problem stems from multiple SWFObjects being loaded. Another plugin that isn't using the WordPress Scripts API (like it should be doing and like mine does in order to prevent this very thing) is likely causing the problem.

  6. ingejanse
    Member
    Posted 5 years ago #

    @ Viper: thank you for your reaction. According to the message on http://wordpress.org/support/topic/179225/page/6?replies=361#post-813295, the conflict in my case is caused by the audio player beta 2 plugin (http://wpaudioplayer.com/). I can't miss either one of the plugins, so does that mean that I have to ask the author of the audio player to fix this? And if so, what exactly can I tell him?

  7. infected
    Member
    Posted 5 years ago #

    As I said before:

    I already have disabled all other plugins but the error still there if vvqt is enabled.
    I had installed audioplayer beta2 plugin, too. But as i said all plugins are disabled!

  8. I can't miss either one of the plugins, so does that mean that I have to ask the author of the audio player to fix this? And if so, what exactly can I tell him?

    Yes, it's their fault. Direct them here:

    http://codex.wordpress.org/Function_Reference/wp_enqueue_script

    I had installed audioplayer beta2 plugin, too. But as i said all plugins are disabled!

    Caching? I dunno, I stay as far away from Internet Explorer as I can get. :)

    All I know though is that SWFObject is widely used (even YouTube uses it), so I'm sure it works with IE.

  9. infected
    Member
    Posted 5 years ago #

    Hi Viper!

    Yes, it seemed to be a cache thing... But i was sure that i cleared cached files. I donĀ“t know what happened. Now it works again (without audioplayer plugin). Thanks for your help!

  10. alexleonard
    Member
    Posted 5 years ago #

    I was absolutely baffled for a while as I looked through the audio-player.php as no mention of swfobject.js was made at all. It turns out the swfobject is loaded as part of assets/audio-player.js and I haven't got a clue how to separate the two.

    I've thrown a support query related to this over at:
    http://wordpress.org/support/topic/179225/page/13?replies=383#post-964376

    Hoping we'll see an update for audio player soon.

    It'd be a shame to have to lose a plugin due to a fixable conflict like this.

    Thanks for the pointers Viper.

    Oh, I'm not sure if this is of interest to you, but when I'm outside of wordpress and need to embed a video I dropped the idea of using swfobject a long time ago in place of this method which doesn't require any javascript and as far as I know is bulletproof.

    <div class="video">
     <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,0,0" width="x" height="x" id="movie" align="">
      <param name="movie" value="[video-url]" />
      <param name="allowfullscreen" value="true" />
      <param name="allowscriptaccess" value="always" />
     <!--[if !IE]> <-->
      <object type="application/x-shockwave-flash" data="[video-url]" width="x" height="x">
        <param name="allowfullscreen" value="true" />
        <param name="allowscriptaccess" value="always" />
        [Non-IE Text description of video - optional - good for search?]
      </object>
     <!--> <![endif]-->
     <!--[if IE]>
     [IE Text description of video - optional - good for search?]
     <![endif]-->
     </object>
    </div><!-- end .video -->

    This method is detailed in depth over here:

    http://joliclic.free.fr/html/object-tag/en/

  11. therman
    Member
    Posted 5 years ago #

    Can somebody please help me with this same issue??? I've un-installed the Vipers tag and the audio plugin but I'm still getting the js. errors in I.E.

    This is frustrating!

    http://www.hockeygoalscoring.com

  12. alexleonard
    Member
    Posted 5 years ago #

    I just loaded your site up in IE7 and didn't spot any "error on page" as usually comes up.

Topic Closed

This topic has been closed to new replies.

About this Topic