WordPress.org

Ready to get started?Download WordPress

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] [Plugin: VideoJS - HTML5 Video Player for WordPress] Shortcode for tracks (20 posts)

  1. locworks
    Member
    Posted 2 years ago #

    The shortcode definition in video-js.php doesn't seem to have anything to support tracks. Are there any plans to implement them?

    http://wordpress.org/extend/plugins/videojs-html5-video-player-for-wordpress/

  2. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Not in the immediate future, but I will definitely consider adding it in the next version. What do you think would be the best shortcode syntax for tracks? Maybe [video mp4="http://video-js.zencoder.com/oceans-clip.mp4"][track kind="captions" src="http://example.com/path/to/captions.vtt" srclang="en" label="English"][/video]? Or can you think of a way to keep it all in the [video] shortcode?

  3. locworks
    Member
    Posted 2 years ago #

    Thanks for posting. I'd actually keep your syntax above. It makes it easier to manage tracks in several languages.

  4. starapple
    Member
    Posted 2 years ago #

    Is vtt a file type that WP will accept for uploads?

  5. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    If you're interested there is new beta version of the plugin available at https://github.com/zencoder/video-js-for-wordpress with track support. I would love any feedback anyone would like to offer!

  6. starapple
    Member
    Posted 1 year ago #

    Thanks. Will test it and then add the tracks component to my little shortcode generator.

  7. ones
    Member
    Posted 1 year ago #

    Captions don't work .

  8. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Where is your caption file hosted? I believe it has to be on the same domain as the main site or else javascript will throw an error. Are you able to view your javascript error logs and see if any errors are coming up?

  9. ones
    Member
    Posted 1 year ago #

    Uncaught TypeError: Cannot call method 'addComponent' of undefined video.js:21
    _V_.Track._V_.Component.extend.activate video.js:21
    _V_.Track._V_.Component.extend.show video.js:21
    prototype.(anonymous function) video.js:21
    ret video.js:21
    (anonymous function) video.js:21
    _V_.extend.each video.js:21
    _V_.Component._V_.Class.extend.each video.js:21
    _V_.Component._V_.Class.extend.triggerReady video.js:21
    techReady video.js:21
    _V_.Component._V_.Class.extend.ready video.js:21
    _V_.Player._V_.Component.extend.loadTech video.js:21
    _V_.Player._V_.Component.extend.src video.js:21
    _V_.Player._V_.Component.extend.init video.js:21
    Class video.js:21
    VideoJS video.js:21
    _V_.autoSetup video.js:21

  10. ones
    Member
    Posted 1 year ago #

    My captions it's hosted on server where i hosting wordpress.

  11. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried disabling other plugins to make sure there isn't another plugin that is causing a javascript conflict/error somewhere?

  12. ones
    Member
    Posted 1 year ago #

    I had only this one activate.. And activate standard wordpress template.

  13. ones
    Member
    Posted 1 year ago #

    I add video with:
    [video webm="http://video-js.zencoder.com/oceans-clip.webm" poster="http://video-js.zencoder.com/oceans-clip.png" preload="auto" autoplay="false" width="640" height="264" id="movie-id" class="alignleft" controls="false"][track kind="captions" src="http://udx.pl/domo/wp-content/plugins/videojs-html5-video-player-for-wordpress/videojs/captions.vtt" srclang="en" label="English" default="true"][/video]

  14. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Try adding this to your .htaccess file:

    <FilesMatch \.vtt$>
       ForceType text/vtt;charset=utf-8
    </FilesMatch>
  15. ones
    Member
    Posted 1 year ago #

    Nothing happen.
    I had that problem:
    Uncaught TypeError: Cannot call method 'addComponent' of undefined

    It's error of video.js:21 (showing in webmaster tool)
    When i open that than i get:
    _V_.Track._V_.Component.extend.activate video.js:21
    _V_.Track._V_.Component.extend.show video.js:21
    prototype.(anonymous function) video.js:21
    ret video.js:21
    (anonymous function) video.js:21
    _V_.extend.each video.js:21
    _V_.Component._V_.Class.extend.each video.js:21
    _V_.Component._V_.Class.extend.triggerReady video.js:21
    techReady video.js:21
    _V_.Component._V_.Class.extend.ready video.js:21
    _V_.Player._V_.Component.extend.loadTech video.js:21
    _V_.Player._V_.Component.extend.src video.js:21
    _V_.Player._V_.Component.extend.init video.js:21
    Class video.js:21
    VideoJS video.js:21
    _V_.autoSetup

    I think it's cannot add track to theme. I don't see on code <track> i see only <video>

  16. ones
    Member
    Posted 1 year ago #

    Very strange. After add control="true" It's work!
    The resolve.
    Change control="true" in [video] on post!

  17. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    When I view the video on your demo site the captions work fine.

  18. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, I hadn't seen your last post. I wonder if the controls might be required so the user has a way to turn on/off the captions. Glad you got it figured out.

  19. ones
    Member
    Posted 1 year ago #

    I want to integrate now youtube video. I try but nothing happen.

    I get on site now:

    <video id="movie-id" class="video-js vjs-default-skin alignleft" width="640" height="264" poster="http://video-js.zencoder.com/oceans-clip.png" controls="" preload="auto" data-setup="{'techOrder': ['html5', 'flash']}">
        <source src="http://www.youtube.com/watch?v=aOpt47lizzI" type="video/youtube">
    <track kind="captions" src="http://udx.pl/domo/wp-content/plugins/videojs-html5-video-player-for-wordpress/videojs/captions.vtt" srclang="en" label="English" default=""></track>
    	</video>
  20. groupemedia
    Member
    Posted 1 year ago #

    I've installed the plugin correctly and activate.
    the I create the following .htaccess
    ***********

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /new/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /new/index.php [L]
    </IfModule>

    # END WordPress

    AddType video/webm .webm
    AddType video/ogg ogg
    AddType video/ogg ogv
    AddType video/mp4 .mp4
    ***********

    I insert the video on my home page http://www.groupemedia.com/new
    directly like this:

    [video mp4="http://www.groupemedia.com/new/Presentation_corporative2.mp4"]
    [video ogg="http://www.groupemedia.com/new/Presentation_corporative2.ogg"]
    [video webm="http://www.groupemedia.com/new/Presentation_corporative2.webm"]

    Obviously I have each of the video.

    But it does not work in ie9, firefox chrome...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic