WordPress.org

Ready to get started?Download WordPress

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] [Plugin: VideoJS - HTML5 Video Player for WordPress] No loading spinner in IE (7 posts)

  1. Z-247
    Member
    Posted 1 year ago #

    Hi,

    I've run into a small issue with the player interface in IE. Clicking the play button triggers loading the video, but the play button doesn't ever switch to the loading spinner. This is making people think the whole thing is broken, and they're not waiting for the video to load/play.

    Any way to improve progressive playback in IE 9 and earlier? Or any tips to get that loading spinner working?

    Thanks,

    Z-247

    http://wordpress.org/extend/plugins/videojs-html5-video-player-for-wordpress/

  2. Z-247
    Member
    Posted 1 year ago #

    I think I've solved this by making sure my .mp4 file was "web optimized" when encoding it. IE videos now properly play while continuing to download, rather than stalling until they're totally downloaded.

  3. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    I must admit I have had this same issue and assumed that there was no solution. What did you have to do to "web optimize" your videos? What encoder were you using? After doing a few Google searches, it looks like the issue may be that metadata needs to be at the beginning of the video rather than the end. Trying to see if ffmpeg can do this...

    Edit: It looks like the solution is qt-faststart. Windows binary is here: http://notboring.org/devblog/2009/07/qt-faststartexe-binary-for-windows/

  4. Z-247
    Member
    Posted 1 year ago #

    I was using Handbrake (free here: http://handbrake.fr/) which, among the various presets and options, has a checkbox for "Web optimized." I think the other things to check are that you're using the H.264 codec and it's an mp4, although m4vs might work as well (I never tested that one.)

  5. motty.cruz
    Member
    Posted 1 year ago #

    I was having the same problem, it took me a day to figure out that is the compatibility mode on IE that keep video from loading. In /themes/header.php I added this line
    <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8" />
    just above </head>

    I hope it helps, or in IE go to Tools --> Compatibility View Settings and uncheck all boxes.

  6. NicolayWorren
    Member
    Posted 1 year ago #

    Hello, I have the same problem, the video plays in all browsers (including Apple devices) except IE. I tried the qt-fastrack program but it does not seem to help. Any help would be appreciated.

    As for the last comment - - as far as I understand this will only help me see the video, but I want others to view it...?

  7. NicolayWorren
    Member
    Posted 1 year ago #

    I tried the Handbrake tool and encoded the file using the "web optimized" setting - does not seem to resolve the problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic