WordPress.org

Ready to get started?Download WordPress

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] [Plugin: VideoJS - HTML5 Video Player for WordPress] No FF fallback (11 posts)

  1. thedannywahl
    Member
    Posted 2 years ago #

    The latest update seems to not be using the object tag on FF11, but instead is still using the video tag even if you only have an mp4. Here's my post code (that worked yesterday):

    [video mp4="http://iywahl.com/wp-content/uploads/2012/04/wpid-VID_20120406_170213.mp4"]

    Here's the render:

    <video width="630" height="354" data-setup="{}" preload="auto" controls="" class="video-js vjs-default-skin" id="example_video_id_1599702042" tabindex="0">
            <source type="video/mp4" src="http://iywahl.com/wp-content/uploads/2012/04/wpid-VID_20120406_170213.mp4"></source>
    </video>

    I just posted this video yesterday with 3.0 and it was working. Still works in Safari. Test it here: http://iywahl.com/going-down-the-slide/

    http://wordpress.org/extend/plugins/videojs-html5-video-player-for-wordpress/

  2. rob.roberts
    Member
    Posted 2 years ago #

    I think this may be my problem as well, but I don't even get a box in IE8. In IE9 on Win7, I get the black box/player, but it has an "X" in it even though the first 3 videos worked yesterday.
    I tried to go back to 3.0, but it looks like the raw code change on CDN prevents even that from working.
    I've got to get video.js back working.
    I'll open up the site so all can see the error: http://video.woodlandstoastmasters.com

  3. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    @thedannywahl It appears that you are using the self-hosted option, which is causing the problem (video.js isn't loading at all). Try switching to the CDN hosted version and see if that fixes the problem (wp-admin -> Settings -> Video.js Settings -> Check the "Use CDN hosted version?" box and Save Changes). It looks like there may be a bug in the code for the self hosted version that needs to be fixed for some hosting platforms. Are you using Windows or Linux based hosting?
    Update: I have verified that there is an issue with the self hosted version. There should be a fix shortly, but in the meantime switching to the CDN version should work fine.

    @rob.roberts Video.js appears to be loading fine on your site, but the videos themselves are not loading. If I download the video file directly (using the src in your video.js code) Windows Media Player tells me the video is corrupted, which would indicate that there is a problem with your video file rather than the plugin. Can you check that there is nothing wrong with the video files? Or try reverting to the previous version of the plugin. If that fixes the problem, then obviously it is a plugin issue.

    Sorry that you are having issues with the plugin update. I will try get this fixed ASAP. If you have any other details about the problems please let me know.

  4. thedannywahl
    Member
    Posted 2 years ago #

    switching to the CDN version fixed it, so it seems you're right the self-hosted version doesn't work. I'm running on Debian Linux on Dreamhost.

  5. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to hear that fixed your problem. Its a pretty simple fix, but it may take a little while before I can push an update to WordPress.org.

  6. rob.roberts
    Member
    Posted 2 years ago #

    I switched to the CDN version last evening, but I still get the problem.
    These files are optimized using the H.264 codec, which Windows Media Player apparently doesn't recognize (or has its own version). These do, however, play directly in Quicktime with no problem.

    I've also pulled these modified videos directly into Roxio and they play flawlessly. I have dismissed the Windows Media Player errors because any edits to any file (using MediaStream, Roxio, or anything else) won't play in Windows Media but will play in all the others.

    NOTE: Three of these videos played just fine on Friday morning when I released the site, but the rest were added later. "Greg Adams", the first I posted, stopped running Friday afternoon, which prompted me to apply the upgrade that appeared.

    I'll try some tests using a much smaller video to see if that resolves anything.

  7. rob.roberts
    Member
    Posted 2 years ago #

    Actually, I just played 12 of 12 I tested off this site using Windows Media Center v 6.1.7601.17514 on Windows 7.
    There has to be something else.

    This is hosted on HostGator using Linux CentOS 6.2

  8. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    VLC and ffmpeg don't like your videos either. Both of those and Windows Media Player play other H.264 videos fine. Video.js (the actual script, not the WordPress plugin) is throwing an error when it tries to play them as well, so I suspect it is a problem with the videos.

    VLC gives the error:

    No suitable decoder module:
    VLC does not support the audio or video format "undf". Unfortunately there is no way for you to fix this.

    and ffmpeg says it cannot find codec parameters.

  9. rob.roberts
    Member
    Posted 2 years ago #

    FOUND IT!
    Playing directly off the site, Windows Media Center transfers the file and fixes any issues.
    I re-downloaded the file and did a bit comparison to the original upload and found errors in each of the 3 headers I downloaded. The headers were in "plain text". I checked my logs for IpSwitch WSFTP_PRO and found that for some reason, all but the first 3 were transferred in ASCII mode. Also, the first 3 were re-transmitted on Saturday with another batch--ALSO IN TEXT MODE!

    I apologize for raising an issue. It was my problem all along and now I am re-starting all the uploads again. Thanks for your help and debugging skills.

  10. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Glad to hear you found a solution :)

  11. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, there is a fix for the self-hosted version in the newest plugin update (3.2.0) so that option should work now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic