WordPress.org

Ready to get started?Download WordPress

Forums

Video.js - HTML5 Video Player for WordPress
[resolved] [Plugin: VideoJS - HTML5 Video Player for WordPress] Doesn't work (44 posts)

  1. gwa777
    Member
    Posted 2 years ago #

    I followed your instructions. My code is the same as your code, with replacement of file name etc. It doesn't work. Just loops and loops and no video.

    http://wordpress.org/extend/plugins/videojs-html5-video-player-for-wordpress/

  2. Shahid
    Member
    Posted 2 years ago #

    why you using this...........use the manual insertion of video?

  3. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    @gwa777 Can you provide any more details on the problem? Or provide a link to an example? Did you try just the basic code [video mp4="http://video-js.zencoder.com/oceans-clip.mp4"]?

  4. starapple
    Member
    Posted 2 years ago #

    Hi nosecreek, I'm really looking forward to implementing videojs on my site. I've created a shortcode generator of sorts within my theme which gives this output for a locally hosted implementation: [video mp4="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.mp4" ogg="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.ogv" webm="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.webm" poster="http://www.abengnews.com/wp-content/uploads/2012/05/demo12_poster.jpg" preload="auto" autoplay="false" width="400" height="280" id="something"]

    The resulting html in my page is:

    <!-- Begin Video.js -->
    	<video id="something" class="video-js vjs-default-skin" width="400" height="280" poster="http://www.abengnews.com/wp-content/uploads/2012/05/demo12_poster.jpg" controls preload="auto" data-setup="{}">
    		<source src="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.mp4" type='video/mp4' />
    		<source src="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.webm" type='video/webm; codecs="vp8, vorbis"' />
    		<source src="http://www.abengnews.com/wp-content/uploads/2012/05/Demo12.ogv" type='video/ogg; codecs="theora, vorbis"' />
    	</video>
    	<!-- End Video.js -->

    The player loads in the browser and load image spins on click but no movie plays. Just once last night it played in Chrome but not again.

    This is the page with the test video at the bottom: http://www.abengnews.com/2011/12/07/ding-dong-ding-dong-cuckoo-bells-are-ringing/

  5. starapple
    Member
    Posted 2 years ago #

    Deleted the mp4 from the list and the video streamed. I replaced it second in the order but apparently whatever parses the shortcode renders the mp4 first whatever the order. The file plays when I download it...

  6. starapple
    Member
    Posted 2 years ago #

    OK. Problem seems solved by converting the ogv to mp4 using Miro Video Converter. Ironically, the ogv and webm were converted from the mp4 using the same Miro application so there may have been a codec issue with the original mp4.

  7. starapple
    Member
    Posted 2 years ago #

    Ah well, it works in Chrome. Not Firefox nor Explorer 9.

  8. starapple
    Member
    Posted 2 years ago #

    The problem is that Firefox and IE9 need to be told the mime type. The solution is to add the mime types to the site's .htaccess file:
    AddType video/ogg .ogv
    AddType video/mp4 .mp4
    AddType video/webm .webm

  9. igloobob
    Member
    Posted 2 years ago #

    Hello,
    I have got it working in safari but no joy in the other browsers. Can anyone please help point out what I am doing wrong? Obviously I have changed the paths below.

    <?php echo do_shortcode('
    [video mp4="http://www.site.com/MediaFiles/video.mp4"

    ogg="http://www.site.com/MediaFiles/video.ogg"

    webm="http://www.site.com/MediaFiles/video.webm"

    poster="http://www.site.com/MediaFiles/video.jpg"

    preload="auto" autoplay="true" width="320" height="240" id="video" class="alignleft"]'); ?>

  10. igloobob
    Member
    Posted 2 years ago #

    I also have no link in my wp-admin to this plugin, should there be one as with other plugins for settings etc?

  11. Dustin Lammiman
    Member
    Plugin Author

    Posted 2 years ago #

    Can you post a link to your site? There should be an admin screen (Settings -> Video.js Settings). Are you using the latest version of the plugin? Have you double-checked the URLs for all of your video source files?

  12. igloobob
    Member
    Posted 2 years ago #

    Hello, sorry for the delay. I had the new version installed and correct paths definitely. I uninstalled and reinstalled plugin several times and it still didn't work or appear in the admin. However, last night, after trying a different option on the page and then coming back to video.js it suddenly appeared in admin and worked!

    Only one of the files (astonishing) is playing in windows vista home premium though. Seems to be working fine on FF, Opera, Safari, Chrome. I haven't seen it on vista, my client has flagged that up.

    Any ideas why?

    Here is a link to the site which is still in development..

    http://www.followbob.co.uk/DEVSITES/JQ/media

  13. mophilly
    Member
    Posted 2 years ago #

    I just visited the site.

    On Windows 7 using IE9, I can play "Astonishing" but no video. Perhaps that is intentional. None of the other clips load.

    Using FireFox 14 on OS X 10.7, all the videos play as well as the "Astonishing" audio.

    I am having similar troubles today, so please update this thread if you have any news.

    Ms. Quinn has a great voice by the way.

  14. igloobob
    Member
    Posted 2 years ago #

    Hello,

    'Astonishing' should have just an image (blue texture with microphone) in the video as it was just an audio track. 'Aladdin' and 'Company' are actually videos and all the others are audio with an image just like 'Astonishing'.

    Hmm, I can't figure this out and it's pretty much the only thing holding us from going live now :(

    Yes thanks, I'll pass on the compliment, she sure does have some strong pipes!

  15. mophilly
    Member
    Posted 2 years ago #

    Here is a new observation:
    If I enable "compatibility mode" in IE 9, the audio plays. Once, and only once, I saw the video for "Company".

    Chrome on Windows does not play the videos either. FireFox on Windows does.

    WP started to complain about IE being out of date. That lead to an update of OS and SilverLight. After that, WP was still complaining about IE. However, the IE installer from MS says the installed version of IE is newer than the installer's version. Hm... Well, onward.

    With all that done, the video on my test site began to play in IE9 and Chrome. FireFox continues to work as desired.

    On your site, the audio plays but not the video.

  16. igloobob
    Member
    Posted 1 year ago #

    Ok, Chrome was replicating the problem and only 'Astonishing' was working. On thinking about it I remembered that I had some trouble with that file exporting from QuickTime with the graphic in place. So I used Handbrake to export this file only. As this one is the only one working on windows I decided to try and export all the other videos from Handbrake to see if it was the Quicktime export that was the problem.

    It seems to work, Chrome now plays them all, Safari plays them all, Opera plays them all, Firefox now plays none!! I haven't tested IE though.

    Anyone any further ideas?

    I have moved the test page now:

    http://www.janequinn.biz/dev/media-test

  17. starapple
    Member
    Posted 1 year ago #

    They didn't load in IE9 but all played in Chrome on Win 7 pro. I don't have Firefox on this machine but I have the issue of Videojs and its cousin MediaElements files not playing in Firefox on one machine and playing on another. Also, try using shortcode with just the file's URL with no options.

  18. igloobob
    Member
    Posted 1 year ago #

    I wonder if it's the files themselves dues to using handbrake and getting better results than quicktime. The plugin demo video seems to play fine.

    What is the best tool people use for converting these files to mp4, ogv, webm?

  19. starapple
    Member
    Posted 1 year ago #

    I found soomething called Miro Video Converter. Last I downloaded it, there were no configuration options http://www.mirovideoconverter.com/

  20. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    ffmpeg with winff is usually a good choice for video conversion.

  21. starapple
    Member
    Posted 1 year ago #

    Thanks for that winff link Dustin Lammiman. Seems to give far more control on the output.

  22. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    No problem. If you are interested here are the presets I usually use for my Video.js videos. You can import them into winff from Edit -> Presets.

  23. starapple
    Member
    Posted 1 year ago #

    Thanks again Dustin. Done. I'll give it a try.

  24. igloobob
    Member
    Posted 1 year ago #

    Hello,
    sorry for the delay. I sued winff with your settings and have had much more success. One of the files won't work correctly (Aladdin) but all others do.

    THe Alladin vid plays fine in FF, Safari Opera, Chrome. IE 9 won't play at all, IE 7 and 8 only the audio of it plays. Any ideas?

    Also in IE 9, the play button has a solid grey box behind it where it should be the drop shadow. How can this be fixed? It looks fine in IE 7 and 8 though it is just a square icon (which I am happy with) rather than the rounded corner drop shadow version.

    http://www.janequinn.biz/media-test

    Can anyone help me to get this final Aladdin video playing so I can sign off this site finally?

    Thanks

  25. igloobob
    Member
    Posted 1 year ago #

    correction sorry, it also doesn't play in Chrome.

  26. igloobob
    Member
    Posted 1 year ago #

    hello Dustin,

    can you suggest any possible fixes for my problem above by any chance?

    Just that one pesky file stopping me getting that page live for my client.

  27. puckisms
    Member
    Posted 1 year ago #

    I am also having issues - installed the plugin an always get this error

    You entered a video URL that isn't compatible with this shortcode.

    even when i use [video mp4="http://video-js.zencoder.com/oceans-clip.mp4"] to test it with

  28. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    @igloobob, if it won't play in IE or Chrome, it sounds like it is a problem with your .mp4 file. Does it play fine in Windows Media Player?

    @puckisms - can you double check that you don't have any other plugins installed which may use a similar shortcode? That doesn't sound like an error that this plugin should give. If it was a bad video, it wouldn't give an error, it just wouldn't play.

  29. evaneckard
    Member
    Posted 1 year ago #

    Has anyone found fixes for any of this? I tried encoding using the presets Dustin mentioned above, and I only get the loading icon over the playback tools in both FF and IE9 on windows 7. Files play locally no problem.

    I had gotten a different version of the mp4 file I had working in FF, but that was it.

  30. Dustin Lammiman
    Member
    Plugin Author

    Posted 1 year ago #

    Full details on how I prepare my videos for the web: Preparing Your Video. Maybe this will help?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic