WordPress.org

Ready to get started?Download WordPress

Forums

Video Thumbnails
Plugin seems to have just stopped working (7 posts)

  1. contactzero
    Member
    Posted 1 year ago #

    Hi - I have been using the "video thumbnails" plugin with "Automatic Youtube Video Posts Plugin" successfully for a couple of weeks on my site.

    I had used this fix to make them work together:
    changed the line
    $markup = get_post_meta( $post_id, $video_key, true );
    to
    $markup = 'http://youtube.com/watch?v=' . get_post_meta( $post_id, $video_key, true );
    and set the custom field value to _tern_wp_youtube_video.

    Now i just went to the "video thumbnails" plugin settings page and the page is blank so i added a / to the end of the page url to make it display the page.

    The Save Changes button still works but when i click the "scan past posts" nothing happens!

    I have tried uninstalling the plugin and reinstalling but its no good.

    Please help - thanks

    http://wordpress.org/extend/plugins/video-thumbnails/

  2. Sutherland Boswell
    Member
    Plugin Author

    Posted 1 year ago #

    The plugin checks the URL to determine if the script for the scan past posts button should be loaded, so the slash workaround seems to be breaking that.

    Can you try replacing

    if ( isset ( $_GET['page'] ) && ( $_GET['page'] == 'video-thumbnail-options' ) ) {
    	add_action( 'admin_head', 'video_thumbnails_past_ajax' );
    }

    with just
    add_action( 'admin_head', 'video_thumbnails_past_ajax' );

  3. contactzero
    Member
    Posted 1 year ago #

    Thanks for your reply.
    I tried this and got the message:

    This plugin has been deactivated because your changes resulted in a fatal error.
    Parse error: syntax error, unexpected '}' in /mounted-storage/home135/sub002/sc25456-UFXE/extrahotmovies.com/wp-content/plugins/video-thumbnails/video-thumbnails.php on line 516

  4. Sutherland Boswell
    Member
    Plugin Author

    Posted 1 year ago #

    Look at line 516, you must have left the closing } after add_action(...) in.

  5. contactzero
    Member
    Posted 1 year ago #

    Yes i did leave that in - i am really new to php

    When i take out the } after add_action(...) and click Update file then the editor goes to a blank page.

    Then, when i try the video thumbnails settings page that is still blank but now after adding the / after the url it is still a blank page.

  6. naughtythakur
    Member
    Posted 1 year ago #

    This plugin is not working anymore... showing blank page and when we try with / the scan button dont response.....

    Please fixed it and provided the updated working version ....

  7. dmoon79
    Member
    Posted 1 year ago #

    The plugin has stopped working all together. Been using it for months, and now it wont fetch video thumbnails

    Error retrieving a thumbnail from the URL http://img.youtube.com/vi/bjekZJtQU8o/0.jpg
    Libcurl error 0: Failed to connect to 2607:f8b0:4007:801::1008: Network is unreachable. If opening that URL in your web browser shows an image, the problem may be related to your web server and might be something your server administrator can solve.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic