WordPress.org

Ready to get started?Download WordPress

Forums

Video Embed & Thumbnail Generator
[resolved] Encoding never starts (11 posts)

  1. DoctorWombat
    Member
    Posted 2 years ago #

    Hello,

    I can't seem to get the encoding to start. FFMPEG looks like it has been linked correctly (not throwing an error), thumbnails are being generated correctly, but when I click on "encode" on a video, the progress bar never moves. On the server in the uploads folder, blank video files (.webm, .ogv, .m4v) files appear, but they never get any bigger than 0kb.

    I've tested it out with a variety of video files, but I thought it for sure would work with a h264 video wrapped in an mp4 -- no dice.

    I'm on DreamHost on WordPress 3.3.1 if it helps.

    Any help would be greatly appreciated. Thanks in advance.

    DW

    http://wordpress.org/extend/plugins/video-embed-thumbnail-generator/

  2. Kyle Gilman
    Member
    Plugin Author

    Posted 2 years ago #

    Hi DoctorWombat, my guess is that the version of ffmpeg installed at Dreamhost is old enough that libvpx requires -vpre flags in order to work. This was true until fairly recently. Have you tried changing the path to FFMPEG to /usr/local/dh/bin ? Apparently that is a newer version (I found that at http://wiki.dreamhost.com/FFmpeg )

  3. DoctorWombat
    Member
    Posted 2 years ago #

    Hi Kyle, thanks for getting back to me. I changed the plugin settings to /usr/local/dh/bin, but unfortunately the same thing happens - clicking "encode" on a video creates some blank files on the server and the progress bar is unresponsive.

    Is there any way I can add those -vpre flags somewhere, like in kg_callffmpeg.php?

    My super logged in through SSH to try to install FFMPEG manually, but ran into a few snags, but he did notice that apparently the "new" version of FFMPEG on dreamhost is the same as the older one (0.7 or something). So I'm beginning to think this is just a problem on DH's end.

  4. Kyle Gilman
    Member
    Plugin Author

    Posted 2 years ago #

    One other thing to try is only encoding a webm video. If that works, then it's a problem with libvpx.

    You can try hacking kg_callffmpeg.php to add -vpre slow -vpre ipod640 to $ffmpeg_ipod_options

    If Dreamhost is running such an old version it sounds like I should include this as an option in the plugin settings, since Dreamhost is one of the few shared hosts that actually allows access to FFMPEG.

  5. DoctorWombat
    Member
    Posted 2 years ago #

    Oh! Sweet -- encoding it as WEBM and as OGV both work great. Thanks for that. So it just seems to be Mobile/H.264 encoding with the problem.

    Unfortunately adding that line didn't seem to have any effect. Is there a specific place I had to put it?

    $ffmpeg_ipod_options = ' -acodec '.$aaclib.' -ab 128k -s '.$ipod_movie_width.'x'.$ipod_movie_height.' -vcodec libx264 -threads 1 '.$movie_rotate.' -b '.$ipodbitrate.'k -bt 800k -f ipod -vpre slow -vpre ipod640 "'.$encodevideo_info['mobilefilepath'].'"';

    When I click "encode", it just spits out the encoding text as a string.

    Encoding Mobile M4V. -acodec libfaac -ab 128k -s 640x360 -vcodec libx264 -threads 1 -b 1080k -bt 800k -vpre slow -vpre ipod640 -f ipod "/home/doctorwombat/path/to/my/video.mp4"

  6. Kyle Gilman
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry I haven't responded in a while. I know that the order does make a difference but I'm not totally sure what the order needs to be. Try adding the two -vpre tags right after -vcodec libx264.

    Also, for some reason I kept saying libvpx in my earlier messages, but the problem is with libx264.

  7. testlink25
    Member
    Posted 1 year ago #

    I'm getting the same issue (encoding not starting) with pacifichost. the bar never moves...

  8. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    testlink25, you should check with Pacifichost to verify that libx264 is installed. It's not listed on their ffmpeg page http://www.pacifichost.com/ffmpeg-hosting.shtml

  9. jbunger72
    Member
    Posted 1 year ago #

    Kyle,

    Just as an FYI I was having a simialr problem with ffmpeg and the encoding not working, I applied your hack where you stated, right after the vcodec libx264 and I am now encoding with the progress bar working. I am only encoding the mobile/h.264

    I also want to thank you for the time that you have been putting into this and wish I could contribute more, especially being in the film/video industry. (If I knew more about coding I would totally be onboard helping you out)

    Best of luck,
    Jim

  10. Kyle Gilman
    Member
    Plugin Author

    Posted 1 year ago #

    You shouldn't have to hack the plugin to get this to work anymore. After this discussion I added an option in the plugin settings page to add vpre flags.

  11. jbunger72
    Member
    Posted 1 year ago #

    I apologize, I miss read and missunderstood the caption for the add vpre flags check box. Checking this box corrects the problems for users on cirtexhosting.

    Thanks again

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic