WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: User Photo] 2 Warnings with WP 2.5 Permission error & Header error (43 posts)

  1. Guysfordummies
    Member
    Posted 5 years ago #

    I'm a very basic novice so I'm not sure if this is something simple that was just fixed in the new WordPress and no one is talking about it any more or what. Does anyone have any suggestions on the below two errors. I can't even get this plugin to begin to work.

    Warning: mkdir() [function.mkdir]: Permission denied in /home2/guysford/public_html/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information - headers already sent by (output started at /home2/guysford/public_html/wp-content/plugins/user-photo/user-photo.php:409) in /home2/guysford/public_html/wp-includes/pluggable.php on line 694

  2. aphnee
    Member
    Posted 5 years ago #

    I have the same problem with WP 2.6. Got something to do with the permissions I think.

    Line 409: if(!file_exists($dir) && !mkdir($dir, 0777))

  3. tection99
    Member
    Posted 5 years ago #

    I have this same problem, It says that The /uploads directory is not writable, but I've changed the permission to 777..

    Anyone got any ideas? Is it a server config issue?

  4. lalomarquez
    Member
    Posted 5 years ago #

    I also have the same problem with the permissions, the error says:

    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /wp-content/uploads/ directory.

    I also have the .htaccess corrected for the security mod, the content and upload directory chmoded to 0777, but nothing. I cannot upload images.

  5. Scott Kingsley Clark
    Member
    Posted 5 years ago #

    It may be related to the function wp_upload_dir which doesn't seem to be pulling "/wp-content/uploads" for me at all

  6. AbysmalTech
    Member
    Posted 5 years ago #

    Same problem here, running WordPress 2.5.1. I'm glad to know I'm not alone.

  7. Weston Ruter
    Member
    Posted 5 years ago #

    Hi everyone...
    Under "Miscellaneous Settings > Uploading", is the "Store uploads in this folder" field set to "wp-content/uploads"?

  8. tection99
    Member
    Posted 5 years ago #

    I added the full URL of the upload directory, now I seem to get this error.

    "Upload error: Missing a temporary folder."

    Do I need to create a temporary folder somewhere?

    thanks

  9. Weston Ruter
    Member
    Posted 5 years ago #

    Someone else had an upload directory of "/pics". This is bad. Do not put absolute paths here. It should instead be simply "pics". This should fix it.

  10. susanohnj
    Member
    Posted 5 years ago #

    I'm having the same issue, but only on one of three blogs.... I tried what you mentioned, but no luck...

  11. Weston Ruter
    Member
    Posted 5 years ago #

    What is your "upload path" set to?

  12. susanohnj
    Member
    Posted 5 years ago #

    wp-content/uploads

  13. Weston Ruter
    Member
    Posted 5 years ago #

    I just published a new version (0.9.1) with updated error messages which will be more helpful to diagnose what the issue is.

  14. ysriad
    Member
    Posted 5 years ago #

    hello

    I have installed user-photo plugin on wordpress 2.6.1 and its working fine. but on wordpress 2.3.1 its not working. it shows error--

    "Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /userphoto directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory."

    but my 'uploads' folder's permission is 777 as well as wp-content. i can upload other files and image from 'write post' page. but when i tried to upload user photo from user profile page it shows the above error. i hv also manually created the 'userphoto' folder inside 'upload' directory abd gave the permission 777. but it still showing the same error. does it work on wordpress 2.3.1. plz give me a solution. i hv to use wordpress 2.3.1 for my laguage compatibility.

  15. mafiamoso
    Member
    Posted 5 years ago #

    hi Guys,

    I have the same problem =(

  16. mafiamoso
    Member
    Posted 5 years ago #

    now I downgraded to version 0.8.1.. It seems that I can upload the image..but the file is empty.

  17. Jers
    Member
    Posted 5 years ago #

    Hi,

    Same problem here. Is there a line where we can hardcode the directory with the userphoto's. I just need it for one user.

  18. Weston Ruter
    Member
    Posted 5 years ago #

    Jers and Mafiamoso:
    What are the error messages you are receiving? Did you change the default upload path from "wp-content/uploads"?

  19. Jamie Birch
    Member
    Posted 5 years ago #

    I've tried everything and get this error:
    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /userphoto directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory.

    Do I need to create a folder and if so where? Then exactly what do I put in the upload directory under the Misc tab?

    Thanks!

  20. jlyon
    Member
    Posted 5 years ago #

    Not sure if this will help but trying going to:-

    http://www.yoursite.com/wp-admin/options-misc.php

    go to:

    - settings
    - miscellaneous settings
    and then uncheck

    Organize my uploads into month- and year-based folders

    This may help.

    I have a question as well:-

    How do I use User Photo with wp_list_authors to show current authors with their photo next to them in the side bar

    Thanks

    Jonathan

    jonathan.lyon@gmail.com

  21. connected888
    Member
    Posted 5 years ago #

    Getting the same errors, I have the default upload setting.

    Warning: mkdir() [function.mkdir]: open_basedir restriction in effect. File(/userphoto) is not within the allowed path(s): (/home:/usr/lib/php:/usr/php4/lib/php:/usr/local/lib/php:/usr/local/php4/lib/php:/tmp) in /home/public_html/press/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information - headers already sent by (output started at /home/public_html/press/wp-content/plugins/user-photo/user-photo.php:409) in /home/public_html/press/wp-includes/pluggable.php on line 694

    Maybe this plugin doesn't work with some hosts - could be the PHP setup.

  22. jessai
    Member
    Posted 5 years ago #

    you have to put absolute path something like that :

    /home/public_html/press/thewayyouwant.

  23. Weston Ruter
    Member
    Posted 5 years ago #

    Yes, either the absolute path from the system root, like:

    /home/public_html/press/thewayyouwant/wp-content/uploads

    Or a relative path from the WordPress install:

    press/thewayyouwant/wp-content/uploads

    Both should be good values for "upload path"

  24. Jamie Birch
    Member
    Posted 5 years ago #

    Maybe I'm a little dense, but I unchecked the box in settings as suggested above. I also changed the upload folder to this wp-content/authors/ and I still get this error in the user page:

    Upload error: The userphoto upload content directory does not exist and could not be created. Please ensure that you have write permissions for the /userphoto directory. Did you put slash at the beginning of the upload path in Misc. settings? It should be a path relative to the WordPress root directory.

    But I know it's there I created the folder.

    When I try to upload anyway, I get this error:

    Warning: mkdir(/userphoto) [function.mkdir]: Permission denied in /homepages/37/d253594647/htdocs/nfa/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/37/d253594647/htdocs/nfa/wp-content/plugins/user-photo/user-photo.php:409) in /homepages/37/d253594647/htdocs/nfa/wp-includes/pluggable.php on line 694

    HELP!!! lol :)

  25. mafiamoso
    Member
    Posted 5 years ago #

    my message error:

    Warning: mkdir() [function.mkdir]: Permission denied in /usr/share/wordpress_kmkiRR/wp-content/plugins/user-photo/user-photo.php on line 409

    Warning: Cannot modify header information - headers already sent by (output started at /usr/share/wordpress_kmkiRR/wp-content/plugins/user-photo/user-photo.php:409) in /usr/share/wordpress_kmkiRR/wp-includes/pluggable.php on line 694

    I have the default path wp-content/uploads

  26. jessai
    Member
    Posted 5 years ago #

    have you put a chmod 777 to wp-content/uploads ?

  27. Weston Ruter
    Member
    Posted 5 years ago #

    @jlyon:
    To use User Photo with wp_list_authors(), I think you could add a filter to the author name before calling wp_list_authors() and then remove the filter after calling it. Otherwise, iterating over all of the authors by hand will always work.

  28. Jamie Birch
    Member
    Posted 5 years ago #

    I have yes

  29. connected888
    Member
    Posted 5 years ago #

    @jessai & westonruter

    Where does the absolute or WordPress install relative path go? Is it a setting in the plugin somewhere or under WordPress Settings > Miscellaneous ?

    Those weird paths "lib/php:/tmp" are being pulled from somewhere automatically, I'm not sure where. Everyone is getting different random paths so i guess they're coming from the hosts' servers.

  30. Jamie Birch
    Member
    Posted 5 years ago #

    Westonruter - any suggestions for me?

Topic Closed

This topic has been closed to new replies.

About this Topic