WordPress.org

Ready to get started?Download WordPress

Forums

User Avatar
Broken code in 3.1 (6 posts)

  1. Sperry77
    Member
    Posted 3 years ago #

    It works - but when users attempt to upload a photo - they get this text 2x:
    "Warning: Invalid argument supplied for foreach() in /home/mysite/public_html/wp-admin/includes/plugin.php on line 1264"

    You can ignore the warning and continue and everything works fine, but I'm afraid that warning will scare people away from uploading a photo. Can you please fix?

    Thanks

  2. enej
    Member
    Plugin Contributor

    Posted 3 years ago #

    Hi Sperry77

    This error could be due to a different plugin that is installed on your wordpress instance.

    Can you see if it still appears if you disable all the other plugins except user-avatar.

    Another suggestions would be to remove warning reporting on your live site and only have warning display on your development instance.

    Cheers Enej

  3. Sperry77
    Member
    Posted 3 years ago #

    You were correct. It shows the Warning message when the [Plugin: WP Hide Dashboard] is installed alongside it. However, I really want this plugin installed as it removes the Dashboard menu, the Personal Options section and the Help link on the Profile page and prevents Dashboard access to users assigned to the Subscriber role.

    Any ideas for a fix?

  4. enej
    Member
    Plugin Contributor

    Posted 3 years ago #

    I am no sure... I took a short look at the WP Hide Dashboard and I can't say why the error happends exactly. I would turn warnings off on your production server and try to fix it in the development. Make sure that the plugin is not loaded on the pages so it will not break them.

    Ask for help from wp-hide-dashboard users.

  5. cinoslaw
    Member
    Posted 3 years ago #

    Also have this problem ... :)

  6. enej
    Member
    Plugin Contributor

    Posted 3 years ago #

    I did some changed to the plugin that might have fixed this issue are you running the latest version. I am sorry but I can't make sure that the plugin doesn't break every plugin. I am just trying to follow best practices and hope for the best.

    If you create a fix for the issue let me know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic