WordPress.org

Ready to get started?Download WordPress

Forums

User Access Manager
Upgraded from 1.0.2 and plugin broke (6 posts)

  1. James
    Member
    Posted 3 years ago #

    Version 1.0.2 was working well until I upgraded automatically to 1.1.

    My "Editor Group" had these settings:

    Read access: all
    Write access: Only group users

    I restricted a category to this Editor Group, and now only logged-in editors can see posts assigned to the restricted category. To everyone else, the page is blank.

    The plugin didn't behave like this with version 1.0.2.

  2. GM_Alex
    Member
    Plugin Author

    Posted 3 years ago #

    Bug confirmed, I will see what I can do.

  3. James
    Member
    Posted 3 years ago #

    Parse error: syntax error, unexpected T_DNUMBER, expecting ',' or ';' in /home/.../UserAccessManager.class.php on line 32

    I changed Line 32 to:

    protected $uamVersion = 1.9;

    The plugin activated, but no access when Read = all

  4. Samuel
    Member
    Posted 3 years ago #

    I wrote up a work around, you have to uninstall completely but it does the job;

    http://wordpress.org/support/topic/plugin-user-access-manager-parse-error-syntax-error-unexpected-t_dnumber-expecting-or?replies=3

    edit: this is to fix the parse error

  5. GM_Alex
    Member
    Plugin Author

    Posted 3 years ago #

    Fixed in version 1.1.1.1

  6. GM_Alex
    Member
    Plugin Author

    Posted 3 years ago #

    @pwayboy: Could you send me an e-mail. I think I have fixed the "Read/Write Access" bug but a tester would be nice.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic