WordPress.org

Ready to get started?Download WordPress

Forums

User Access Manager
Unable to set any access (3 posts)

  1. Mark
    Member
    Posted 3 years ago #

    Hi Alex

    was just about to deploy to the customer and upgraded - but now it is messed up!

    upgraded WordPress to 3.0.1
    upgraded UAM to 1.1.4
    Am using it to control access to pages.
    Now everything is open to all users and am unable to set access either on posts or on users. Tick any of the groups, save and then look again - the setting is not saved.
    Any suggestions to get it back working?!

    http://wordpress.org/extend/plugins/user-access-manager/

  2. Mark
    Member
    Posted 3 years ago #

    OK, for the benefit of anyone else this happens to...

    Take a backup of the database (why not)
    Uninstall and delete the files for the plugin
    Re-install the plugin

    You should find that the user groups that you set up are still there, except they have lost all their settings (which was what you had before after the upgrade).

    However now you have re-installed you should be able to set the users to their groups and the pages to their groups, test a couple to make sure - the pages and users now hold their settings after you save.

    Once you have done that, you are back in business!

    (Alex: if this happens again with an upgrade and it can't be avoided then it is a bit of a fright that everyone can access everything - it would be better if you could set something so no-one can access anything)

  3. marcycapron
    Member
    Posted 3 years ago #

    @markryderbluesparkcouk I'm having this problem but reinstalling etc isn't fixing it... boxes stay ticked, but no pages/posts are actually protected.

    argh! hmmm. though, this was a fresh install, not an upgrade. I am using 3.0.1 and 1.1.4, though.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic