WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Use Google Libraries] Fatal error after one hour that i have active (9 posts)

  1. Kykkyus
    Member
    Posted 3 years ago #

    Hi, when i use google-libraries i have this:

    Fatal error: Cannot access protected property JCP_UseGoogleLibraries::$google_scripts in /var/www/virtual/[site]/wp-content/plugins/use-google-libraries/use-google-libraries.php on line 67

    and i can’t use it. My free host block drang and drop with worpress. I have installed google-libraries and it all works good, but after one hour it give me that error. How i can solve it? Or there is some other plugin such as google-libraries? because i see the word in white in post's editor and i can't use it, i can't drag and drop and some other problmes that google libraries solve for me...
    Thanks

  2. Jason Penney
    Member
    Posted 3 years ago #

    I've never heard of such an error. It seems that for some reason your PHP install isn't letting an instance access it's protected class members. A quick web search points to it possibly being some sort of hosting configuration issue. It might be related to use of a php accelerator (like eaccelerator). Do you happen to know if there's one running on your host, and if so what version? Also, what version of PHP are you running on that host?

  3. Kykkyus
    Member
    Posted 3 years ago #

    thanks for replay, i don't know if there is some php accelerator and php version, i ask to hosting support forum, when they tell me the answer i will post that here.

  4. Kykkyus
    Member
    Posted 3 years ago #

    i have the raply from ufficial supporto:

    PHP Version 5.2.0-8
    eAccelerator Enabled

    Any workarounds? Thanks!

  5. Jason Penney
    Member
    Posted 3 years ago #

    The best option would be to upgrade to a version of eAccelerator that doesn't have this bug, but if that isn't a choice, you could try changing the protected variable to private, or even public, in use-google-libraries.php and see if that clears up the issue for you.

  6. Kykkyus
    Member
    Posted 3 years ago #

    thanks for replay. how i can change protected variable?

  7. Jason Penney
    Member
    Posted 3 years ago #

    Find these lines in use-google-libraries.php:

    protected $google_scripts;
    protected $noconflict_url;
    protected $noconflict_next;
    protected $is_ssl;
    protected static $script_before_init_notice

    And change protected to private.

  8. Kykkyus
    Member
    Posted 3 years ago #

    THANKS A LOT IT WORKS!!!!!!!!!!!!!

  9. Jason Penney
    Member
    Posted 3 years ago #

    That's great! Glad to heard it worked.

    For anyone else encountering this, it's apparently an old eAccelerator bug that's been fixed in later versions, but it does seem to pop back up now and again:

    http://eaccelerator.net/ticket/236
    http://eaccelerator.net/ticket/359
    http://eaccelerator.net/ticket/408

Topic Closed

This topic has been closed to new replies.

About this Topic