WordPress.org

Ready to get started?Download WordPress

Forums

URL Shortener
[resolved] 3.1.2 URL plugin (8 posts)

  1. David Winter
    Member
    Posted 3 years ago #

    Unfortunately the plugin isn't working on an upgrade to WP 3.1, I confirmed it wasn't theme related as it applies to all my sites (4) with different themes.

    The effect is that trying to post in the dasboard on both pages and posts the 'Visual' tab shows a the HTML code the same as the 'HTML' tab and the toolbar is NOT available at all.

    Disabling the plugin restores full functionality of the dashboard.

    Hope you can fix it soon as it is very useful.

  2. Gerald
    Member
    Plugin Author

    Posted 3 years ago #

    @David Winter:

    Your plugin issue has been noted. I'll try and reproduce the bug and release a bugfix soon.

    Just a clarification, the visual editor is not working when you enable the plugin.. is this correct?

    On another note, as it's my mid-term exams in school, I can only look into the matter in about 2 weeks time.

    Thanks.
    Regards
    Dev.

  3. David Winter
    Member
    Posted 3 years ago #

    Correct Gerald - the visual (WYSIWYG) editor doesn't work at all and only trying the 3.1 upgrade on different themed sites did it show up as a plugin conflict and selectively deactivationg them highlighted it as the URL Shortener. Both Visual and HTML tabs show the same content (html code) and the toolbar (fonts, alignment, colours, links et al ) does not load at all.

    Hope you are successful

  4. Gerald
    Member
    Plugin Author

    Posted 3 years ago #

    @David Winter:

    I can't replicate the problem on an install of WordPress 3.1 with only URL Shortener 3.1.2 activated.

    Could you give me a list of your plugins in used?
    The problem may be due to a conflict between 2 plugins rather than with WordPress Core.

  5. David Winter
    Member
    Posted 3 years ago #

    Hi Gerald

    Being aware of plugin conflicts I have run the sites with all plugins deactivated - no problems - with only URL shortener activated - Visual editor not avaialble - all plugins apart from URL Shortener activated - editor works OK. Every time I reactivated your plugin I have issues.

    I am running four sites with three different themes, Arras, Eximus and Intrepidity because I thought it could be a theme conflict but even though two of those are from the same author (possible duplicate coding)the third one isn't.

  6. Gerald
    Member
    Plugin Author

    Posted 3 years ago #

    @David Winter:

    Hmmm... Interesting....

    What's the shortening service you're using? I'll have to check if there were changes to the API implementation as well... it may be another possible cause.

    Looks like I'll run more tests when I finish my exams.

  7. David Winter
    Member
    Posted 3 years ago #

    bit.ly

  8. Gerald
    Member
    Plugin Author

    Posted 3 years ago #

    Okie.. Thanks. Will update again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic