WordPress.org

Ready to get started?Download WordPress

Forums

[plugin: updraftplus] 'UpdraftPlus Notice' wraps entire page in (1 post)

  1. cvc1968
    Member
    Posted 1 year ago #

    This may be an edge case. I've installed UpdraftPlus on my local development site, which has a url like this: mysite.dev. Once live, the site will live at mysite.com. I've gone through all the steps to authenticate with GDrive, but it will only allow you to set the redirect using the .com URI.

    This means that until the site is uploaded to mysite.com, I cannot complete the Gdrive to UpdraftPlus authentication step. Which means that UpdraftPlus is showing the UpdraftPlus notice at the top of all my pages in WordPress admin.

    Here is the first problem...That notice is wrapping basically every element on the page in (as in this example from my Plugins page):
    <a href="?page=updraftplus&action=updraftmethod-googledrive-auth&updraftplus_googleauth=doit">Plugins </a>
    Which in some cases, makes the page unusable.

    The second issue is that the link produces a "You do not have sufficient permissions to access this page." error. Even the legitimate link 'Click here to authenticate your Google Drive account (you will not be able to back up to Google Drive without it).' within the notice produces this error when clicked.

    Presumably, I can disable the plug in on dev and only enable it once its on mysite.com and be fully authenticated. That should disable the notice and the problem should therefore not exist. Still, thought you should know about it.

Topic Closed

This topic has been closed to new replies.

About this Topic