WordPress.org

Ready to get started?Download WordPress

Forums

Plugin update function broken (9 posts)

  1. tin68
    Member
    Posted 5 years ago #

    I upgraded WP from 2.6.5 to 2.7.

    Now the update function for plugins seems to be broken - if I want to automatically update an active plugin I get

    Upgrade Plugin

    Downloading update from http://downloads.wordpress.org/plugin/sociable.2.9.8.zip

    Download failed.: Operation timed out with 0 out of -1 bytes received

    Plugin upgrade Failed

    Any help?

  2. tin68
    Member
    Posted 5 years ago #

    No idea?

    In the error-log of the server I find:

    Sun Dec 14 20:39:24 2008] [error] [client xx.xx.xx.xx] client denied by server configuration:
    /home/httpd/vhosts/blogkom.net/httpdocs/wp/wp-content/plugins/wp-dbmanager/images/database.png,
    referer: http://www.blogkom.net/wp/wp-admin/update.php?action=upgrade-plugin&plugin=wp-db-backup%2Fwp-db-backup.php

    What server configuration must be enabled that WP can install a new plugin?

  3. tin68
    Member
    Posted 5 years ago #

    This problem seems to be related to the other problem I sent in - or better so say - it seems that both problems have the same cause.

  4. techdog
    Member
    Posted 5 years ago #

    I too have been experiencing this issue with several different plugins. I love the changes to 2.7 but I would like to see this back and working.

  5. 14words
    Member
    Posted 5 years ago #

    I get this error as well with plugin updates. Never had this problem with the 2.7 nightly builds, just the final 2.7.

  6. tin68
    Member
    Posted 5 years ago #

    @14words
    Really - very strange...

  7. RoarinRow
    Member
    Posted 5 years ago #

    I'd be interested in this fix as well. My RSS feed in the Admin Dashboard are not working either.

  8. NetSpider
    Member
    Posted 5 years ago #

    WP 2.8.1, same trouble =(

  9. NetSpider
    Member
    Posted 5 years ago #

    i've found solution!!

    Download and install this plugin manually: http://wordpress.org/extend/plugins/core-control/ Once you've activated it, Load the "Core Control" settings page and activate the "HTTP Module". Go to the new tab fore the "HTTP Module" and test cURL. You will most likely receive the following error message "An Error has occured: name lookup timed out" Now click the "Disable Transport" link in for cURL. You should now be able install plugins and plugin updates.

    in my case, PHP HTTP Extension got error 200!

Topic Closed

This topic has been closed to new replies.

About this Topic