WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate TinyMCE
[resolved] "Save scrollbar position" option causes error in widget editor (13 posts)

  1. Marco Chiesi
    Member
    Posted 2 years ago #

    Hello Josh,
    here are further details about compatibility issue between Ultimate TinyMCE and Black Studio TinyMCE Widget, as we were discussing previously.
    When keeping the option "Save scrollbar position in editor" enabled, the editor instances created by Black Studio TinyMCE Widget give a javascript error when initializing the editor.
    Would it be possible to fix the issue on your side, by only considering that option in post/page edit screens, and not on widget administration screen?
    Thank you.

    http://wordpress.org/extend/plugins/ultimate-tinymce/

  2. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Hi Marco, thanks for following up on this for me.

    I have a pretty full day, today. But I will get on this when I get back home this evening.

    I haven't researched this fully... so perhaps you could save me a little bit of time.

    Is there a conditional to check whether or not the page being loaded is a post/page content editor?

  3. Marco Chiesi
    Member
    Posted 2 years ago #

    I believe the following should be enough:

    global $pagenow;
    if ($pagenow != "widgets.php") {
    ...
    }
  4. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Got it. You're awesome!

    Working on it now.

    I won't be at my home computer for a few hours.

    If I sent you the updated file... could you load it and test it for me?

    Do you have "Ultimate Tinymce" installed where you can test?

  5. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Okay, after adding the conditional... everything still works properly on my end.

    I've tested with your plugin and all appears fine. I have also written the changes into my next plugin update (which I'm about ready to release).

    However, I would appreciate if you would test this for me also... as you know your plugin MUCH better than I do.

    I only needed to change one file in my plugin. Perhaps I can email this file to you and you can overwrite the original on your installation for testing purposes?

  6. Marco Chiesi
    Member
    Posted 2 years ago #

    Sure, I can test the file. You can send it to (marco*blackstudio*it).

  7. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Thanks. File has been sent.

  8. Marco Chiesi
    Member
    Posted 2 years ago #

    Hi Josh,
    I tested your file. The javascript error disappeared but unfortunately now the editor doesn't load at all (both in widgets and in posts/pages edit screens).
    I believe it is due to some missing files that have been added/moved in your in progress version, but that are not found in my test environment (Ultimate TinyMCE v.2.4). In particular I noticed that there are two 404 (not found) errors on these:
    - /wp-content/plugins/ultimate-tinymce/jwl_span/jwl_span.js?ver=345-20111127
    - /wp-content/plugins/ultimate-tinymce/layer/editor_plugin_src.js?ver=345-20111127

    I also noticed another alert (given by Google Chrome):
    - Resource interpreted as Script but transferred with MIME type text/html: "http://.../wp-content/plugins/ultimate-tinymce/shortcodes-editor-selector/editor_plugin.js.php?ver=345-20111127
    This is harmless and it appears also with the original file. It should be sufficient to put a Content-type header on that file to avoid it.

    Cheers.

  9. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Shoot. Sorry. I forgot I also made some other modifications for my newer version which were also in that file.

    I am sending you a zipped file of the new version.

    I tried replicating the notice with Chrome. How (and when) exactly were you receiving this notice?

  10. Marco Chiesi
    Member
    Posted 2 years ago #

    With the zipped file version everything works fine :-)

    The warning I was talking about appears in Google Chrome Console (Warnings or All), for all pages where the editor is used (new post/page, edit post/page, widgets, ...), but only if the option "Shortcodes Select Button" is enabled. Anyway, I think it's not a big problem, since it's just a warning.

  11. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Awesome! Thanks for working this out with me!!

    Okay. Still, I like to have all code playing nicely :)

    I don't mean to be persistent... but, I'm still learning Chrome. I hadn't ever used it before now. I'll try to find the Console which you are referring.

    You mentioned adding a Content-type header on that file.

    Do you mean the editor_plugin.js.php file? Do you have any idea which content-type I should use?

  12. Josh (WP Edit)
    Moderator and Editor Customizer
    Plugin Author

    Posted 2 years ago #

    Okay, it seems kind of like Mozilla Firebug.

    I right-click and "inspect element". Then, I click on "Console" in the tabs.

    All I have is a small blue arrow pointing to the right. Kind of like a cursor insertion prompt.

    Is this where you are receiving the notice?

    OFF SUBJECT: Can you please send me any graphics (if you have them) of your plugin? Something about 300px by 200px would be ideal. And would you like me to link it to the wordpress download page, or your personal website page?

  13. Marco Chiesi
    Member
    Posted 2 years ago #

    Hi Josh,
    sorry for the late answer. You are right about Chrome Console, it's almost like Mozilla Firefox's Firebug. The warning appears exactly in the place you are referring to (it is possible that you may have to select "All" or "Warnings" at the bottom of the Console).
    Yes, the file is editor_plugin.js.php and I think it should be fine to put a header like this:
    header('Content-type: application/javascript');

    OFF SUBJECT: I will send you the images by email. I also added a link to Ultimate TinyMCE into the plugin's page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.