WordPress.org

Ready to get started?Download WordPress

Forums

Ultimate Blogroll
[resolved] "addlink" and "more" link don't work (22 posts)

  1. markus.leder
    Member
    Posted 1 year ago #

    I installed the ultimate blogroll and set the page it should appear on.
    Then I added the widged in the rightside column.

    When I go to the page, and click the "addlink", nothing happens... when I click the "more" link, the same page opens.

    The links only work on the designated(?) page itself.

    http://wordpress.org/extend/plugins/ultimate-blogroll/

  2. otechwebmaster
    Member
    Posted 1 year ago #

    I have the same problem after updating to the latest WP...
    Work't fine before...
    I rely hope the developer will fix this problem soon...
    Love this plug-in!!!

  3. tinaponting
    Member
    Posted 1 year ago #

    I go to the page, and click the "addlink", nothing happens... when I click the "more" ?? tried to reinstalled it but not working!!
    on my blog: hXXp: ottsjopunkten.tk, please help me:)

  4. lucienv1
    Member
    Posted 1 year ago #

    Can this plugin be fixed please? It's awesome but not if it's not working :)

    I have the same problem on 3 sites, addlink & more does not work.

  5. nhr2k
    Member
    Posted 1 year ago #

    Hey Guys. I was testing out this plugin and found the same issues. I'm not sure where the developer is, so I dug into the code and found a quick fix.
    If you are not comfortable or capable of editing a file directly through wordpress, then this is NOT going to work for you and this is only a temporary solution until the developer does something about the problem.

    1) From your WordPress Dashbord, go to your Plugins -> Editor section.
    2) Look on the upper-right hand corner of the page for a dropdown-list "Select plugin to edit:" which contains a list of your plugins.
    3) Select the Ultimate Blogroll from the list.
    4) On the right of the page, you will see "Plugin files".
    5) Locate the file "ultimate-blogroll/domain/Widget.php".
    6) Click on the file to load it in the editor.
    7) Do a text search in your browser (CTRL-F in Firefox) and search for "More". This will take you to the 2 offending lines of code:

    $gui .= "<li><a href=\"".get_permalink(Mapper::getInstance(Mapper::Settings)->getConfig("permalink"))."\">".__("More", "ultimate-blogroll")."</a></li>";
    $gui .= "<li><a href=\"".get_permalink(Mapper::getInstance(Mapper::Settings)->getConfig("permalink"))."#wp-add-your-site\">".__("Add link", "ultimate-blogroll")."</a></li>";

    I'm really not sure what the purpose of the "More" link really is, so I removed it entirely. On the second "Add Link" line, here is what you should replace it with, making sure to change the section "your-link-page-here" to whatever your link page url is. Notice the single quotes and make sure you do the same.

    8) $gui .= "<li><a href='/your-link-page-here/#wp-add-your-site'>Add Your Link</a></li>";
    9) Save the page and that's it! You're done. Test it out and make sure it's working, if not, go back in and edit the file according. I customized the anchor text "Add link" to "Add Your Link" for my own personal taste, you can modify as you wish.

    If you have any problems, just reply here. Thanks to the developer of the plugin and hopefully you come back with an update to fix this properly, rather than my edit.

    Cheers and hope you all get it working.

  6. webgames
    Member
    Posted 1 year ago #

    I have the same problem. I tested the nhr2k solution, but didnĀ“t work.
    Does someone can help me in order to solve this problem.
    Thanks in advance.

  7. nhr2k
    Member
    Posted 1 year ago #

    Hey Webgames. I looked at your site and the link to your page is working, but for some reason your link page is empty. You may want to try and creating or re-creating the page and selecting it again from the Ultimate Blogroll settings. I added the plugin to and your link to my blog, so you can see for yourself here. Let me know how it goes.

  8. tinaponting
    Member
    Posted 1 year ago #

    I tried it:( and my blog crashed!

  9. nhr2k
    Member
    Posted 1 year ago #

    Sorry to hear that. Where's the link to your blog?

  10. webgames
    Member
    Posted 1 year ago #

    Hi nhr2k, I already try again to create, recreate the page but still not working. Do you have more ideas?

  11. nhr2k
    Member
    Posted 1 year ago #

    Hey Webgames. Seems like the edit you followed from me worked. For some reason, the plugin is not generating the info for your link page. Maybe there is a plugin or template conflict. I'm sure what it could be. You would have to go step by step disabling each plugin to see which one may be causing the issue. You an email me directly and maybe I can help you better. just put "me@" in front of the name of my blogs domain, and thats my email address. Good luck with whatever you choose to do.

  12. donramon
    Member
    Posted 1 year ago #

    who knowe's how to remove the link Cadeauwebwinkel.be n/a n/a n/a n/a n/a

    in editor where can i find the link in editor to remove in Ultimate Blogroll

  13. nhr2k
    Member
    Posted 1 year ago #

    @donramon Take a look at the UB settings page and turn off "Support developer". Have you gotten the plugin to work properly?

  14. donramon
    Member
    Posted 1 year ago #

    certainly overlooked thanks nhr2k , and thanks for your tip for the quick fix "addlink" works well here thanks ;)

  15. nhr2k
    Member
    Posted 1 year ago #

    Just thought I'd let everyone know, that Webgames and I were able to get the plugin working for him on his website. My quick-fix worked, but there is a conflict with Ultimate Blogroll and other plugins that use Facebook features, "like" button. So if your issue is the link page is blank, check for those kind of conflicting plugins.

    Good luck everyone.

  16. tinaponting
    Member
    Posted 1 year ago #

    Please! HELP ME! http://ottsjopunkten.tk/your-link-page-here/#wp-add-your-site
    I cannot get it working!

  17. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    First of all I am sorry for my delayed reaction. New house, new job, I am now settled and have time to work on Ultimate Blogroll. I will continue to support Ultimate Blogroll I am currently making a list of all the bugs and possible improvements. Do you have anything that disturbs you?

  18. nhr2k
    Member
    Posted 1 year ago #

    @jensg, nice to have you back.

    As you can see from the posts on here, there are a few problems with the plugin. The "More" and "Add Link" links do not link the proper section of the website.

    There are also a few conflicts with Facebook plugins, that cause the actual link page associated with UB, not to display at all.

    I've also noticed that with the latest WordPress update, this error:

    Warning: Missing argument 2 for wpdb::prepare(), called in /home/nhr2k/public_html/ilovesexcams.com/wp-content/plugins/ultimate-blogroll/persistence/LinkpartnerMapper.php on line 64 and defined in /home/nhr2k/public_html/ilovesexcams.com/wp-includes/wp-db.php on line 990

    shows up at the top of the page. Would it be possible to have, rather than selecting a "page" as the link page, to be able to insert code that would allow the UB link section to show up?

    Thanks for a great plugin. Congrats on the job and house too! Happy Holidays and I look forward to Ultimate Blogroll in the New Year!

    Cheers!

  19. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    As you can see from the posts on here, there are a few problems with the plugin. The "More" and "Add Link" links do not link the proper section of the website.

    This is due to a trailing slash ("/") I will add a check for that.

    There are also a few conflicts with Facebook plugins, that cause the actual link page associated with UB, not to display at all.

    Could you be specific? If you can give me a name I can take a look at it.

    I've also noticed that with the latest WordPress update, this error:

    I will fix this error

    Would it be possible to have, rather than selecting a "page" as the link page, to be able to insert code that would allow the UB link section to show up?

    I will take a look at it, but first I will add unit tests to the plugin. That way I can assure the quality of the plugin.

    I will fix the errors, then add unit tests and if all that is done I will take a look at new features.

  20. worldcommunity
    Member
    Posted 1 year ago #

    Hi jensg when will this plugin be updated and working,realy want to use your plugin,but dont want to install it before its working prober.

  21. jensg
    Member
    Plugin Author

    Posted 1 year ago #

    All the issues should be fixed, unless you come at the facebook plugin (which should also be fixed, I used a prefix (Ub) to avoid name collisions). I will mark this topic as solved.

  22. tinaponting
    Member
    Posted 1 year ago #

    Many Thanks:) And Happy new year:)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic