WordPress.org

Ready to get started?Download WordPress

Forums

UK Cookie Consent
[resolved] More info link not working? (23 posts)

  1. mikeotgaar
    Member
    Posted 2 years ago #

    Found the "More info" link didn't work when plugin installed.
    This can be easily fixed by plugin users - in the Info page name field in plugin settings, just add a forward slash in front of page name - i.e. /cookies instead of just Cookies (and change to all lower case if your WP installation uses case sensitive URLS)

    http://wordpress.org/extend/plugins/uk-cookie-consent/

  2. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    I'm not convinced that the forward slash is necessary. Seems to be working well enough for others - though will check about this and your point about case sensitivity and update.

    Thanks for posting.

  3. splashpuddle
    Member
    Posted 2 years ago #

    Great plugin, but I agree with Mike, the More Info doesn't work. I get the 404... The page it is supposed to create automatically is not created.

  4. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Okay, I'll fix that and issue a new version. Are you changing the name of the more info page?

  5. mikeotgaar
    Member
    Posted 2 years ago #

    My apologies Catapult - I meant the slash should be at the END, not the beginning of the page name.
    I think whether it works or not with or without the trailing forward slash depends on the Permalink structure. It may be fine for a default WordPress set-up. Mine uses trailing slashes, other sites/blogs can have different structures
    Splashpuddle - check if the page is in your list of pages - mine was. Open the page then paste the URL to the page - (leaving out the domain part). My article describes this "The Info Page link May Not Work"
    Nice lightweight plugin...
    Once again, apologies for the typo...

  6. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Ah, now that makes sense. I'll update so that it always includes a trailing slash.

    Thanks for the feedback.

  7. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Version 1.2 just uploaded to include trailing slash fix.

  8. spbriggs
    Member
    Posted 2 years ago #

    I've installed on a couple of sites and found the cookie policy page only appears if I first try to edit it in the backend. Is this a bug or did I just miss a bit in the installation instructions in my haste?

    Great plugin otherwise. Perfect, easy way to deal with a stupid bit of legislation.

  9. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for the feedback. Could you clarify 'only appears'? The page gets generated when you install the plug-in otherwise you wouldn't be able to edit it in the back-end.

  10. spbriggs
    Member
    Posted 2 years ago #

    I get a 404 when I click through to the "more info" page. Likewise, it doesn't show in my menu structure.

    I then go to the backend to edit the page (don't actually edit or save it) and suddenly the link works. I have permalinks enabled on the sites. See http://www.fridayemails.com for example.

  11. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm... That's something for me to look at for the next version.

    I'd suggest that if you're installing it on another site, to go to its settings page and click Save Updates, whether you've updated the settings or not.

    I will investigate further.

  12. HGeorge
    Member
    Posted 2 years ago #

    Hi there,

    I have just downloaded this great plugin - however the 'cookie info' page does not work. I have followed the instructions suggested by mike otgaar. However there is no 'info page name' in this version. I'm using the latest version of twenty eleven...
    see below for error code which comes up when more info is clicked on

    http://hellogeorge.co.uk/HelloGeorge/wordpress/cookie-policy/

    Any help on how i can activate the page?

  13. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Hi. I think there are two things here. If you go into Pages, just double-check that the Cookie Policy page has been created. If not, you need to go into Settings > Cookie Consent and hit Save Changes (even if you don't change anything).

    The second thing is a bit more problematic. The plug-in assumes you've got your permalinks set to 'post name'. If you haven't (and it's not an option for you), I'll need to make an update to the plug-in to accommodate this.

  14. HGeorge
    Member
    Posted 2 years ago #

    Thank you catapult. I have followed your instruction and it worked. Great plugin.

  15. mudandroutes
    Member
    Posted 2 years ago #

    Hi - it's the same here - I'm not using those type of permalinks and the find out more doesn't work for me, even if the page is there via the default path:
    e.g. http://www.walkuptheben.co.uk/?page_id=210 works perfectly
    but http://www.walkuptheben.co.uk/cookie-policy/ just takes me to google?!

    A way to manually change the link would be ideal if there's no way to do so automatically. I've tried changing permalinks, but that just borked the links completely.

    It works with my main site though, where the permalinks are set to numeric, so thanks for the plugin.

  16. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Those last links are spam - they just take me to a .ru site. Not nice.

  17. Samuel Wood (Otto)
    Tech Ninja
    Posted 2 years ago #

    Catapult: Which links are you referring to?

  18. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    The ones from the post above - walkuptheben. I clicked and was redirected to a .ru site. Not the same for you?

  19. Samuel Wood (Otto)
    Tech Ninja
    Posted 2 years ago #

    Nope, those look fine to me. Load up just fine, no redirects. Well, the last one redirects to Google, but he says that is the problem too.

  20. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm... I take it back. Apologies to mudandroutes.

  21. Otto, the second one sends me to http://24-medi.ru/timetose?19 too. So ... Something's odd, but I'm not sure it's the plugin, since there's no reason both a ?p=foo page and a pretty URL should resolve to different places.

    That is foo.com/?p=1 and foo.com/hello-world should both end up on foo.com/hello-world

    tl;dr, I think it's the case of not using pretty permalinks and something else on the site.

  22. Catapult
    Member
    Plugin Author

    Posted 2 years ago #

    Well at least I'm not going completely mad...

    First time I clicked, I went to the .ru site. After Otto queried, I tried again and went to the Ben Nevis site.

  23. mikeotgaar
    Member
    Posted 2 years ago #

    Very strange - his sites definitely redirceting - took me to Google too, with quite a delay
    could be something like VSF Simple Block plugin set to redirect 'cookie' or 'policy' in URL or one of the ad plugins conflicting.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic