WordPress.org

Ready to get started?Download WordPress

Forums

uCan Post
[resolved] "Ucan Post" localization (15 posts)

  1. bluebird2
    Member
    Posted 3 years ago #

    I wish this plugin was localized. It is the best-looking and the most user-friendly plugin for post-submission. But you cannot have it in languages other than English.

    http://wordpress.org/extend/plugins/ucan-post/

  2. cartpauj
    Member
    Plugin Author

    Posted 3 years ago #

    It supports other languages. It looks like I forgot to include a Template.POT file. I will create one for the next release that you can use with a tool like Poedit to translate into your own language. If you need more help hit me up at my forums at http://cartpauj.com/forum

  3. bluebird2
    Member
    Posted 3 years ago #

    Thanks. You need to name the "pot" file "ucan-post.pot" and place it in a folder called languages (or you can place it in the main folder.) Otherwise some translation devices cannot locate the localization file.

  4. bluebird2
    Member
    Posted 3 years ago #

    I translated the pot file but it didn't work on the site. The site still shows the english words. I think this is caused because the pot file and the translation files are in the folder "i18n".

  5. jimjimjim
    Member
    Posted 3 years ago #

    No, this method is working fine for all other plugins. Make sure you name the translated files ucan-post-LANGUAGE.po and ucan-post-LANGUAGE.mo and put them in the /i18n/ folder.
    Example the french language would be ucan-post-fr_FR.po and ucan-post-fr_FR.mo

    Open the .POT file in Poedit, translate and then do a SAVE-AS, this will generate the .po and .mo files for you, don't actually leave the .POT file translated.

  6. cartpauj
    Member
    Plugin Author

    Posted 3 years ago #

    Exactly thanks Jim.

  7. bluebird2
    Member
    Posted 3 years ago #

    That is what I did. The files are named "ucan-post-fa_IR.mo" and "ucan-post-fa_IR.po".
    It does not work.

  8. cartpauj
    Member
    Plugin Author

    Posted 3 years ago #

    Do you have them in the /i18n/ folder?

  9. bluebird2
    Member
    Posted 3 years ago #

    Yes. I do.

  10. cartpauj
    Member
    Plugin Author

    Posted 3 years ago #

    The last release fixes this. I apologize but there was an error in the directory structure for the i18n files. Should work fine now. Thanks for your patience on this one!

  11. bluebird2
    Member
    Posted 3 years ago #

    Thanks. That fixed the problem of localization. The only problem I have now is that the text box is LTR (left-to-right) for left-to-right languages. How can I change the default for the text box to RTL?

  12. bluebird2
    Member
    Posted 3 years ago #

    Thanks. That fixed the problem of localization.

    The only problem I have now is that the text box is LTR (left-to-right) for left-to-right languages. How can I change the default for the text box to RTL? Is it possible for you to add an option to the settings page for RTL languages?

  13. cartpauj
    Member
    Plugin Author

    Posted 3 years ago #

    Let me know if this works, try changing this (near the top of ucan-post-class.php):

    <script type="text/javascript">
                tinyMCE.init({
                  mode : "specific_textareas",
                  theme : "advanced",
                  skin : "o2k7",
                  editor_selector:"theEditor",
                  width:"80%",
                  theme_advanced_buttons1 : "bold,italic,underline,|,justifyleft,justifycenter,justifyright,fontsizeselect,formatselect",
                  theme_advanced_buttons2 : "cut,copy,paste,|,bullist,numlist,|,outdent,indent,|,undo,redo,|,link,unlink,image,media",
                  theme_advanced_buttons3 : "forecolor,backcolor,|,emotions,charmap,spellchecker,|,code,preview,|,help",
                  theme_advanced_toolbar_location : "top",
                  theme_advanced_toolbar_align : "left",
                  plugins : "emotions,preview,safari,spellchecker,media"
                });
              </script>

    To this:

    <script type="text/javascript">
                tinyMCE.init({
                  mode : "specific_textareas",
                  theme : "advanced",
                  skin : "o2k7",
                  editor_selector:"theEditor",
                  width:"80%",
                  theme_advanced_buttons1 : "bold,italic,underline,|,justifyleft,justifycenter,justifyright,fontsizeselect,formatselect",
                  theme_advanced_buttons2 : "cut,copy,paste,|,bullist,numlist,|,outdent,indent,|,undo,redo,|,link,unlink,image,media",
                  theme_advanced_buttons3 : "forecolor,backcolor,|,emotions,charmap,spellchecker,|,code,preview,|,help",
                  theme_advanced_toolbar_location : "top",
                  theme_advanced_toolbar_align : "left",
                  plugins : "emotions,preview,safari,spellchecker,media",
                  directionality : "rtl"
                });
              </script>
  14. tipluis
    Member
    Posted 3 years ago #

    This plugin is fantastic but strange that the plugin does not work here for videos

  15. bluebird2
    Member
    Posted 3 years ago #

    Thanks. That fixed it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags