WordPress.org

Ready to get started?Download WordPress

Forums

Types - Custom Fields and Custom Post Types Management
[resolved] Import / Export Not Functioning (7 posts)

  1. couturefreak
    Member
    Posted 2 years ago #

    Currently the export function returns a 404 error.
    We'd like to be able to export the custom post types.

    Thank you!

    http://wordpress.org/extend/plugins/types/

  2. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Is the 'export' page itself returning you a 404 error, or when you're clicking on the 'export' button?

    Can you paste the full URL of the export function here, so that we can see if the URL is mis-calculated in your site?

    Also, did you make sure that no file is missing from your install?

  3. Srdjan
    Member
    Plugin Author

    Posted 2 years ago #

    Subscribing...

  4. bondzinho
    Member
    Posted 2 years ago #

    ugh. nothing worse than setting up a dozen or so types and variables and custom fields on the development side just to find out you can't import them. PAINFUL.
    Further, I haven't seen such an unfriendly response to a failed action in years.
    After trying to import (all other plugins off...tried on different browsers) I get this

    "Import/Export
    Error parsing XML
    xmlParseEntityRef: no name"

    That's it.
    I tried it with just using the text import as well. Same msg.
    UGH! Completely unusable. I'm using the latest version of WordPress. And the latest version of the plugin. Would love to see a way around this.

  5. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Probably related to escape characters in the text. See this other thread:
    http://wordpress.org/support/topic/plugin-types-custom-fields-and-custom-post-types-management-import-doesnt-work

    If this is the case, we found the cause and it's being fixed for the next update.

  6. bondzinho
    Member
    Posted 2 years ago #

    Alright, I got rid of the ampersands in the XML files before importing (simply find and replace works like a charm), and boy am I happy. I wish i could edit my previous post (i said "completely unusable")...because with that little fix (admittedly difficult to find), I have been very very happy. Thanks.

  7. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Great. Thanks for confirming that it's working for you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags