WordPress.org

Ready to get started?Download WordPress

Forums

Types - Custom Fields and Custom Post Types Management
[resolved] Getting a "Invalid argument su (13 posts)

  1. jmamorteg
    Member
    Posted 2 years ago #

    I tryed to apply a relationship between a custon post-type to a parent post, and the plugin showed me an error saying:

    Warning: Invalid argument supplied for foreach() in XXX/wp-content/plugins/types/includes/post-relationship.php on line 200

    Warning: Cannot modify header information - headers already sent by (output started at XXX/wp-content/plugins/types/includes/post-relationship.php:200) in XXX/wp-includes/pluggable.php on line 866

    And all of a sudden I am getting 404 errors in every post, I can see my homepage since is not related to Types, but when trying to load the custom-post-type archive, a 404 shows up.
    site: http://www.cuadernoslobo.com/ediciones/

    http://wordpress.org/extend/plugins/types/

  2. Cinamonas
    Member
    Posted 2 years ago #

    Hey, see my bug report for a workaround.

  3. David Radovanovic
    Member
    Posted 2 years ago #

    Just received the above error as well when saving a New Custom Post. Going BACK to edit page with a Crtl F5 displays a "Custom post type saved".

  4. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Can I have your database dump, so see how this is happening?

    The workaround reported is fine, but you're reaching a condition which shouldn't happen and it would help if we could see what's actually triggering it.

    Let me know how I can email you and we'd like to get that DB for testing and fix the problem from its root.

  5. jmamorteg
    Member
    Posted 2 years ago #

    I am kind of lost with this issue, and not sure of what am I supposed to send you (Database Dump), please contact me through jmamorteg@dostruchas.net. Thank you a lot.

  6. Kristof
    Member
    Posted 2 years ago #

    Having the same issue as listed above. Also seeing that "Featured Image"is no longer available as an option to display with the custom post type.

  7. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Kristof, you're right. We 'over optimized' the content of the V popups, so the entire 'basic' group no longer appears. We'll add it back to the GUI in the upcoming bug-fix version.

    In the meanwhile, you can insert it manually to the text, using:
    [wpv-post-featured-image]

    from:
    http://wp-types.com/documentation/views-shortcodes/#wpv-post-featured-image

    We're also looking at the other problem reported here and we'll get that sorted as well.

  8. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Here's a patched version, which contains the fix for the warning you've been getting:
    http://d1ftqtsbckf6jv.cloudfront.net/types.9.5.1.zip

    The 404 error is not due to this. It's something that might happen when the WordPress rewrite rules get changed. To fix it, go to Settings->Permalinks and just save.

    Let me know if there are still 404 pages after that.

  9. Terrycy
    Member
    Posted 2 years ago #

    Hi Amir, thanks for the fix, I had just posted a question regarding the same thing, and just as I posted the solution, the post was deleted...

    Lesson learnt about reading other threads before posting!

    I did mention that I thought the error was a result of turning off the 'has_archive' option

  10. Kristof
    Member
    Posted 2 years ago #

    Hi Amir - The problem is that the Featured Image Meta box doesn't display so there's no way to add/upload a featured image. If I can't upload an image using the meta box, there's no way for me to call/display it in my Archive template.

  11. Kristof
    Member
    Posted 2 years ago #

    Amir - Feature suggestion for the image upload custom field.

    When selecting an image from either the Gallery or Media Library, it would be great if the WordPress Alignment and Size options could be used. Currently, the "Use as field value" only selects/uses the original, uploaded image. Thanks.

  12. jmamorteg
    Member
    Posted 2 years ago #

    The issue seems to be fixed with Amir's patched version. To avoid the 404 I had to set default permalinks and is working OK, I will try to set the Pretty Permalinks later to see what happens.
    Thank you very much, Amir

  13. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    If anyone else is going over this thread, please note that the new release fixes this problem. Instead of applying a patch, just download the current version.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags