WordPress.org

Ready to get started?Download WordPress

Forums

Types - Custom Fields and Custom Post Types Management
[resolved] Custom Fields Not Recognized - Agai (4 posts)

  1. HD15
    Member
    Posted 2 years ago #

    I posted yesterday about Types custom fields not be recognised by a CSV importer while other custom fields/taxonomies were recognized. I thought I had made a mistake by not scrolling down to the end of the custom fields list to see the wpcf prefix, but as it turns out there really is a problem in getting the Types custom fields recognized.

    Today I created 2 more Types custom fields and now these aren't recognised by the importer and I'm not just not seeing them. I've tried removing them from Types control and turn setting off and on but no luck. What's odd is that now I've noticed the fields I was working with yesterday - while I can import data into them and are recognised by the importer, now don't show up a new custom post, but they do show up on imported posts. Yes I've check and all the settings are right as far as I can tell.

    So there really does appear to be something wrong were the fields are either not recognised by the CSV importer or they don't display properly on new posts, but I can't figure out what I turned off in the first group to make the importer recognise them that now I can't turn on again to make it appear on a new custom post nor can I figure out how to get the new fields recognised by the importer....etc etc.

    Any help would be great!
    Thanks.

    http://wordpress.org/extend/plugins/types/

  2. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Maybe the importer is checking for post-meta entries. This means that you're not going to see these fields in the importer unless you've already created at least one post that uses these fields.

    You can:
    1. Create a dummy post and insert these fields.
    2. Use the importer to get everything in.
    3. Delete that post.

    If you want to fields to appear in the importer GUI without creating that dummy post, we'll need to work with the author of the importer plugin and explain to him how to read Types setup from the options table.

  3. HD15
    Member
    Posted 2 years ago #

    Thanks, Amir.

    I've already got a dummy post with the fields attached. On the first group of custom fields I had a dummy post with the fields inserted; the importer wouldn't recognise them; I then played around with the settings and now the importer recognises them, but now they won't display on new posts. The group name displays but the actual fields will not. I've gone through all the settings, and they are set to appear on the custom post type I'm working with etc etc.

    As this is a bit odd, I might just use the custom field creator that comes standard on wordpress, then import data, then try and change the settings so those fields are "under types control".

  4. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Honestly, it's very difficult for me to tell why these fields are not showing. There could be a number of possibilities and it's likely not exactly related to Types.

    If you conclude (and can reproduce it) that there's a bug somewhere, or compatibility issue, which you can trace to the code, we'll be happy to work on this with the other author.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.