WordPress.org

Ready to get started?Download WordPress

Forums

Types - Custom Fields and Custom Post Types Management
Bad Performance & Timeouts (11 posts)

  1. Strong Island
    Member
    Posted 2 years ago #

    Hi,

    I'm having serious issues with this plugin in regards to performance, it is taking ages to load pages and sometimes I get timeouts too. I have tested the WordPress install with no plugins and then with just this plugin and it is definitely this plugin that seems to be dragging everything down. It even runs the dashboard side of the website down to the point of timeouts too.

    http://wordpress.org/extend/plugins/types/

  2. Strong Island
    Member
    Posted 2 years ago #

    To show the website I've had to re-activate all the plugins, it is located at:

    http://www.wplinternational.com/wpl/home/en

    PHP Version 5.2.16

  3. Strong Island
    Member
    Posted 2 years ago #

    P.S. I have 11 different custom post types and one custom taxonomy

  4. Strong Island
    Member
    Posted 2 years ago #

    Can anyone help???

  5. Srdjan
    Member
    Plugin Author

    Posted 2 years ago #

    Can you provide some more info please?
    Are you using only custom types and taxonomies created by Types?
    Do you use custom fields (which ones)?
    Does your theme do something with custom types or taxes created by Types.

    If you use only custom types and taxonomies,
    there shouldn't be any performance issues.
    All Types do is - read your settings from DB for each and registers custom type/taxonomy. Nothing more.

  6. RoamFree
    Member
    Posted 2 years ago #

    Hmm. Look at the report for that URL on http://www.webpagetest.org/ and you find it takes 7 seconds for the first data to appear... and later several images take 3 seconds. I wouldn't expect your logo image to be served through Types.

    I wonder if a cache plugin would help.

  7. Francesco Canovi
    Member
    Posted 2 years ago #

    Hello. I'm having similar problems with a site with types and WPML and a big number of posts. We are still investigating it the problem is related with Types. In the meantime please write here if you find some solutions for your case... we are really going mad.

  8. Strong Island
    Member
    Posted 2 years ago #

    Hi,

    I have am using a cache plugin at the moment.

    My website uses Types in combination with Advanced Custom Fields. It is difficult to test the website pages with only one plugin activated.

    I have run tests with no plugins activated and just Types and the Dashboard of WordPress loads significantly slower.

    I'm going to try to optimise my code somewhat but there really does seem to be an issue with the plugin from what I can tell. A real shame as it ticks every other box for what I need.

  9. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    This plugin can tell you which queries are running:
    http://wordpress.org/extend/plugins/debug-queries/

    Want to use it and report what you're getting?

  10. Strong Island
    Member
    Posted 2 years ago #

    Thanks for the tip with that plugin, here are the results. Going by the summary at the bottom it seems that there aren't any heavy duty queries holding things up

    [Log moderated. Please use the pastebin]

  11. AmirHelzer
    Member
    Plugin Author

    Posted 2 years ago #

    Your comment got moderated. You'll need to paste that log somewhere else (pastebin was recommended).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags