WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Wings
[resolved] Twitter wings - tweets don't show (10 posts)

  1. msmisplaced
    Member
    Posted 2 years ago #

    I'm not sure what I'm doing wrong, but Twitter Wings isn't showing tweets. Everything appears to be set up correctly and other Twitter plugins work fine. Problem can be viewed on http://www.hoodmusic.net

    First widget is Twitter for WordPress, which works ok. Second is Twitter wings, which shows the follow button, but that's it.

    Any suggestions would be most appreciated.

    http://wordpress.org/extend/plugins/twitter-wings/

  2. joepahl
    Member
    Plugin Author

    Posted 2 years ago #

    Not sure what the problem is, but a couple of ideas.

    If you turn the other Twitter plugin off (actually deactivate it) is there still an issue? There could be a conflict between the dueling Twitter plugins.

    If turning the other plugin off doesn't fix the problem immediately, give it an hour. It's possible that Twitter for WP is serving up a cached version, and burning through the rate limit before Twitter Wings can access it.

    Hope this helps. Thanks for downloading.

  3. hyeagz
    Member
    Posted 2 years ago #

    I'm having the same issue with my Twitter Wings widget. I had some other Twitter plugins, which I deleted. Still lacking my updates. I do have the Facebook, Twitter & Google+ Social Widgets plugin on my posts, but I wouldn't think that would interfere.

    http://www.thenewmenmusic.com

  4. joepahl
    Member
    Plugin Author

    Posted 2 years ago #

    hyeagz,

    I don't think it's a conflict with the social widgets, but i could be a conflict with one of your plugins or the theme itself.

    What is more likely is that your server cannot connect to the Twitter API because the rate limit has been exhausted.

    A future version of the plugin will have a debugging option that will help diagnose these kinds of issues.

    If you know how, ssh on to your server and type curl http://api.twitter.com/1/account/rate_limit_status.xml. This will return something like:

    <hash>
    <reset-time-in-seconds type="integer">1320702143</reset-time-in-seconds>
    <reset-time type="datetime">2011-11-07T21:42:23+00:00</reset-time>
    <remaining-hits type="integer">146</remaining-hits>
    <hourly-limit type="integer">150</hourly-limit>
    </hash>

    If your remaining hits value is zero, you know that the rate limit is the issue. This may not be your fault. If you are on a shared server someone's site may be responsible.

    Good luck.

  5. msmisplaced
    Member
    Posted 2 years ago #

    Thanks for the advice. I deactivating all widgets except Twitter Wings and tried both the Twenty-Ten and Twenty-Eleven themes with no luck at all - Twitter Wings still wasn't working.

    I think I'll have to use another widget until a version with debugging is available as I can't ssh.

    Thanks again.

  6. clayboswell
    Member
    Posted 2 years ago #

    I'm having the same issue.

    Output from the curl command:

    me:~ > curl http://api.twitter.com/1/account/rate_limit_status.xml
    <?xml version="1.0" encoding="UTF-8"?>
    <hash>
    <remaining-hits type="integer">115</remaining-hits>
    <hourly-limit type="integer">150</hourly-limit>
    <reset-time-in-seconds type="integer">1321109694</reset-time-in-seconds>
    <reset-time type="datetime">2011-11-12T14:54:54+00:00</reset-time>
    </hash>

    I like the options that seem to be available with this widget so I hope this issue can be fixed.

  7. joepahl
    Member
    Plugin Author

    Posted 2 years ago #

    Can you send me a link to your site?

    Hope I can help. Thanks for downloading.

  8. clayboswell
    Member
    Posted 2 years ago #

  9. clayboswell
    Member
    Posted 2 years ago #

    I hope you can figure this out... I've tried nearly a dozen other twitter widgets & none seem to have the depth of configuration options as Twitter Wings.

  10. scanmaster
    Member
    Posted 2 years ago #

    I too love the twitter wings widget. Having same issue at http://scanmaster.com. Thanks if anyone knows a fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic