WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] No Tweets Available Message (on a site with little traffic) (11 posts)

  1. Morkouz
    Member
    Posted 1 year ago #

    Hi, I'm quite new to wordpress, i've recently updated to 3.4.2 and just found that my twitter feed isn't working anymore, i'm getting a "No Tweets Available" Message on my widget (bottom right on http://www.markseabridge.com/).

    The same seems to happen if I switch back to the feed widget built into my theme.

    From what i've read in the forum from other people getting this issue I can't think that its a hosting or traffic issue as its a personal portfolio website and I don't share the domain.

    Any help would be much appreciated.

    Thanks

    Mark

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. bythegram
    Member
    Posted 1 year ago #

    It looks to me that the plugin needs to be update to the new API (or at least the new change). This is the url it is calling:

    http://twitter.com/statuses/user_timeline/morkouz.json?callback=twitterCallback2&count=2

    which gives a 404 error.

    Hopefully the plugin developers catch it soon.

    By the way this url works:

    http://api.twitter.com/1/statuses/user_timeline.json?screen_name=morkouz&callback=twitterCallback2&count=3

    Now it would be just a matter of recoding the plugin to match that format.

  3. Morkouz
    Member
    Posted 1 year ago #

    Thanks for the quick response bythegram, I presume thats the same url on the built in twitter feed in the theme.

    If anyone knows of a simple twitter feed plugin that does work with the new API please let me know.

  4. bythegram
    Member
    Posted 1 year ago #

    I've built a scrolling twitter feed that currently works though will have to be updated before March 2013.

    http://wordpress.org/extend/plugins/twitter-feed-ticker/

    It's pretty basic in terms of design but It works for me.

  5. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    The API URL that it uses is correct (https://api.twitter.com/1/...). It will have to be updated by March to include Authentication for version 1.1 of the API, but it certainly works now.

    Chances are pretty high that the reason you're not getting Tweets is that you've exceeded your API request limit. However, that limit is not just on your site. It looks like eUKhost mostly focuses on shared hosting, which means there are many sites on your server not just yours, and sometimes multiple servers behind a single IP. The limits are based on IP.

    I just released an update. Try upgrading to 2.4.0 and then go to Settings->Twitter Widget and you'll be able to see a summary of current API usage.

  6. chrispinnock
    Member
    Posted 1 year ago #

    I have found a few issues with this plugin today, including lack of twitter feeds. If I put in the settings on the widget/appearance page they do not stick. However if I fill them out on the Settings -> Twitter Widget page everything works again.

  7. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    Chris: Please start another support thread so we don't lose the original problem from this thread in the shuffle.

  8. Morkouz
    Member
    Posted 1 year ago #

    Amazing, all working after the update 9and a few setting tweaks) - thanks Aaron.

    Just to let you know what I did to make it work, under Settings>Twitter Widget Pro>General Settings I changed the "HTTP vs HTTPS" setting to "Use Twitter API via HTTP" and also used the "Clear Update Locks" function (although I got an error message for that).

    For your reference the Current API Usage was as follows: Used: 1
    Remaining: 149, Limits reset in: 59 minutes.

    I'll go and give the update a rating now and then try a bit of styling, I presume there aren't any options for hyperlink colours/spacing between tweets that I've missed?

    Thanks again

    Mark

  9. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    There are classes that make things easy to style, but there are no styles built-in so that it conforms to your theme. You can add new styles to your themes style.css file.

  10. joel_birch
    Member
    Posted 1 year ago #

    I am now getting the "no tweets available" message and followed the problem to the tlc-transients.php file. On line 42 I changed the if statement to if ( true ) { and this seemed to fix the plugin (the tweets showed up, at least).

    So then I wondered why the else path was not working and noticed that on line 55 there is an if statement:

    if ( $data[0] !== 0 && $data[0] < time() )

    …so clearly the plugin expects $data[0] to be a time of some sort. I did print_r() to see what $data was and it showed the following (will only put the start of it here for brevity):

    a:2:{i:0;i:1360926814;i:1;a:7:{i:0;O:8:"stdClass":20:{s:10:"created_at";s:30:"Fri Feb 15 00:17:02 +0000 2013";s:2:"id";i:302209869153443840;s:6:"id_str";s:18:"302209869153443840";s:4:"text";s:136:"A scientist...[etc, actual tweet content here]...

    ...which does not seem to be what the plugin is expecting, even though it is not false, which would have sent the code down the working path of the above-mentioned if statement.

    Aaron, I hope this helps you figure out what is going on. I appreciate it's hard for you to debug a problem you can't replicate. Please let me know if I can help you with it.

    Cheers.

  11. joel_birch
    Member
    Posted 1 year ago #

    Sorry, to summarise: clearly get_transient() is returning the wrong datatype.

    What will happen if I set that first if clause to true until a real solution is in place? Caching won't work? Twitter will block us? World will explode?

    Ta.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic