WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
No Tweets Available (54 posts)

  1. Ryan Andrews
    Member
    Posted 2 years ago #

    Using version 2.3.3, Just says "No Tweets Available" even when there are.

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    Usually this means that your server can't connect to the Twitter servers. Likely because you're on a shared server and the IP has been limited or blocked. Do any other twitter widgets like Wickett Twitter Widget work?

  3. Ryan Andrews
    Member
    Posted 2 years ago #

    I fixed the problem in the code. The twitter api feed is not secure, you use https:// , it should be http://

    According to twitter's website, the api feed url is:

    http://api.twitter.com/1/statuses/user_timeline.format

    Hope this helps you. Twitter Widget Pro is working great for me now :D

  4. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

  5. Ryan Andrews
    Member
    Posted 2 years ago #

    Not sure what to tell you, other than that if you change it to http:// it works flawlessly and if it is https:// the widget reads "No Tweets Available"

    Ryan

  6. Matt Ruff
    Member
    Posted 2 years ago #

    FWIW, I'd been wrestling with the same problem for the past couple days. I just edited the code as Ryan suggested, and now my Twitter Widget Pro is working too...

  7. vlogolution
    Member
    Posted 2 years ago #

    we had the same problem, and changing from https:// to http:// worked for us too - thanks!

  8. Ryan Andrews
    Member
    Posted 2 years ago #

    no problem, that is definitely the issue. It works on all the servers I've tried when this fix is applied.

  9. dmurch
    Member
    Posted 2 years ago #

    Widget shows No Tweets Available. Using the most recent release and other Twitter feeds work so it's not my hosting company blocking Twitter. I'm on a dedicated IP anyway. I switched the https to http as suggested above and it appears to be working.

  10. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    I'm worried that the real issue is not http vs https. I think that all the change is doing is changing the hash so that whatever is stuck in the database is being ignored. You could try running this query to clear out the stored data and see if that helps:
    DELETE FROM wp_options WHERE option_name LIKE '_transient_%twp_%' || option_name LIKE '_transient_%tlc_%'
    (if you changed your table prefix, make sure that wp_options is whatever your options table is)
    You may want to run SELECT * FROM wp_options WHERE option_name LIKE '_transient_%twp_%' || option_name LIKE '_transient_%tlc_%' first to take a look at what you're deleting.

  11. qmarcos
    Member
    Posted 2 years ago #

    More feedback about this. I've changed my URL to http and is working. I think if you are requesting tweets from a HTTPS page the https url works, but if you are requesting them from a HTTP page it doesn't work.

    I have double checked the SELECT you recommend, and there are no records in the XX_options table with that condition, so I think this is not the problem...

    Hope it helps.
    Marcos.

  12. Dries Vints
    Member
    Posted 2 years ago #

    I can also confirm that the widget is working fine again after changing to http instead of https

    Dries

  13. blueidea05
    Member
    Posted 2 years ago #

    It Works!
    Just modify "https" to "http" in line 186 within wp-twitter-widget.php

  14. fabpicca
    Member
    Posted 2 years ago #

    Just to say that even in my case, switching from https to http solved the issue.

  15. redrockettattoo
    Member
    Posted 2 years ago #

    Probably a stupid question but...how do I get to the code in order to edit it?

  16. redrockettattoo
    Member
    Posted 2 years ago #

    Sorry...found the code. Just not sure where exactly I'm supposed to change https to http...

  17. ken.ph
    Member
    Posted 2 years ago #

    changing https to http worked for me too.

    but it wasn't line 186 but line 904 on wp-twitter-widget.php

    simple method:
    * just go to your list of installed plugins
    * under 'twitter widget pro' select 'edit'
    * in the opened page, go to the very bottom of the code
    * find 'http_vs_https' => 'http', (line 904 on editors)
    * save and refresh

    hope that helped others.
    thanks Ryan :)

  18. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    @ken.ph the line changed because it's an option you can easily change WITHOUT modifying the plugin.

    @redrockettattoo same thing, just change the option.

    In wp-admin go to Settings->"Twitter Widget" and it's the very first setting.

  19. chizhny
    Member
    Posted 2 years ago #

    I have switched from https to http and seemed like it was working. But a few days ago I have stopped seeing new tweets in my widget.

    http://pindosiya.com/ the widget is on the right side in the middle of the page and the last update was on January 17 :((

    All the versions are current. Any ideas what may cause a problem?

  20. chizhny
    Member
    Posted 2 years ago #

    Any ideas how to solve it?

  21. igotkat
    Member
    Posted 2 years ago #

    I've changed HTTPS to HTTPS in two places, the code and the plugin itself (there is an option at the top of it's settings page) and still nothing...

  22. marcusdervin
    Member
    Posted 2 years ago #

    Aaron, I changed the https to http in the plugin and it's not working. It was all fine before I upgraded, ah! It's on my home page.. http://www.webvine.com.au Be great to get a quick fix or a rollback option?

  23. noyz
    Member
    Posted 2 years ago #

    http not https... solved for me...

  24. Aaron D. Campbell
    Member
    Plugin Author

    Posted 2 years ago #

    I'm not so sure that http vs https is actually solving it for anyone. For some reason it seems that some people are getting update locks set and never cleared. Since the key for storing all this is based off a hash of the URL being called, changing from https to http changes it and ignores the lock that's stuck. The thing I'm having a hard time figuring out is HOW/WHY those locks are getting stuck, because I can't reproduce this still.

    For now I've added an option to "Clear Update Locks". Please test this out and see if clearing the update locks will get things moving again for you. I added it in version 2.3.7 which is available in the repository.

  25. marcusdervin
    Member
    Posted 2 years ago #

    I think mine cleared without adding the update, it just took some time, so I'll leave it now that it's working! Thanks Aaron, much appreciated.

  26. Roger Coathup
    Member
    Posted 2 years ago #

    We have the same problem... receive the message 'no tweets to display' for an hour or two, it then clears, only to come back again later.

    I've upgraded to v2.3.8

    Tweets displayed for a short while after the update - but then got the no tweets to display message.

    I've tried the clear locks option - and received a 'no locks to clear' notification - tweets still not displaying.

    I switched to http: instead of https: - tweets still not displaying

    Our site is fairly heavy traffic (up to 10,000 page views / day, and approx. 10 new user registrations / hour). Could there be a race condition that the plugin locks can't cope with?

    Site url: http://enterprisenation.com

  27. KTW914
    Member
    Posted 2 years ago #

    I used the Clear Update Locks option and HTTP and I'm getting tweets, but not the most recent ones. In reverse chron order I'm getting 1, 4, and 8 (I set the widget to pull back 3). Any ideas?

  28. twentystar
    Member
    Posted 2 years ago #

    I've cleared the locks and changed to HTTP. It didn't work at first, then worked for about 10 minutes and now it's reverted back to "No Tweets Available".

    I've tested one other twitter plugin and it works from my server so my IP/host isn't being blocked by twitter.

  29. Roger Coathup
    Member
    Posted 2 years ago #

    @Aaron - are you working on a fix for this, or is it best to move to a different Twitter plugin?

  30. illusiodesign
    Member
    Posted 2 years ago #

    Even when http is checked and locks are changed, the plugin updates but maybe for a day or two, then goes back into lockdown mode. @Roger, be sure to check out Twitter Tools. It also supports shortcodes if you need it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic