WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Widget Pro
[resolved] CSS not changing anything (6 posts)

  1. shepnic
    Member
    Posted 1 year ago #

    I've been at this for hours now and I have used the code available from the FAQs section, but nothing changes.

    My site is http://www.imperialarms.co.uk/press/ and I just need to make it all fit in the box and look like it does in the pretty screenshot.

    I know this isn't covered as support, but I'm at a loss with what to try next, oh and also the reason!

    Thank you.
    Nic

    http://wordpress.org/extend/plugins/twitter-widget-pro/

  2. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    It looks to me like the only thing that doesn't fit is the follower count. Since that's an iframe from Twitter, you can't do much to style it. However, you CAN hide it. There are quite a few support threads here that have sample code for doing just this. Check out http://wordpress.org/support/topic/plugin-twitter-widget-pro-hide-counter and http://wordpress.org/support/topic/plugin-twitter-widget-pro-hide-follower-count ... both should have code to do exactly what you need.

  3. shepnic
    Member
    Posted 1 year ago #

    Hi Aaron. This didn't seem to work but thank you for getting back to me. I added the code and nothing changed, apart from code appearing at the top of the website page!

    I actually wanted to alter the colour of the links as they are all the same and you can't tell one from another, but this doesn't seem possible either!

    Cheers

  4. Aaron D. Campbell
    Member
    Plugin Author

    Posted 1 year ago #

    It sounds like you didn't put the code in the right place. Those threads specify that the code should be added to your theme's functions.php file, but it sounds like you put it in a different file (or possibly outside the php tags in that file?)

    As for the styling of links, you can do that with CSS. I looked at your site, and it seems that your theme doesn't really use register_sidebar correctly. Read this thread to fix your register_sidebar calls.

    If you fix them, then add this CSS to your style.css file in your theme (adjust the color to whatever you want):

    .widget_twitter a {
    	color: red;
    }

    If you don't make the fixes from the other thread you can still fix the link colors, but it will affect links in all widgets instead of just in the Twitter Widget. To do this, look around line 350 of your theme's style.css file and you'll find a rule for .widget ul li a. Change the color in that to whatever you want.

  5. Fred_L
    Member
    Posted 1 year ago #

    Love the plugin so far but we're getting two headers. Can you help? See on this page: http://worldfoodtravel.org/our-story/membership. Also, settings seem similar in the widget area and
    in the Dashboard > settings > twitter widget area. Is there one that overrides the other? Can they cause a conflict if set differently?

  6. Fred_L
    Member
    Posted 1 year ago #

    Never mind. I was able to fix it myself.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.