WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Tools
new v2.4 broken/problems? (46 posts)

  1. Misosofos
    Member
    Posted 3 years ago #

    I solved my problem by changing .htaccess and adding these lines:

    AddHandler x-httpd-php5 .php
    AddHandler x-httpd-php .php4

    My hosting is Godaddy, and they allow PHP5, but it's disabled by default.

  2. Misosofos
    Member
    Posted 3 years ago #

    As teapot, I had no updates until I installed Simple Twitter Connection plugin.

  3. kira002
    Member
    Posted 3 years ago #

    I'm having the same problem as Sim-O: after upgrading and entering the OAuth info, I click "connect to Twitter" and get a blank screen.

  4. andrerighetto
    Member
    Posted 3 years ago #

    I had the same issue, fatal error: call to undefined function curl_init() in XXX/wp-content/plugins/twitter-tools/twitteroauth.php on line 201 running on a Debian box and php5.

    And get it fixed when I installed curl and php5-curl.

  5. blackartz
    Member
    Posted 3 years ago #

    I'm having the same issue as Sim-O and kira002 with a client's installation.

    I upgraded Twitter Tools, entered the OAuth stuff, clicked on 'connect to twitter' then get presented with a totally blank screen at www.***blogaddress.co.uk/wp-admin/options-general.php - seems it must be a server setting as it works fine on my own blog.

    Anyone have any thoughts?

  6. timbearcub
    Member
    Posted 3 years ago #

    hmm dunno if hostgator have solved the problem, I get:

    Fatal error: Call to undefined method TwitterOAuth::get() in xxxxxxxxxxxxxxxx/plugins/twitter-tools/twitter-tools.php on line 1623

    :-(

  7. timbearcub
    Member
    Posted 3 years ago #

    Can't be a hostgator oAuth issue either as WP to Twitter plugin using oAuth works and connects OK now, as does Simple Twitter Connect.

    Oh well...I preferred Twitter Tools but I'll have to junk it.

  8. myhow2guru
    Member
    Posted 3 years ago #

    Hi guys,

    I am facing the same problem with the plugins.
    “Fatal error: Class ‘OAuthSignatureMethod_HMAC_SHA1′ not found.”

    Found that it is causing by the PHP with OAuth enabled.

    I done some modification on the plugins and it works now.
    check out the solution here.

  9. sgr496
    Member
    Posted 3 years ago #

    @Sim-O,@kira002.At first,sorry for my bloken english.
    I have a same trouble,after "connect to Twitter" and get a blank screen. did u find the way to resolve it.
    wordpress ver:3.0.1
    twitter tools ver:2.4
    php ver:5.2.5

    I tried to build another DB,another WP on same server and only install Twittertools.but same trouble again.so I think it's not because of DB,confrict.

    ummm,help me from japan orz

  10. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    No changes made. Voodoo?

    Nope.... cuz it ain't workin for me! ;)

  11. itanum
    Member
    Posted 3 years ago #

    i'am still have the problem: wordpress/wp-content/plugins/twitter-tools/twitteroauth.php on line 201

    Do you have any idea what might be the cause of this? curl is running.

  12. hypernayte
    Member
    Posted 3 years ago #

    In regard to the error:

    "twitter tools Fatal error: Call to undefined function curl_init() in twitteroauth.php", or something similar, I simply installed php-curl (as mentioned above) on my FreeBSD server. This worked like a charm.

    Thanks, andrerighetto.

    Nathan

  13. daveabrahams
    Member
    Posted 3 years ago #

    Re: Fatal error: Call to undefined function curl_init() in .../wp-content/plugins/twitter-tools/twitteroauth.php on line 201

    Installing php-curl didn't work for me, sadly. The odd thing is, it is getting picked up by php even when I run it from the command-line. Just to prove it to myself, I deinstalled php5-curl and started over: [I'm using lighttpd, so the php.ini file that gets used is in /etc/php5/cgi]

    ~# php --php-ini /etc/php5/cgi -r 'curl_init(); print "ok\n";'
    Fatal error: Call to undefined function curl_init() in Command line code on line 1
    root@boostpro:~# aptitude install php5-curl
    ...
    The following NEW packages will be installed:
      php5-curl
    0 packages upgraded, 1 newly installed, 0 to remove and 27 not upgraded.
    ...
    Building tag database... Done
    root@boostpro:~# php --php-ini /etc/php5/cgi -r 'curl_init(); print "ok\n";'
    
    Fatal error: Call to undefined function curl_init() in Command line code on line 1
    root@boostpro:~# ls /etc/php5/conf.d/
    gd.ini  imagick.ini  mysqli.ini  mysql.ini  pdo.ini  pdo_mysql.ini  pdo_pgsql.ini  pgsql.ini
    root@boostpro:~# mv /tmp/curl.ini /etc/php5/conf.d/
    root@boostpro:~# php --php-ini /etc/php5/cgi -r 'curl_init(); print "ok\n";'
    ok
    root@boostpro:~# php --php-ini /etc/php5/cgi -i | grep -i curl
    additional .ini files parsed => /etc/php5/cli/conf.d/curl.ini,
    curl
    cURL support => enabled
    cURL Information => libcurl/7.18.0 OpenSSL/0.9.8g zlib/1.2.3.3 libidn/1.1
    root@boostpro:~#
  14. smjdesign
    Member
    Posted 3 years ago #

    The 'blank screen' problem is probably a result of not having PHP-cURL installed. That is how it was for me.

    I installed an Ubuntu RPM: apt-get install php5-curl
    and now Twitter Tools works.

    (and you if you don't know what the above line means then you probably won't be able to fix it yourself)

  15. daveabrahams
    Member
    Posted 3 years ago #

    Apparently twitter tools needs http://wordpress.org/extend/plugins/xrds-simple/ to be installed!! At least, that fixed it for me. Do they document this dependency anywhere?

  16. geminiman7
    Member
    Posted 3 years ago #

    Strange, Twitter Tools had worked great up until Jan 19th. Somewhere in between Jan 19th and March 20th it stopped working entirely. When I tried to access the Twitter Tools settings page I got the "parse error on line 19" message.

    Called my hosting company (New World Hosting) and they said that their server runs both PHP4 and PHP5 at same time. Even though my control panel does not show PHP4, their admins switched it on their end to use full PHP5 and that resolved my issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic