WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Tools
[resolved] Error with file twitteroauth.php when trying to connect to twitter (8 posts)

  1. Tate-Ramingham
    Member
    Posted 4 years ago #

    Hello,

    I was attempting to set up my Twitter app so I could connect my blog to Twitter using Twitter Tools. I have done this for a couple of other blogs of mine and had zero issues with it. However, with my blog hosted at GoDaddy I'm running into an error when trying to connect to Twitter.

    I went to dev.twitter and set everything up and plugged in all my consumer keys, tokens and secrets, then when I click connect to twitter I get the following error message:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /wp-content/plugins/twitter-tools/twitteroauth.php on line 19

    Line 19 reads:

    public $http_code;

    I figured that I was dealing with a corrupted file since everytime I update anything on my wordpress blog hosted on GoDaddy some files get screwed up in the process and I have to manually download from wordpress.org and replace individually. I downloaded the twitter tools zip and compared the two files and line 19 is the same.

    Could there be another issue?

    Thanks.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 4 years ago #

    Are you using PHP 5? It's highly likely that his new version requires PHP 5.

    On GoDaddy, go to your hosting control center screen, find Content -> Add On Languages, and there you'll be able to switch it to PHP 5.

  3. Tate-Ramingham
    Member
    Posted 4 years ago #

    I went into my hosting control center and changed it to php5 and tried it again. Received the same error.

    Uninstalled Twitter tools, then reinstalled and tried again. Same error.

    Will try again later.

  4. Tate-Ramingham
    Member
    Posted 3 years ago #

    Ok, I tried it again after waiting 24 hours since changing to PHP5. It worked.

    Thanks Otto.
    BTW, I love SFC. such a sweet plugin.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    You're welcome.

    Simple Twitter Connect is pretty cool too. ;)

    Doesn't work with Twitter Tools though.

  6. pickled
    Member
    Posted 3 years ago #

    i just had the same issue and according to this post on twitter tools oath requires php5 now.

    i was able to easily switch to php5 at mediatemple hosting and everything work fine now

  7. Percoco Marble
    Member
    Posted 3 years ago #

    I have the same issue described above, except I am already using PHP 5.2.14... Anyone else?

  8. Percoco Marble
    Member
    Posted 3 years ago #

    Ok, so I found a fix for my issue. There is a PHP configuration option in cPanel (for lunarpages customers at least) and by changing that from "System Default" to "PHP 5" it now works. FWIW YMMV.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic