WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Twitter Tools] Daily digest blog post issues (7 posts)

  1. DJ Lein
    Member
    Posted 5 years ago #

    Running:

    Issue #1:
    The daily digest blog post populates with tweets from a different day, likely because of a time zone discrepancy. For example, I tweet at 7:30pm on 2008-10-15, but it shows up in the daily digest for 2008-10-16.

    Issue #2:
    The daily digest blog post schedules itself to post at 11:59pm on the correct day, but it never actually posts. I have to go into the dashboard and publish them manually.

    Any help with either of these issues would be fantastic. Thanks!

  2. Alex King
    Member
    Posted 5 years ago #

    I've seen reports of these issues before, but I've never been able to reproduce them. I think it's likely something I'd need to debug on a server that is experiencing the issue.

    Unfortunately, that's a time-consuming process and I'm not sure when I'll have time to look into it.

    If someone wanted to sponsor the development and provide a "broken" environment for debugging I could get it into the queue at Crowd Favorite.

  3. DJ Lein
    Member
    Posted 5 years ago #

    It was auto-posting fine for the first week or two before it started queuing up the scheduled posts. Almost like something in the database got full or something...

    I don't know, I'm reaching a bit here.

  4. DJ Lein
    Member
    Posted 5 years ago #

    I clicked the 'Reset Tweet Checking' button and it's auto-posting again, but now it's creating two identical posts per day. Ugh!

  5. darrellosborn
    Member
    Posted 5 years ago #

    I'm having the same problem. It appears that my digest cuts off at 11:59am instead of pm. My time settings on WP are set and the time is appearing correctly elsewhere.

    I am in the Pacific Time zone if that helps, currently -7UTC.

  6. dfiore1230
    Member
    Posted 5 years ago #

    could this possibly be due to the status of the post being set to publish and not published?

    , 'post_date' => date('Y-m-d 23:59:59', $digest_day)
    , 'post_category' => array($this->blog_post_category)
    , 'post_status' => 'publish'
    , 'post_author' => $wpdb->escape($this->blog_post_author)

  7. danpez
    Member
    Posted 5 years ago #

    WP 2.6.2
    Twitter Tools 1.5.1

    I'm having the same type of problems. I set Twitter Tools to digest for the first time, and it posted 4 of the same post to my site on the first night, and then nothing on the second night. I was wondering if I managed to get something out of synch. When I first set it up, I engaged daily posts, but then thought it would be better to go weekly, so turned daily off, and weekly on. Then my indecisive self decided to go back to daily. Could switching back and forth break it? and if so, how do I get that cleared out and back to a happy start?

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic