WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Twitter for WordPress] Not seeming to pick up new twits (33 posts)

  1. netdiva
    Member
    Posted 6 years ago #

    It's not seeming to pick up new tweets or changes.

    See http://www.groundworkopensource.com/blog

    I changed it to pick up the last 3 tweets and it's showing 1 which isn't the most recent.

    http://wordpress.org/extend/plugins/twitter-for-wordpress/

  2. netdiva
    Member
    Posted 6 years ago #

    It's looking like this is an issue with twitter. The RSS isn't updating. :/

  3. jaimetout
    Member
    Posted 5 years ago #

    This is happening to me too--my most recent tweet isn't being displayed by the plug-in. However, I checked my Twitter feed and it does contain the tweet in question.

    Anybody know what might be going on here?

  4. kissmykitty
    Member
    Posted 5 years ago #

    I'm also having this issue. On my blog I simply get "No public Twitter messages." displayed instead of my tweets.

  5. producte
    Member
    Posted 5 years ago #

    Me too. No new updates or tweets since more than a day when Twitter has been updates several times.

  6. davist11
    Member
    Posted 5 years ago #

    Yep, me too. Does this have something to do with 2.7? I contacted the plugin author yesterday but haven't heard back yet.

  7. moshang
    Member
    Posted 5 years ago #

    Installed it for the first time yesterday. Worked fine. Updated to 2.7 later in the day and now it's not working... hmmm.

  8. joelennon
    Member
    Posted 5 years ago #

    To fix this, go to Plugins -> Editor in your WordPress Admin interface. Click on "Twitter for WordPress" on the list of plugins on the right of the page. Now, under the line with the following:

    define('MAGPIE_CACHE_AGE', 120);

    Add the following line:

    define('MAGPIE_CACHE_ON', false);

    Click on the Update button at the bottom of the page. Your plugin file will need to be writeable in order to make this change. If you can't write to plugin files directly, download the file using FTP, make the changes and upload it again.

    This turns off caching for the fetch_rss function, which appears to be the issue with 2.7. This is not a recommended solution, but it should get you by until an official fix is released.

    If you have any questions let me know.

  9. joelennon
    Member
    Posted 5 years ago #

    FYI, new version of the plugin is out now and includes the fix I posted previously.

  10. patrickrhill
    Member
    Posted 5 years ago #

    I just updated to the newest version of this plug-in and I immediately started getting the "No public Twitter messages." error. I uninstalled the plugin, re-downloaded it and reinstalled. It started working for about 20 minutes then started showing the error message again. Everything was working fine before I updated. I'm still using wordpress 2.6.3. Could this be the problem? Is there a way for my to downgrade to the older version of the plugin?

    Update: It started working again. Seems to just be going in and out of service.

  11. Smokey1987
    Member
    Posted 5 years ago #

    Unfortunately, the plugin isn't working any more. If activated, the sidebar and the footer templates aren't included. I get no PHP error within the website's source code.

    Furthermore the widgets page in the wp-admin section isn't working. No widgets are shown in the related sidebar.

    If the plugin is disabled, everything is working fine. I use the new version 1.9.2.

  12. quasarkitten
    Member
    Posted 5 years ago #

    Here is what I see is going on. Two issues: one with twitter limiting request and the other with WP 2.7 + version 1.9.2 + caching.

    joelennon posted a fix above for people using 2.7. Apparently having this plugin do caching in WP 2.7 causes the sidebar to break. (?) So the solution was to turn caching off within the plugin.

    The problem with this is Twitter limits request of your RSS feed to 100 per hour. Which is why it stops working after a set amount of time, then start working again.

    Proposed Fix: if you not using WP 2.7 turn caching on in the plugin. If you are using 2.7 then wait for an update or just hope you don't have more than 100 request per hour.

    FYI: This is just my hypothesis about what is going on.

  13. Dave333
    Member
    Posted 5 years ago #

    I added the line:

    define('MAGPIE_CACHE_ON', false);

    as suggested by joelennon and it seemed to work for about five minutes then my Tweets dissappeared again.

    Would extending the age help at all? For example:

    Changing
    define('MAGPIE_CACHE_AGE', 120);

    to somethign like:
    define('MAGPIE_CACHE_AGE', 240);

    I have no idea. But I sure would like to have my tweets back on my blog. I spent hours fixing all the problems created by 2.7 and now it seems I have another day of troubleshooting ahead of me. It's frustrating for sure.

  14. Ricardo Gonzalez
    Member
    Posted 5 years ago #

    I have released a 1.9.2 version in order to fix the bug, but as some of you already posted, is a wp2.7 RSS cache bug maybe combined with a limit from twitter.com

    I'm working on it...

  15. markdeboer
    Member
    Posted 5 years ago #

    I've had the same problem as mentioned: after updating WP to 2.7, Twitter for WordPress (1.9.2) stopped working, even blocking the showing up of widgets in the admin panel.
    With some trial and error I managed to get it working again. Don't really understand what I did, but here is the piece of code that seems to do the trick:

    define('MAGPIE_CACHE_AGE', 240);
    // define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug
    define('MAGPIE_INPUT_ENCODING', 'UTF-8');

    works like a charm...

  16. rohitnair
    Member
    Posted 5 years ago #

    The plugin update seems to fix the issue for me for WP 2.7

  17. Taipa
    Member
    Posted 5 years ago #

    The suggestion from markdeboer worked for me.

    Changed from:
    //define('MAGPIE_CACHE_AGE', 120);
    define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug
    define('MAGPIE_INPUT_ENCODING', 'UTF-8');

    to:
    define('MAGPIE_CACHE_AGE', 120);
    // define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug
    define('MAGPIE_INPUT_ENCODING', 'UTF-8');

    Now it works great (WordPress 2.7)

  18. lacarmina
    Member
    Posted 5 years ago #

    My tweets showed up yesterday, when I installed the plugin. Now, none of the proposed fixes work for me... Any advice?

    My site is
    lacarmina.com/blog
    Thanks!

  19. keempoo
    Member
    Posted 5 years ago #

    I'm with lacarmina. On the initial install, it worked perfectly. 5 minutes later it didn't and the all the code changes listed above don't seem to change the situation one bit.

    http://www.keempoo.com

  20. keempoo
    Member
    Posted 5 years ago #

    Now it's working after 20 minutes using the code from markdeboer:

    define('MAGPIE_CACHE_AGE', 240);
    // define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug
    define('MAGPIE_INPUT_ENCODING', 'UTF-8');

    Maybe it just needs time to work it's magic.

  21. uglymunky
    Member
    Posted 5 years ago #

    Using the following line:

    define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug

    causes my page to display "No Public Twitter Feeds"

    However, when I comment it out and un-comment the following:

    define('MAGPIE_CACHE_AGE', 240);

    as suggested by markdeboer, my posted tweet is not my latest (it posts one from over a month ago).

    Any ideas?

  22. uglymunky
    Member
    Posted 5 years ago #

    update to my last post:

    I posted a new tweet on Twitter and now everything is working ok using, in other words no longer posting an outdated tweet. Using the following code (WP 2.7):

    define('MAGPIE_CACHE_AGE', 120);
    // define('MAGPIE_CACHE_ON', false); //2.7 Cache Bug
    define('MAGPIE_INPUT_ENCODING', 'UTF-8');

  23. vellkan
    Member
    Posted 5 years ago #

    I try everything from this topic, but nothing gone to help mi.
    My status disappear after few minutes. i try uninstall, reinstall, turn on/off cache - don't work anything :/

  24. Lovelidicious
    Member
    Posted 5 years ago #

    I'm using the same one as uglymunky and I think it's working. It no longer keep showing the "no tweets to display". :)

  25. typemachine
    Member
    Posted 5 years ago #

    I've tried all the above fixes and it's not working for me either using 2.7.1

  26. lowlight
    Member
    Posted 5 years ago #

    How's this for weird: The plugin is working for me on one WordPress install, but not on another. Using the same version of WordPress and the plugin, and the same Twitter account, but on different server hardware.

  27. skb
    Member
    Posted 5 years ago #

    I'm using 2.7.1 and I can't get it to display anything other than "No public Twitter messages" regardless of which code option I try from the ones above.

    Has anyone figured this out?

  28. skb
    Member
    Posted 5 years ago #

    Can't edit my previous post. After repeated refreshing, it now works.

  29. martinjy
    Member
    Posted 5 years ago #

    When I first activate the plugin it works, but when I refresh my blog's page it fails and I get the "No public messages" message.

    If I deactivate then reactivate it works. Then I refresh and it fails again.

    My tweets are less than 24hrs old and I'm on WP 2.7.1.

    It looks great when it's working, so I'm hoping there's an explanation/fix on the way....

    ** Edit: Looks like Twitter was down when the plugin was failing for me before. I tried to log in and got the fail whale.

    So maybe the message in the plugin is what's making people (including me) think that the plugin is failing? "No public messages" is technically correct, but if the reason for that is because Twitter's down then perhaps should the message be something along the lines of "Twitter is down" instead?

  30. rfr
    Member
    Posted 5 years ago #

    This is just crazy - i have tried all the code above and it doesn't seem to work. Further I am way below the 100 tweets threshold. The way this is acting I cant believe this is not coming from Twitter. There is no way we would see this kind of flux...

    I have found twitter to be full of bugs anyway so this doesnt surprise me at all.

    Rob
    http://www.robfrazzini.com

Topic Closed

This topic has been closed to new replies.

About this Topic