WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Twitter for WordPress] No public Twitter messages (60 posts)

  1. Okoth1
    Member
    Posted 5 years ago #

    I use WP 2.8.1 and everything works fine.

  2. James
    Member
    Posted 5 years ago #

    Sorry, I'm using a fresh install of WP 2.8.2, and getting the same intermittent "No Public Twitter" messages on my web site.

    For what it's worth, the plugin has never failed when viewing the same page on localhost.

  3. Okoth1
    Member
    Posted 5 years ago #

    Problems with 2.8.3 again....

  4. pif
    Member
    Posted 5 years ago #

    Hello,

    I am with 2.8.4. and 1.9.6 plugin and have the "no public message" error...

    Thank you for your help, I'm lost and can't find any other good replacement (I need to display multiple accounts with the same plugin).

  5. PKtm
    Member
    Posted 5 years ago #

    Same here: 2.8.4 and latest plugin, downloaded today. "No public Twitter messages."

  6. marcycapron
    Member
    Posted 5 years ago #

    hi guys, I get the same error every other refresh... emailed the plugin author about it... will let you know if he writes back!

  7. marcycapron
    Member
    Posted 5 years ago #

    yeahhhhh so he never wrote back and I am literally getting "no public twitter messages" 3 out of every 4 refreshes.... has anyone found a fix????

  8. Drew Strojny
    Member
    Posted 5 years ago #

    Same issue on WP 2.8.4. Hopefully we hear something soon.

  9. MentheFraiche
    Member
    Posted 5 years ago #

    It appears that Twitter's API has rate limit and returns an error 400 :
    Respone codes : http://apiwiki.twitter.com/HTTP-Response-Codes-and-Errors
    Rate limiting : http://apiwiki.twitter.com/Rate-limiting

    This limit is IP based.
    On mutualized hosting, default rate limit is easily reached in few minutes.

    On mutualized hosting, ideal cache duration is 3600 seconds...

  10. marcycapron
    Member
    Posted 4 years ago #

    update: with new plugin update everything is fine on my end, no more issues!

  11. TrishaM
    Member
    Posted 4 years ago #

    I have just updated to the most recent version of this plugin and am STILL getting the "no public Twitter messages"......

    I'm on WP version 2.8.4

    I've also tried a couple of the suggestions above that seemed to work for some, but they did not work for me, so I'm still seeking a solution.

  12. Don Salva
    Member
    Posted 4 years ago #

    I think I found the solution.

    1. go to your Twitter Page http://twitter.com/YOURNAME
    2. hover over "RSS feed of YOURNAME's tweets"
    3. write down the number in "http://twitter.com/statuses/user_timeline/THENUMBER.rss"

    now open twitter-for-wordpress/twitter.php and edit (line 36)

    $messages = fetch_rss('http://twitter.com/statuses/user_timeline/'.$username.'.rss');

    to

    $messages = fetch_rss('http://twitter.com/statuses/user_timeline/THE_NUMBER_YOU_WROTE_DOWN.rss');

  13. hhalvor
    Member
    Posted 4 years ago #

    I had the same problem, now I am using this solution with javascript.

    Works great and no plugin.

  14. TrishaM
    Member
    Posted 4 years ago #

    @ Don Salva - I tried your solution but it does not work for me - even with using the rss feed number instead of the name, I still get "no public twitter messages"...

    @hhalvor unfortunately I can't use the js provided by twitter because I'm making a modification of the variable used by the twitter for wordpress plugin ($username) so that this works for a multi-author site, showing the twitter messages for the author currently being viewed.

    I can get the variable to work correctly and use the current author's twitter name just fine, but it doesn't matter which author's name is used, they all come back with "no public messages".......so I think that there must be a basic flaw in the plugin.....

    Still looking for a solution....

  15. TrishaM
    Member
    Posted 4 years ago #

    Okay so actually it DOES seem to work if I use the NUMBER instead of the name as Don Salva suggests above.....however......

    I need to be able to use this for a mulit-author blog, and if I use a variable to use the author's metadata instead of hard-coding the rss # into the plugin, it only ever displays MY twitter feed, not the feed of the author who's page is currently being viewed......

    I really need some help with this one....it looks like if I put the variable in the page template, the plugin ignores it and says "RSS not configured", but if I try to put the variable into the plugin code itself, it bombs because it doesn't know the WP core functions.......

    SO how do I tell it to include the path to the WP core functions so it will recognize something basic like get_author_meta() ??

  16. Chris
    Member
    Posted 4 years ago #

    I managed to get this plugin to work by manually puting my username into the twitter.php file. Just fill out the empty space where it reads $username = '' (line 49)

    // Display Twitter messages
    function twitter_messages($username = '', $num = 1, $list = false, $update = true, $linked  = '#', $hyperlinks = true, $twitter_users = true, $encode_utf8 = false) {

    It should look like this:

    // Display Twitter messages
    function twitter_messages($username = 'YOUR_USERNAME_HERE', $num = 1, $list = false, $update = true, $linked  = '#', $hyperlinks = true, $twitter_users = true, $encode_utf8 = false) {
  17. electricvishnu
    Member
    Posted 4 years ago #

    thanks tvarne - that just worked for me - hopefully it will stick.

  18. Dylan Kuhn
    Member
    Posted 4 years ago #

    I just had some luck with disabling wp-cache for the page where I call twitter_messages().

  19. M.Edeving
    Member
    Posted 4 years ago #

    Come on. It must be a one fix to rule them all for this problem.

  20. jmharris903
    Member
    Posted 4 years ago #

    tvarne, I think you are on the right track. It looks like line 49 of twitter.php is redefining $username to blank, overwriting the username that it gets passed. If you remove the =' ' it should function properly.

    current line 49 of twitter.php
    function twitter_messages($username = ' ', $num = 1, $list = false, $update = true, $linked = '#', $hyperlinks = true, $twitter_users = true, $encode_utf8 = false) {

    change to
    function twitter_messages($username, $num = 1, $list = false, $update = true, $linked = '#', $hyperlinks = true, $twitter_users = true, $encode_utf8 = false) {

  21. Suncokret
    Member
    Posted 4 years ago #

    I tried everything you said but still get the dreaded message.

    Why the authors never respond when their plugin is not working?!
    This is the 3rd twitter plugin that I tried.

  22. EarthenRecords
    Member
    Posted 4 years ago #

    Still receive the same message despite trying the fixes mentioned here.

  23. AlvinLuo
    Member
    Posted 4 years ago #

    Hello guys,

    This must be a very weird issue.

    I moved my hosting from other hosting to Godaddy, and now it works perfectly well.

    I have tried all the solutions above and it did not work with my previous hosting.

    For godaddy, I kept the default settings and I have no problem for it.

    Good luck!

  24. jackfig
    Member
    Posted 4 years ago #

    Don Salva's fix worked - replacing the rss number with the one from your twitter rss feed. However, I'm so tired of this janky plugin, I just used hhalvor's suggestion to get the widget from twitter: http://twitter.com/widgets/html_widget. You'll need to login to acquire it. Less hassle for sure. Twitter for WordPress plugin now going into the trash.

  25. programmer
    Member
    Posted 4 years ago #

    I just solve this problem
    MAGPIE_FETCH_TIME_OUT constant is answer.
    Set this constant value greater then 2 seconds(by default).
    This constant defined in rss.php file.

    if ( !defined(’MAGPIE_FETCH_TIME_OUT’) ) {
    define(’MAGPIE_FETCH_TIME_OUT’, 2); // 2 second timeout
    }
    set

    if ( !defined(’MAGPIE_FETCH_TIME_OUT’) ) {
    define(’MAGPIE_FETCH_TIME_OUT’, 15); // 15 second timeout
    }
    or greater value

    I had to temporarily override the default Magpie timeout to get it to read the twitter RSS feed. It’s 2 seconds by default, which seems terribly short to me. Since the twitter site is excruciatingly slow right now, it was timing out.

  26. raelga
    Member
    Posted 4 years ago #

    My solution, editing the sidebar.php

    <?php if(function_exists('twitter_messages')) { ?>

  27. <ul class="sb-tools clearfix">
    <li class="twitter-icon">

    <span><?php _e('Latest Tweet', 'default'); ?></span>

    <!-- Remove o comment the code between ####
    #######
    /*<?php if(function_exists('twitter_messages')) { twitter_messages('raelga', 1, false, false, '', false, false, false); } ?>
    #######
    -->

    <!-- Add the Twitter generated JS o change the this script directly
    raelga it's my Twitter username, change it for your username -->

    <div id="twitter_div">

    <ul id="twitter_update_list">
    Sígueme en Twitter
    </div>
    <script type="text/javascript" src="http://twitter.com/javascripts/blogger.js"></script>
    <script type="text/javascript" src="http://twitter.com/statuses/user_timeline/raelga.json?callback=twitterCallback2&count=1"></script>

    <!-- Remove o comment the code between ####
    ###########
    <p class="sb-icon-text"><?php _e('Follow me on twitter', 'default'); ?> <?php _e('here', 'default'); ?>.</p>
    ######### -->

  28. <?php } ?>

  • raelga
    Member
    Posted 4 years ago #

    My solution, editing the sidebar.php

    <?php if(function_exists('twitter_messages')) { ?>
    <li>
    	<ul class="sb-tools clearfix">
    		<li class="twitter-icon">
        	<a class="sb-icon" href="http://twitter.com/raelga" rel="nofollow">
        		<span><?php _e('Latest Tweet', 'default'); ?></span>
    
    <!-- Remove o comment the code between ####
     #######
       		/*<?php if(function_exists('twitter_messages')) { twitter_messages('raelga', 1, false, false, '', false, false, false); } ?>
    #######
    -->      </a>
    
    <!-- Add the Twitter generated JS o change the this script directly
    raelga it's my Twitter username, change it for your username -->
    
    <div id="twitter_div">
    
    <ul id="twitter_update_list"></ul>
    <a href="http://twitter.com/raelga" id="twitter-link" style="display:block;text-align:right;" target="_blank">S&iacute;gueme en Twitter</a>
    </div>
    <script type="text/javascript" src="http://twitter.com/javascripts/blogger.js"></script>
    <script type="text/javascript" src="http://twitter.com/statuses/user_timeline/raelga.json?callback=twitterCallback2&count=1"></script>
    
    <!-- Remove o comment the code between ####
    ###########
        	<p class="sb-icon-text"><?php _e('Follow me on twitter', 'default'); ?> <a href="http://twitter.com/raelga" rel="nofollow"><?php _e('here', 'default'); ?></a>.</p>
    ######### -->
    
    </li>
    	</ul>
    </li>
    <?php } ?>

    Works like charm and uses de stylesheet CSS.

    http://rtfm.es/

  • bryanwalker
    Member
    Posted 4 years ago #

    I just updated to 2.8.6 when i put the server live. Locally it worked fine, but not now because it's either live or updated. None of the above solutions helped, so far.

  • Rob Cubbon
    Member
    Posted 4 years ago #

    Has anyone sorted this one out? It's driving me mad. We've got "No public Twitter messages" 90% of the time. Have tried Don Salva's fix, jmharris903's and tvarne's. No go.

  • Rob Cubbon
    Member
    Posted 4 years ago #

    It's not a fix but another way of doing it without the plugin - http://remysharp.com/2007/05/18/add-twitter-to-your-blog-step-by-step/

    works for me.

  • 12

    Topic Closed

    This topic has been closed to new replies.

    About this Topic

    Tags