WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: Twitter for WordPress] No public Twitter messages (60 posts)

  1. tvds
    Member
    Posted 5 years ago #

    I get a lot of:

    No public Twitter messages

    on my site. No all the times though.

    And trust me there are public Twitter messages on my twitter (they all are)

  2. Rocket 442
    Member
    Posted 5 years ago #

    Same thing is happening to me. I just installed it and used the php code, not the widget and I get that there are no public twitter messages.

  3. Barefoot Ted
    Member
    Posted 5 years ago #

    Me too! Same problem.

    What's up?

    BFT

    PS. Was working fine...and then just stopped working...no changes to WP or Twitter settings...

  4. lhuber
    Member
    Posted 5 years ago #

    When you write out the tag... instead of putting in your Twitter username ex. "lhuber" use your twitter ID # ex. 10856102

    To get your Twitter ID #...
    Log into Twitter
    Click on your username so that you get to the page of just your tweets
    Mouse over the RSS feed link.
    You will see the RSS feed link uses TWITTER_ID.rss now, not USERNAME.rss

  5. mohanbn
    Member
    Posted 5 years ago #

    Even after that it doesn't work. Looks like this plugin works with WP 2.7 but not with 2.7.1

    Can someone confirm on that?

  6. inorganik
    Member
    Posted 5 years ago #

    Even using my ID# can't get it to work. Using 2.6.5

  7. inorganik
    Member
    Posted 5 years ago #

    Using the twitter supplied feed and its working great. Just uses javascript.

    Find it at twitter.com/widgets then click 'other'.

  8. deepfresh
    Member
    Posted 5 years ago #

    Im getting the same error! Sometimes it works, sometimes it doesnt sayinf no public twitter messages?

    ist there a fix for this?

    thx

  9. XIII
    Member
    Posted 5 years ago #

    Same problem here using 2.7.1

  10. Roy McKenzie
    Member
    Posted 5 years ago #

    yeap! same here on 2.7.1 with buddypress... any ideas? Twitter API limits?

  11. torx
    Member
    Posted 5 years ago #

    The problem appears to be with the fetch_rss() function which apparently works via Magpie.

    Both the plugin and a manually constructed rss fetcher work fine on my localhost test machine, but fail to grab the feed on the server.

    I'll post more if I find any solutions.

  12. torx
    Member
    Posted 5 years ago #

    Alright, I have it working — at least momentarily.

    You can add this line to the plugin or a functions.php

    define('MAGPIE_FETCH_TIME_OUT', 5);

    Feel free to change the time out to something shorter (in seconds).

  13. torx
    Member
    Posted 5 years ago #

    Boo! I posted too soon

    Now it's back to not working. Even with greater time outs it's not grabbing the feed. I wonder what made it work then decide not to.

    Hopefully I'll post a new solution soon.

  14. jl_678
    Member
    Posted 5 years ago #

    Just to add to this, I am seeing the same thing. The other weirdness is that I will see one page, say the homepage, with my tweets and then I navigate to an archive page and it shows "no public posts". Completely weird. I am running super-cache and cleared the cache and then the problem reversed itself. ("no public posts" on the homepage and normal tweets on the archive page.) Very odd. I have temporarily switched to twitter tools, but liked the simplicity of Twitter for WordPress.

  15. torx
    Member
    Posted 5 years ago #

    Just to clarify, this is not this plugin's error. I've used Twitter Tools with similar errors and even wrote a function using SimplePie to get the Twitter RSS feed instead of Magpie and it comes up with intermittent feed-grabbing errors.

    The problems all seem to be server based as I have no issues whatsoever from the localhost. I've checked up and down Google, phpinfo(), and PHP setting changes to no avail.

    I'm going to try the RSS widget next, but in order to get the feed the way I like, I'm going to have to customize this as well. I'd much rather use a simple plugin like this.

  16. bmharris
    Member
    Posted 5 years ago #

    It looks like there is a bug (seems to be related to this issue) on line 158 of the plugin (twitter.php). It fetches the messages using the standard fetch_rss, but the url passes in an unset $username variable. I don't believe this line is needed, and it returns an empty feed obviously as there is no username. With this removed, the widget is now only making the request once, and I haven't had any issues so far, even with magpie cache enabled (the twitter widget disables it by default). I'd like to hear if removing line 158 fixes the issue for anyone else.

  17. natako
    Member
    Posted 5 years ago #

    @bmharris

    that didnt do it for me.

  18. Marin G.
    Member
    Posted 5 years ago #

    the 1.9.4 upgrade fixes the issue

  19. dbog
    Member
    Posted 5 years ago #

    I am using 1.9.4 and am still experiencing this. I've tried the other fixes noted above to no avail. The plugin works for a while, then it doesn't and displays "No public Twitter messages." Anyone else have any insight?

  20. g3r
    Member
    Posted 5 years ago #

    the "158" fix worked for me (altough it seemed more line 160 in 1.9.4)
    by commenting the line the tweets started again...

    All this on a wp 2.6.3 heavily modded. I hope this might help :)

  21. juanjose2012
    Member
    Posted 5 years ago #

    I deleted line No. 160 in 2.7 and it doesn't fix the problem.
    I need to correct it.

  22. torx
    Member
    Posted 5 years ago #

    I've successfully devised a function that has reliably grabbed the latest Tweet for the last several days for me.

    For those of you who have been getting this problem and want a no-frills function that grabs only the most recent tweet, you can find the function here.

    It uses the Atom feed instead of RSS. My server has had no problems with it.

  23. duka
    Member
    Posted 5 years ago #

    I think it clearly has something to do with the MAGPIE_CACHE feature.

    When the cache expires (by default, 180 seconds), the plugin works, otherwise it does not retrieve the feed. In fact, I think that magpie is not able to write the cache file, so it doesn't return anything.

    I'm trying to define another MAGPIE_CACHE_DIR to see if it has anything to do with permissions, but I'm still failing.

  24. amthomas
    Member
    Posted 5 years ago #

    I have a question does this plugin just add feeds from your twitter account to your blog or does it also take posts from your blog and feed them into twitter. If it does not post your blog post in twitter then is there a plugin that does this?

  25. Ritwik
    Member
    Posted 4 years ago #

    @Amthomas: http://www.twitterfeed.com will do what you want.

  26. kautzz
    Member
    Posted 4 years ago #

    I think I found a solution to this problem.

    If you edit the 'twitter-for-wordpress/twitter.php' in line 54 (think that was the line) to

    $messages = fetch_rss('http://twitter.com/statuses/user_timeline/yourtwittername.rss');

    everything should work just fine...
    at least it does for me.

  27. kautzz
    Member
    Posted 4 years ago #

    NOT, sorry people

  28. focused313
    Member
    Posted 4 years ago #

    I'm using 1.9.6 and WP 2.8.1 and I still get the error from time to time.

  29. RockyShark
    Member
    Posted 4 years ago #

    It was playing up for me too (displaying tweets from November last year!) but I just upgraded to WP 2.8.2 and it's working...

  30. RockyShark
    Member
    Posted 4 years ago #

    And almost an hour later it's still okay.

    Might just need to upgrade WP guys. :D

Topic Closed

This topic has been closed to new replies.

About this Topic