WordPress.org

Ready to get started?Download WordPress

Forums

Twitter Blackbird Pie
You Are Not Allowed to be Here - on bird click (7 posts)

  1. sherrodOhInternet
    Member
    Posted 2 years ago #

  2. bradvin
    Member
    Plugin Author

    Posted 2 years ago #

    Hello,

    Are you an administrator on your site? I am just trying to figure out what is different for you, cause when I test it, it works 100%?

  3. sherrodOhInternet
    Member
    Posted 2 years ago #

    Yes, I am an administrator. I would like for all the authors on the site to be able to use it though.

  4. bradvin
    Member
    Plugin Author

    Posted 2 years ago #

    ok... so do you also get the "not allowed here" message when you are administrator? Or is it only authors that get it?

    Sorry, but it is extremely difficult to debug issues with so little info

  5. sherrodOhInternet
    Member
    Posted 2 years ago #

    Sure, I understand.

    I am an administrator at all times. Though, we have about 40 bloggers in our pool who are "authors". None of them have tried it. Sorry if I was unclear about that. I wanted to be able to try it first and got the "not allowed" diaglog immediately upon pressing the blackbird.

    Basically, yes, I am an administrator and would like it to work. I would also like it to work for those who are not administrators, but haven't asked them to try it yet, so don't have information about whether it is working or not for them.

  6. bradvin
    Member
    Plugin Author

    Posted 2 years ago #

    cool thanks for more info. With your blog setup, did you place the WP-content folder outside of the classic file structure at all?

    Cause that popup, which is popup.php in the tinymce subfolder is trying to load WP's wp-load.php and then does this:

    // check for rights
    if ( !is_user_logged_in() || !current_user_can('edit_posts') )
    wp_die(__("You are not allowed to be here"));

    So I think in your case the only way the above would break is if it cannot find the wp-load.php

    Check out wpload.php in the tinymce subfolder to see what I am talking about. On line 14 of that file you can specifiy the path to the wp-load.php file

  7. sherrodOhInternet
    Member
    Posted 2 years ago #

    Hello. There was a permissions conflict with the "user role editor" plugin. We have manually edited it and it is fixed and working now.

    HEre is our usage of it in a blog post:

    http://blog.ohinternet.com/11601/racism-takes-a-funny-turn-on-twitter-and-also-hunger-games/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic