WordPress.org

Ready to get started?Download WordPress

Forums

Twitchers
[resolved] PHP version (15 posts)

  1. xs650
    Member
    Posted 2 years ago #

    Ouch...

    Doesn't work with PHP version 5.2.17?

    any alternatives?

    http://wordpress.org/extend/plugins/twitchers/

  2. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    Hi

    thanks for the message.

    The php version is a carry over from the Sightings plugin but I have either removed or changed about 80% of the code so it may work in earlier versions of php. My web host runs php 5.3 so I am unable to test the plugin with earlier version of php.

    I am going to be releasing an update in the next couple of days but before I do I will check through the code and see if I can find any code which is dependant on php 5.3 and try and re-write it.

    Have you tried running the plugin in? If you do and get an error message please post it here to give me an indication of any possible code changes I need to make.

    Thanks
    Kevin

  3. xs650
    Member
    Posted 2 years ago #

    So after further tinkering, maybe its not the php version.

    When i try to use the shortcode in a post, page, or sidebar, I only see the [twitcher-map]

    I am using other plugin with other shortcodes on the site

    I may try to call it with php, I'll keep you updated, but if you have any ideas, I am open to try them.

    Thanks for your response and I look forward to trying your plugin

  4. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    Hi

    there is a fix for it going out later today hopefully or tomorrow with the next update.

    There was acall to the plugin directory path using a php 5.3 method. I've swapped that path call for the standard wordpress mthod so php version should not matter.

    I'm just tweaking some settings at the moment and then I'll be releasing version 1.3

    Kevin

  5. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    If you want to try the fix then open the filters.php file in;

    twitcher > theme-files > filters.php

    look for about line 14:

    // Register shortcodes
            include __DIR__ . '/shortcode-twitcher-map.php';

    change it to:

    // Register shortcodes
            include dirname(__FILE__) . '/shortcode-twitcher-map.php';

    that should fix the php version issue. But as I said my web host runs php 5.3 so I've not been able to test it on earlier versions of php.

    Kevin

  6. xs650
    Member
    Posted 2 years ago #

    That isn't working

    in fact, it nukes my whole site, heh

    but i think its on the right track

    Ryan

  7. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    that's trange if it's nuked your whole site. I'm using the new path call without a problem.

    You sure you did not delete a closing braket or ; by mistke as well?

    Kevin

  8. xs650
    Member
    Posted 2 years ago #

    very odd
    i tried
    include(dirname(__FILE__).'/shortcode-twitcher-map.php');
    and even just
    include('shortcode-twitcher-map.php');

    and they both white screened the site

    I'll mess with it more later and let you know what i find

  9. xs650
    Member
    Posted 2 years ago #

    I think its when the include 'does' work that it nukes the site.

    If i use the include code with a bad path, I get the same issue as with the __DIR__ code

    Must be something unfriendly in
    shortcode-twitcher-map.php

  10. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks Ryan,

    I'll take a closer look at that file.
    There may be some php 5.3 specific coding in there somewhere.

    Kevin

  11. xs650
    Member
    Posted 2 years ago #

    Any luck with that 5.3 specific code hunt? I looked but didn't see anything that stood out to me. I just loaded your new version and

    since you use
    include dirname(__FILE__) . '/shortcode-twitcher-map.php';
    now, it white screens my whole site on 5.2.17

  12. xs650
    Member
    Posted 2 years ago #

    if you are interested in testing on 5.2.17, I could set you up a site

    let me know

    you can email me at ryan.leisinger@gmail.com

    Ryan

  13. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ryan

    I am planning on spending a couple of hours tomorrow (sunday) looking into this.

    If you vould get me access to 5.2 php then it would help me al ot on testing and running debugs etc.

    You can send me details on kevin@ypraise.com

    I'm not sure but I think it could be the way the marker is being called for when people make a contribution.

    thanks
    Kevin

  14. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    Hi Ryan,

    I've done a few changes to file structure ready for the next update sometime next week but it would be good if you could give me some feedback on if it's working in php 5.2

    you can download the zip file from:

    http://ypraise.com/store/twitchers.zip

    thanks
    Kevin

  15. kevin heath
    Member
    Plugin Author

    Posted 2 years ago #

    For those who have been following this thread.

    I will not be adapting the code to work with php 5.2 as it will require a major rewrite.

    The issue is the use of the Paamayim Nekudotayim (:: double colon) with variables. This additional use was introduced in php5.3 and is not supported in earlier version of php.

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.