WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: Twit Connect] Twitter oAuth problem (4 posts)

  1. Joost
    Member
    Posted 4 years ago #

    I am using WP with buddypress.

    When adding the login options to comment pages, the api wants to login using oAuth, but in the popup the following message appears:

    "You've successfully granted access to Twit Connect!

    Simply return to Twit Connect and enter the following PIN to complete the process.
    XXXXXX"

    Where XXXXXX is a number.

    This Pin is only necessary for mobile and/or desktop applications, so why is it there?

    http://wordpress.org/extend/plugins/twitconnect/

  2. 4braham
    Member
    Posted 4 years ago #

    Check your applications settings on Twitter and make sure that your application type is set to "browser" not "desktop".

    http://dev.twitter.com/apps

  3. Joost
    Member
    Posted 4 years ago #

    It is not my application :-) I am using it.

  4. swhitley
    Member
    Posted 3 years ago #

    This was a bug that resulted from my switch to oAuth 1.1. For anyone interested, the PIN popup is displayed if "oob" is specified in the callback (happened by default in this case). I fixed the bug and this is no longer an issue.

Topic Closed

This topic has been closed to new replies.

About this Topic