WordPress.org

Ready to get started?Download WordPress

Forums

TweetMeme Button
TweetMeme button DISAPPEARED! (16 posts)

  1. fbahram
    Member
    Posted 3 years ago #

    Hi,
    My tweetmeme buttons on all posts have disappeared as of Jan 5th around 10am EST/7am PST.

    http://www.prolificliving.com/blog/

    I have cleared the cache, tested in several browsers, and changed some settings on TweetMeme just to Save Changes and still no luck.

    PLEASE HELP!
    I have it displayed on top and bottom of blog posts.

    Thank you!
    Farnoosh

  2. Trippa
    Member
    Posted 3 years ago #

    Same happened to me after installing the v2.0 button. Reverted to the previous version and Tweetmeme button reappeared.

  3. Dave
    Member
    Posted 3 years ago #

    Same here. Shame, hopefully they will take note.

  4. weirdnews
    Member
    Posted 3 years ago #

    The last update the tweetmeme button ran away, then the folks at tweet meme made a new version 2.1 that was to fix the install error but seems to have not worked either because even with 2.1 the button is still hiding.

    I don't know much but the code is calling for div but no css is being loaded to tell it what goes there.

    <div class="tweetmeme_button" style="float: right; margin-left: 10px;"><a class="tm_button" rel="&source=newsweird&style=normal&service_api=Local%2C+i.e.+http%3A%2F%2Fwww.newsweird.com%2F%3Fp%3D1234&space=1&hashtags=interesting,odd,Unusual&b=2" href="http://www.newsweird.com/2011010410/odd-and-bazarre/japanese-scientists-engaged-training-smart-bacteria-3457"></a></div>
    <div id="attachment_3458" class="wp-caption alignleft" style="width: 310px"><a rel="attachment wp-att-3458" href="http://www.newsweird.com/?attachment_id=3458"><img class="size-large wp-image-3458" title="smart-bacteria-darmflora-unusual-science" src="http://www.newsweird.com/wp-content/uploads/2011/01/smart-bacteria-darmflora-unusual-science-300x195.png" alt="Smart bacteria" width="300" height="195" />

    I will leave it active for a while if anyone needs to look at it in the source code to help find a solution. You wont find the code on the main page, you will have to look at a post page and view the source to see the tweet meme code. Weird News

    Help help help we really liked the button.

  5. weirdnews
    Member
    Posted 3 years ago #

    Hmmm or could it be the line in the tweetmeme.php file

    Where it calles for the get_post_status perhaps works with unpublished just not existing posts?

    * Generates the image button
    */
    function tm_generate_static_button() {
    	if (get_post_status($post->ID) == 'publish') {
            $url = get_permalink();
    		return
    		'<div class="tweetmeme_button" style="' . get_option('tm_style') . '">
    			<a href="http://api.tweetmeme.com/share?url=' . urlencode($url) . '">
    				<img src="http://api.tweetmeme.com/imagebutton.gif' . tm_build_options() . '" height="61" width="50" />
    			</a>
  6. Dave
    Member
    Posted 3 years ago #

    2.1 seems to be working for me. Came through immediately too.

  7. agentOOjoe
    Member
    Posted 3 years ago #

    I am having a problem with 2.1 where a tiny scroll bar loads right next to the button after it gets clicked, and it doesn't go away until you click somewhere else on the page.

    Any solutions?

  8. Trippa
    Member
    Posted 3 years ago #

    had to laugh at the change-log message:

    2.1

    Fix for WordPress installs which have a non-standard URL structure

    So it's my "non-standard" URL, Not that anything changed in the plug-in between versions then?

    Good to know.

  9. jamesmichie
    Member
    Posted 3 years ago #

    This problem persists for me.

    I have updated to 2.1 and my "footer" code is correct. When I look at the source code for my blog there is the code for the tweetmeme button but it is not displaying on my posts or pages.

    Please help.

    My blog is at http://jamesmichie.com/blog

    Regards
    James.

  10. agentOOjoe
    Member
    Posted 3 years ago #

    just got the update, thanks for the scroll bar fix!

  11. bstark
    Member
    Posted 3 years ago #

    Spent so much time on this you have no idea, trying to get this thing working again.

    Finally gave up and switched to the digg digg plugin.

  12. Dave
    Member
    Posted 3 years ago #

    These guys have a forum on their own site. My advice would be to ask questions there about it not working as they don't seem to be here.

  13. jamesmichie
    Member
    Posted 3 years ago #

    Now sorted, thanks to the peeps over at tweetmeme.

    Make sure you have the latest version installed.

    Make sure you have <?php wp_footer(); ?> just before the </body> tag in Footer.php

    And make sure that you don't have a plugin running that moves javascript around. My problem was that I was running the wp_minify plugin. It was minifying the javascript which was moving the <?php wp_footer(); ?> tag to the top of my source code. When the tweetmeme button looked for it in the footer it wasn't there.

    Solution? I turned off minification of javascript. The button returned instantly. You may have a similar issue.

    Regards
    James.

  14. ri-kun
    Member
    Posted 3 years ago #

    I have the same problem too...its hard to let go of this so I hope this will be fix.

  15. computerbrain25
    Member
    Posted 3 years ago #

    Make sure you have <?php wp_footer(); ?> just before the </body> tag in Footer.php

    Had to post and say I had the same problem, had to add the wp_footer() to my footer.php file. Thank you much for your help!

  16. kissmykitty
    Member
    Posted 2 years ago #

    Many thanks to computerbrain25 for posting the solution regarding adding wp_footer(); to footer.php - doing this immediately brought the TweetMeme button back to my posts on Mamahood.org. Thanks again! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags