WordPress.org

Ready to get started?Download WordPress

Forums

Tweetily - Tweet Your Posts Automatically!
[resolved] Not posting... (34 posts)

  1. raissuli
    Member
    Posted 2 years ago #

    Installed the plugin yesterday, and it's not posting automatically. Tested the "tweet now!" button several times, and it's working fine. So, I think it's not an authorization problem...

    Tried lots of different configs and variables, and nothing worked. When the contdown comes to zero, nothing happens (no tweets, and the clock stay in 0:0:0 permanently)...

    http://wordpress.org/extend/plugins/tweetily-tweet-wordpress-posts-automatically/

  2. mahodder
    Member
    Posted 2 years ago #

    I'm seeing the same thing.

  3. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    What web hosting company are you using?

    I'm looking at the code now to see what could cause that to hang there, it may be the function it runs to post is getting blocked, so I'll work out an alternate way too just in case which should fix it for you guys.

    If you could let me know the hosting provider that would be great!

    I worked out a 1and1 issue a couple of days ago so there are still some hosting providers with custom setups that I need to create some workarounds.

    Thanks for letting me know about the issue.

  4. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    Are you able to check the error logs on your server/hosting account? See if there's anything in there related to the plugin?

    I'm wondering if your server configuration prevents one of the functions from running which keeps the auto tweet from working.

    If that's the case, I can write up an alternate way that it also tries to get around that and let the plugin work.

  5. raissuli
    Member
    Posted 2 years ago #

    Flavio,

    I'm using DreamHost.

    Since I'm not a programmer, I don't know how to see/acess the logs. But If you guide me, I can do it for sure.

    If you prefer, We can chat through email, so we can have answers quicker: [ email redacted ]
    Thanks!

  6. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks! I just sent you an email.

  7. mahodder
    Member
    Posted 2 years ago #

    http://www.stormondemand.com - not seeing anything in the error logs or plugin log yet - will try another test.

    Running Apache, suPHP and modsec if that helps.

  8. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    Thanks for your patience. I found the issue and am testing a workaround on my own test account with Dreamhost.

    I will let you know once I've confirmed that it's working.

  9. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    Looks like my fix worked. I'll let it run just a couple more times to make sure everything cool and submit a fix to the WordPress repo.

    @mahodder if you email me (flavio@themana.gr) I can send you the manual fix so you can edit the plugin and get it working right away. Otherwise, as soon as WordPress has the update, your blog can check for updates and update it automatically that way.

  10. mahodder
    Member
    Posted 2 years ago #

    I can wait till it's live no big rush - will report back.

  11. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    No worries, I actually like taking care of these AS FAST AS POSSIBLE!

    I just submitted the fix so you can now download version 2.3.1 of the plugin and get the fix. My Dream host test account was caching the automatic update, so I had to delete the plugin and then install it again for the new version to appear.

    Anyway, here's the fix:

    Click plugins > Editor > select the file top-core.php

    Search for:

    $last = $wpdb->get_var("select option_value from wp_options where option_name = 'top_opt_last_update';");

    Replace line with:

    $last = $wpdb->get_var("select option_value from $wpdb->options where option_name = 'top_opt_last_update';");

    Save and you should be set.

  12. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    New code is now available on the WordPress code site and tested on multiple blogs! It should now be fixed.

  13. mahodder
    Member
    Posted 2 years ago #

    It did post but we had a flood of about 17 posts, instead of just 1.

  14. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    What's your Twitter account?

    Also, what plugins are you using?

    Do you have access to your WordPress database through PHPMyAdmin? I may need to look in there to see what values it has stored for the tweet time.

    Also, are you running version 2.3.1?

  15. raissuli
    Member
    Posted 2 years ago #

    If you want to follow my tests, I'm doing some with a new clean twitter account. firs 1 msg/minute, then 1/6min and now 1/30min (more or less).

    The account is @lojinha_QF

  16. mahodder
    Member
    Posted 2 years ago #

    I'm wondering if it's all the back ones from when I was doing the initial testing and they weren't posting? Does it store them somewhere before they post - so when the first real one fired all the others did too?

    Yes 2.3.1

  17. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    No, it shouldn't. But the easiest way to test is to look at what's in the WP_OPTIONS table for the plugin settings.

    Can you check and see what's listed for the variable next_tweet_time? It should have a long number for the time which it converts. If that's being cached some way (I thought it wasn't) it would cause the plugin to keep tweeting.

  18. mahodder
    Member
    Posted 2 years ago #

    1338584484 - I'll test again later to see if it happens again.

  19. mahodder
    Member
    Posted 2 years ago #

    Yeah it's still happening but it only seems to happen when you have a longer time set on the tweets, ie 2 mins works fine - while 5 hours posted 3 times: https://twitter.com/#!/mark_test

    Just W3TC Cache active with Akismet

  20. raissuli
    Member
    Posted 2 years ago #

    I'll try this in my test account too. I'm still using short periods. I'll try 3 hours.

  21. raissuli
    Member
    Posted 2 years ago #

    Here are the plugins I am using:

    Akismet
    All in one Favicon
    All in One SEO Pack
    Authors Widget
    Auto Post Thumbnail
    Banner Wizz
    Contact Form Plugin
    DB Cache Reloaded Fix
    Efficient Related Posts
    Facebook Members
    Feather
    flickrRSS
    Google Affiliate Network widget
    Google XML Sitemaps
    Jetpack by WordPress.com
    Jetpack by WordPress.com
    Network Publisher
    Really Simple Gallery Widget
    Revision Control
    Simply Show IDs
    Social Sharing Toolkit
    Tweetily
    WordPress Backup to Dropbox
    WordPress Importer
    WP-DBManager
    WP-PageNavi
    Wp Pagenavi Style
    WP Super Cache
    WPtouch
    WP Widget Cache

  22. Flavio Martins
    Member
    Plugin Author

    Posted 2 years ago #

    Any update on that? It looks like it's posting, but I don't know what settings you have set.

    If it's not posting right, I'd like to look at the database on that test site to see the settings it has in there and see what I need to change in the code to make sure that it correctly updates the settings.

  23. dustin321
    Member
    Posted 2 years ago #

    Hi,
    I am using Tweetily and it's not working. No auto tweets workg. Also, when I manually try and tweet, I get an error message:
    "Tweet 0 : Oh no! Something went wrong. Please try again."

    I am using godaddy hosting.
    I have Thesis Themes - Smart Skin theme.
    I have the following plugins. Although, I deactivated every single one of them, and it still didn't work.

    1-click Retweet/Share/Like
    Add Post Footer
    Akismet
    Blubrry PowerPress
    Hello Dolly
    Jetpack by WordPress.com
    Raw HTML
    Tweetily
    Viper's Video Quicktags
    WordPress Database Backup
    WordPress Importer
    Yet Another Related Posts Plugin

    Please help! Thanks so much

  24. mobilelife
    Member
    Posted 1 year ago #

    I'm having the same problem. Also, when I try to authenticate with Twitter the "Sign In With Twitter" button just links to the current page. So if I click on it the page just reloads.

  25. AliciaJay
    Member
    Posted 1 year ago #

    I'm having the same problem as well. I am authorized and connected. When I choose my settings, click "update" and then "tweet now" I either get a message stating "Oh no!Something went wrong. Please try again!" or I get redirected back to my site.

    I am using Thesis theme and Bluehost. Thank you!!

  26. Flavio Martins
    Member
    Plugin Author

    Posted 1 year ago #

    I've just updated the plugin to version 3.2. It should be available for you to update and then re-install. That should take care of some of the issues that you're seeing.

    If not, let me know. I may have to log in and see what your WordPress site is doing behind the scenes to see why it's not working.

  27. zensoft
    Member
    Posted 1 year ago #

    I activated the plugin, among other things, nice idea, but when I try to run it tells me this item:

    "No post found to tweet. Please check your settings and try again."

    the settings are correct, that is a choice of 50 posts.

  28. zensoft
    Member
    Posted 1 year ago #

    I managed to solve the problem.
    If only one post I have one or more category and is disabled the plugin does not send the Tweet automatically.
    example:
    the post has category A and B, both must be accepted for the Tweet, if the category A or category B is excluded, the tweet will not be sent.

    Great plugin, congratulations.

    ps. I follow you on twitter ;)

  29. Thrills 2 Chills Travel
    Member
    Posted 1 year ago #

    I have GoDaddy hosting and installed this program on 11/29/12 for it sounds like this is what I would like to use. I would like to have my Twitter posts auto post to my WP homepage site. I do not have any active feeds at this time cause I am building my new site. No error messages shown but the program is just not working. Is there further instructions you have on installation?

    Please help, thank you.

    dev.thrills2chillstravel.com

  30. Sreejesh
    Member
    Posted 1 year ago #

    Hello flavio, I experience the same issue here on techgyo.com

    When I click on "Tweet now" I get this error: "Tweet 0 : Oh no! Something went wrong. Please try again."

    Here's the screenshot : http://www.diigo.com/item/image/1h1yd/4umi

    However when I try the another plugin called "tweet old post" with almost same interface and functions the auto tweet works but the contributor level users are unable to upload any media files in the post.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic