WordPress.org

Ready to get started?Download WordPress

Forums

Revive Old Post (Former Tweet Old Post)
[Plugin: Tweet Old Post] Plugin not automatically posting tweets (44 posts)

  1. jsgispert
    Member
    Posted 1 year ago #

    3.3.3 installed, it works fine so far. Could you please explain how "Random Interval" works? Does it accept non integer values (i.e. 0.1)? Thanks.

  2. MCM
    Member
    Posted 1 year ago #

    I cannot SAVE my settings nor do anything because I "dont have permissions". I really dont know what to do.

  3. samisam
    Member
    Posted 1 year ago #

    Same issue here.. the plugin does not auto post. dude. come on, figure something out. atleast follow through on your work and respond to people appropriately

  4. mohamed_am83
    Member
    Posted 1 year ago #

    Hi!

    I've installed TOP and experienced the same problem: auto-posting didn't work! I had a look at the code and didn't find any part that will run periodically, so I added the following to tweet-old-post.php (right below the define's), works for me!

    register_activation_hook(__FILE__, 'top_activation');
    register_deactivation_hook(__FILE__, 'top_deactivation');
    add_action('top_hourly_event', 'top_hourly');
    
    function top_activation() {
        wp_schedule_event( time(), 'hourly', 'top_hourly_event');
    }
    
    function top_deactivation() {
        wp_clear_scheduled_hook('top_hourly_event');
    }
    
    function top_hourly() {
        $interval = get_option('top_opt_interval');
        // get the # hours since the beginning of the current year
        $h = floor( (time() - strtotime('1-1-' . date ( 'Y', time()) )) / 60 ) ;
        if ($h % $interval == 0)  top_opt_tweet_old_post();
    }

    cheers!
    -Mohamed

  5. MCM
    Member
    Posted 1 year ago #

    I get errors trying that.

    "You do not have sufficient permissions to access this page. " I still get this issue.

    Anbody get there's to work?

    My admin page for the plugin says if the current url is not correct go to:
    /wp-admin/admin.php?page=Tweetily

    I do that but get the permission error. Only a few users and we all admin. ??

  6. rushtips
    Member
    Posted 1 year ago #

    If you get an error when trying to authorize, try Chrome. Worked for me.

  7. indiefan23
    Member
    Posted 1 year ago #

    So are you going to fix this or not? Maybe I’ll try the other plugins taht do this

  8. mekemoke
    Member
    Posted 1 year ago #

    Hi,
    I have same issue so tried to look at the code.
    Seems to be due to the fact that there was a "top_opt_last_update" apparently is not updated.

    Please try to change the top-admin.php as described below.
    And click [Update Tweet Old Post Options] button.

    before:

    //successful update message
                print('
    			<div id="message" class="updated fade">
    				<p>' . __('Tweet Old Post Options Updated.', 'TweetOldPost') . '</p>
    			</div>');

    after:

    // *** add trigger
               update_option('top_opt_last_update', time());
    
                //successful update message
                print('
    			<div id="message" class="updated fade">
    				<p>' . __('Tweet Old Post Options Updated.', 'TweetOldPost') . '</p>
    			</div>');
  9. Ajay Matharu
    Member
    Posted 1 year ago #

    have resolved this issue in new update. Please update the plugin.

  10. mekemoke
    Member
    Posted 1 year ago #

    Hi Matharu,
    I love plugin that you produced 'Twitter Old Post'.

    I translated to Japanese, to be able to run in multibyte languages​​, I have modified the code a little.

    Can I help you to update as a multilingual version?

    Source file:
    http://mekemoke.jp/downloads/tweet-old-post_4.0.4-ja.zip

    It contains the TweetOldPost-ja.po, TweetOldPost-ja.mo ;)

  11. MCM
    Member
    Posted 1 year ago #

    Still does not work for me :(

    1. If I access the ADMIN page it has old url

    2. I then enter in NEW URL and get the error that I do not have permissions etc. I am Admin user.

  12. roadie
    Member
    Posted 1 year ago #

    I have just upgraded to 4.0.4. And now posting automatically works. Thanks.

  13. sergeytru
    Member
    Posted 1 year ago #

    I have 5 WP sites shared one Twitter account. Unfortunately only 1st registered one works with this plugin, all others reject twitter app authorization. Is there a way to rename the plugin twitter application to get personal copy for each site?

  14. sergeytru
    Member
    Posted 1 year ago #

    After updating settings it's working with one twitter app! Cool!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic