WordPress.org

Ready to get started?Download WordPress

Forums

Tumblr Importer
Nothing is Imported (11 posts)

  1. Navjot Singh
    Member
    Posted 2 years ago #

    I am trying to import my Tumblr blog since past 2 days and nothing gets imported. I click Refresh View and sometimes this error is shown:

    Problem communicating with Tumblr, retrying later.

    I tried importing a second blog too but same thing happens.

    http://wordpress.org/extend/plugins/tumblr-importer/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Use the clear credentials button and start over. You can get this sort of error if you have put in incorrect information.

    You can also get this sort of error if your server is firewalled and blocked from communicating with tumblr's servers. Talk to your webhost about that, or try the import on a local test install first.

  3. Navjot Singh
    Member
    Posted 2 years ago #

    Done that too. Regarding incorrect information I don't think that's the case because I can see the list of blogs under my account in the Import screen.

    Installed on localhost as well and still I am getting the same error.

    Also I get this warning on localhost:

    Warning: fopen(http://localhost/www/blogsvn/wp-cron.php?doing_wp_cron=1323950062) [function.fopen]: failed to open stream: HTTP request failed! in E:\server\xampp\htdocs\www\blogsvn\wp-includes\class-http.php on line 877.

  4. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 2 years ago #

    Unless your localhost install resides at http://localhost/www/blogsvn/ , you've set up WordPress wrong to begin with. The wp-cron process does a lot more of WP stuff than this importer. Scheduled posts, enclosure handling, etc.. These are wp-cron functions.

  5. Navjot Singh
    Member
    Posted 2 years ago #

    My Localhost install does reside at http://localhost/www/blogsvn/

  6. Navjot Singh
    Member
    Posted 2 years ago #

    Got the word from Webhost. Everything is fine at their end and it is able to connect to the Tumblr blog. Curl was not enabled on Localhost. Enabled it and I am still getting the same error.

  7. Navjot Singh
    Member
    Posted 2 years ago #

    Turning off the custom domain feature worked. It has imported all the posts now though a lot of images are still not loaded. You should add this in a FAQ or somewhere in the Plugin readme.

  8. Slaven
    Member
    Posted 2 years ago #

    Hey, I've got the same error:

    Warning: Cannot modify header information - headers already sent by (output started at /srv/disk5/xxxxxx/www/xxxxxxxx.com/wp-includes/class-http.php:877

    I'm on Awardspace. Where did you turned off custom domain feature?

    Thanks

  9. Slaven
    Member
    Posted 2 years ago #

    I just switched DEBUG to false and it works now, hopefully it will continue to work :)

  10. deadhippo
    Member
    Posted 2 years ago #

    @Slaven - he switched off custom domain in the Tumblr dashboard.

  11. Slaven
    Member
    Posted 2 years ago #

    OK, Tnx

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic