WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Plugin tried to edit .htaccess but failed error ... (10 posts)

  1. katmoody
    Member
    Posted 1 year ago #

    I've already asked Hostgator to address this once, which didn't work, and am awaiting hearing from them again. Basically, I am getting this error saying that W3TC can't write to the .htaccess file. The permissions are set properly but I think the problem is that this is a reseller account and it's reading the root level .htaccess file as part of the plugin (I think?)

    Here's the message that appears at the top of the dashboard:

    W3 Total Cache Error: The plugin tried to edit, /.htaccess, but failed. Files and directories cannot be modified. Please review your file permissions. A common cause is .htaccess and /home/katscafe/public_html/Cafe/wp-content having different ownership or permissions.  
    
    File: /home/katscafe/public_html/Cafe/wp-config.php File permissions are 644 File owner: katscafe:katscafe
    File: /.htaccess File permissions are 0, however they should be 644. File owner: root:root
    Directory: /home/katscafe/public_html/Cafe/wp-content File owner: katscafe:katscafe
    Owner of current file: katscafe:katscafe
    The files and directories have different ownership, they should have the same ownership.

    This is occuring on a site I'm in the process of rebuilding (so I'm using the temporary URL until I'm ready to direct folks to this site):

    http://173.192.120.157/~katscafe/Cafe

    Thanks for any help you can give me - I'll re-post here if either I or Hostgator is able to solve the problem before I hear back (and how!).

    Kat

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. katmoody
    Member
    Posted 1 year ago #

    Hostgator says it isn't a problem they can solve so anyone else have ideas? I really wanted to use this caching plugin rather than a different one. Thanks.

  3. Laca
    Member
    Posted 1 year ago #

    Try setting permissions to 777 temporarily

  4. katmoody
    Member
    Posted 1 year ago #

    Unfortunately that didn't have any effect. I'm pretty sure the answer lies in addressing that .htaccess file in the root directory it's reading -- it shouldn't be reading that one at all as that is part of another account. :(

  5. heni1022
    Member
    Posted 1 year ago #

    do you have access to that root directory?
    is this a reseller account through hostgator?

  6. traffas
    Member
    Posted 1 year ago #

    Any luck with this? I'm experiencing the same problems.

  7. katmoody
    Member
    Posted 1 year ago #

    I wasn't able to find an answer but it went away about a week later ... :(

  8. lleemon
    Member
    Posted 10 months ago #

    katmoody - what version of wp and w3 total cache do you have working? We are using wp 3.5.1, the w3 version was 9.3 when error started, tried going back but that didn't help either.

  9. katmoody
    Member
    Posted 9 months ago #

    I've since switched to a different server but have helped a few different clients successfully use w3 (the latest version) along with the newest version of WP ... so far I haven't run into this problem again. Just updating so you don't think I forgot about this post :D

  10. Christopher
    Member
    Posted 9 months ago #

    My company has also had the same issue with W3TC that you describe and we have narrowed the problem down to using a temporary URL. The issues resolved themselves when we assigned a domain to each site.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic