WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] Parsing? (7 posts)

  1. vanhass
    Member
    Posted 1 year ago #

    Hi,
    I've noticed that every instance of a word is tranlated through the entire site, so 'thank you' is translated on every page throughout the site from one translation.
    This has caused a few problems, so I've 'parsing' can control this, but I'm notwhere to start. Could I also ask again if there is a manual or comprehensive readme I could learn from?
    Thanks again

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

  2. vanhass
    Member
    Posted 1 year ago #

    Correction: 'This has caused a few problems, so I've read that 'parsing' can help, but I'm unsure where to start?'
    Thanks

  3. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Hello There,

    Take a look at the comments on the top of the file parser.php

  4. vanhass
    Member
    Posted 1 year ago #

    Hi,
    I just don't have the skills to know what I'm looking at? I see for example:
    require_once("constants.php");
    OR:
    define('PUNCT_BREAKS', TRUE); // Will punctiations such as , . ( and such will break a phrase

    I'm afraid you'll have to be specific. If you can provide the line I need I'll try to navigate through the problem from there.
    Thanks again

  5. Ofer Wald
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Must say that this is not an official feature, and must be taken with a grain of salt. but you are seeing the "define" lines, right?

    You need to change TRUE to FALSE, depending on your needs.
    For example:
    "Hello, World" will currently break into "hello" and "world"
    if you will define punct breaks to false, it will be considered as one segment

    Good luck

  6. vanhass
    Member
    Posted 1 year ago #

    Thanks. I'll work through your suggestions. Appreciate your time with this. Thanks again.

  7. hgezim
    Member
    Posted 1 year ago #

    I tried setting:

    define('PUNCT_BREAKS', TRUE) to FALSE but nothing changes.

    I even deleted automatic translations. How do I go about "resetting transposh?"

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.