WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] Not translating... (14 posts)

  1. pngised
    Member
    Posted 2 years ago #

    I did not change anything, but it stop working 2 days ago.
    Now it doesn't change language and don't show translations....

    I deactivate WP Super Cache in case there was a conflict. But nothing changed, still not working.

    I activate wp debug, but I get no error. So I don't understand...

    http://wordpress.org/extend/plugins/transposh-translation-filter-for-wordpress/

    Here the link to blog: http://www.ilcommercialethesalesman.com

  2. enivid
    Member
    Posted 2 years ago #

    I've got the same problem.

  3. pngised
    Member
    Posted 2 years ago #

    FYI

    In my case it starts working again after the latest WP updates.

  4. enivid
    Member
    Posted 2 years ago #

    What do you mean by the latest WP updates? I am running WordPress 3.3.2.

  5. pngised
    Member
    Posted 2 years ago #

    I mean WP 3.3.2
    I got the problem when I was 3.3.1.

    I also removed all the automatic translation an let the plugin rebuild them

  6. enivid
    Member
    Posted 2 years ago #

    Thanks for the tip, but how do you trigger the plugin to rebuild automatic translations?

  7. pngised
    Member
    Posted 2 years ago #

    In settings > Transposh look for the buttons/link scrolling down the page.

    You can see three links/button:
    - Remove all the automatic translation
    - Remove all the automatic translation older than 14 days
    - Correct errors of previous versions...

    On the right column, there is the "Translate all now" button.

    If you don't see it, open the "screen settings" in top right of the page and activate all you need.

    Hope it is clear enough.

  8. enivid
    Member
    Posted 2 years ago #

    Sorry for bugging you, but what translation engine did you use - Google or Bing? And did you enter any API keys?

  9. pngised
    Member
    Posted 2 years ago #

    Hi enivid.

    I use Google without API.

  10. enivid
    Member
    Posted 2 years ago #

    For some reason nothing of this worked for me. Redoing the auto translation results in untranslated pages when language is switched to something different than English. Either there is a bug, or I am doing something wrong and have no idea what it is.

  11. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    @pngised - happy to hear things worked out
    @envivid - a link to your site can be really helpful ;)

    Have fun,

  12. enivid
    Member
    Posted 2 years ago #

  13. Ofer Wald
    Member
    Plugin Author

    Posted 2 years ago #

    @enivid, the database tables does not exist on your site, you need to create them manually or delete the transposh_db_version option from wp_options table.

    The latest svn snapshot also has a fix for this in the maintenance button

    Good luck

  14. enivid
    Member
    Posted 2 years ago #

    Thanks! That worked!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic