WordPress.org

Ready to get started?Download WordPress

Forums

Transposh WordPress Translation
[resolved] [Plugin: Transposh - translation filter for wordpress] Transposh not working in "yellow" l (9 posts)

  1. mediopirzel
    Member
    Posted 3 years ago #

    Hi team.
    First of all, you have the most useful plugin of all times.
    We are using your plugin in our site. The only problem that we find is that "yellow" languages are not working properly.
    When you press "Translate All" it seems it works, and visibility rules of flag icons are showed properly, and redirects to the correct page, but the content of the site is not translated for this language.
    If you change the yellow to green language, all works OK.

    Our wordpress is an Spanish installation and this plugins:
    Breadcrumb NavXT
    Fancy Gallery
    Google Analytics for WordPress
    Google XML Sitemaps
    Picasa Express x2
    Quoted Comments Widget
    Sharedaddy
    Ultimate Taxonomy Manager
    White Label CMS
    WPaudio

  2. Ofer Wald
    Member
    Plugin Author

    Posted 3 years ago #

    Hello,

    thanks for the compliments ;)

    Yellow languages are limited in access to just translators, and not everything happens there, what are your expectations?

  3. mediopirzel
    Member
    Posted 3 years ago #

    Hello Ofer,

    I thought that if a language marks in yellow, translators, might view the translated texts.
    My problem is that "Administrator" and "Editor" roles don't see texts translated.
    As an administrator in front page, you see the icon that is in yellow, wen you press the icon, redirects to the correct url (ex: mywebsite/es or mywebsite/en) but text is not translated.

    Sorry but English is not my first language, nor the second. :)

  4. Ofer Wald
    Member
    Plugin Author

    Posted 3 years ago #

    Thanks,

    Sorry for the late reply

    Will check this out, however this is not a very common use case.

  5. mediopirzel
    Member
    Posted 3 years ago #

    Hello Ofer,

    Thank you for the new 0.7.2. version.
    I've been testing with an english fresh installation with same results:
    Translators can't see or translate translatable languages (the yellow ones).

  6. Ofer Wald
    Member
    Plugin Author

    Posted 3 years ago #

    I will do some testing on this for the next version, probably some regression that crept in, and I would guess it will be a few lines patch

    :(

    Thanks for making me aware of this

  7. Ofer Wald
    Member
    Plugin Author

    Posted 3 years ago #

    Hello,

    This has been fixed, tested and committed to our trac
    http://trac.transposh.org/changeset/623

    thanks for the report!

  8. mediopirzel
    Member
    Posted 3 years ago #

    Hello,

    It works! Thank You very much.

    I wrote a piece of code that allows editors to insert easily "no_translate" classes on the tinyMCE. I want to share this code with the transposh community because I think is useful. Where is the best place to uplad this code? This forum, your website... ?

  9. Ofer Wald
    Member
    Plugin Author

    Posted 3 years ago #

    Hi,

    Regarding the code you suggested, please create a ticket in our trac and add the patch there, you can also see that we have added a shortcode recently, so it might be easier to use that.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic